Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#7543 closed defect (wontfix)

adjusting the viewability of the UI for overscan

Reported by: brian@… Owned by: stuartm
Priority: major Milestone: unknown
Component: MythTV - User Interface Library Version: 0.22
Severity: medium Keywords:
Cc: Ticket locked: yes

Description

Currently, if one needs to reduce the size of the UI in order to have it viewable within the boundaries set by overscan, one actually winds up reducing (and likely offsetting) the size of the UI widget/window. This can be done conveniently through the Screen Setup Wizards tool.

The problem is however, if the UI is being viewed on a screen with gnome panel(s), unless the UI is exactly the size of the screen on which it's being displayed, it gets displayed "under" the panels.

It would appear that gnome has some logic by where if a window is the same size as the screen it's running on (i.e. "full screen") the window is placed on top of the panels, hiding them. If the window is however only one pixel (or more) smaller than the screen, either vertically or horizontally, then the window goes under the panels.

It seems the solution to this is to not reduce the size of the actual window that the UI is being displayed on when compensation for overscan is being requested, but to keep the window the same size and just scale down the area on that window being used to draw the UI.

Without overscan, the effect of this would be to have a "border" around the space that the UI is active in rather than having the UI stretch right to the window edges.

I hope this explanation was clear. I'd be happy to try to clarify if not.

Change History (5)

comment:1 Changed 10 years ago by danielk

Resolution: wontfix
Status: newclosed

There must be some way to tell gnome to get out of the way; if not, there are plenty of other window managers.

comment:2 in reply to:  1 Changed 10 years ago by anonymous

Replying to danielk:

There must be some way to tell gnome to get out of the way;

There is. You make your window the size of the screen.

if not, there are plenty of other window managers.

Oh yeah. So we'll just throw the baby out with the bathwater will we?

Rather than telling everyone who uses gnome to just use something else, why not work with it and tell it to get out of the way in the manner that it has set itself up to be told -- namely making your window the size of the screen and allowing the UI within that window to be scaled inward, away from the window edges?

Why is this being dismissed out of hand and not even being considered?

comment:3 Changed 10 years ago by anonymous

Additionally, I would submit that you want some amount of space between the window edge and the UI edge as the overscan on many TVs is quite sloppy (not straight and square) and reducing the window edge to the same size as the viewable portion of the overscan usually leaves portions of the overscan (i.e. at the border) not filled in by UI.

comment:4 Changed 10 years ago by robertm

Ticket locked: set

comment:5 Changed 10 years ago by stuartm

It's being dismissed because the Gnome behaviour is broken, it's ignoring the fullscreen window flag.

Note: See TracTickets for help on using tickets.