Opened 10 years ago

Closed 9 years ago

#7584 closed defect (Duplicate)

spectrum visual display issues on widescreen displays

Reported by: anonymous Owned by: paulh
Priority: minor Milestone: unknown
Component: Plugin - MythMusic Version: Master Head
Severity: low Keywords: spectrum
Cc: Ticket locked: no

Description

The spectrum visualizer in mythmusic seems to not handle various aspect ratios of displays properly. The display worked correctly on a 4:3 display, but stopped working correctly when I switched to a 16:9 display. Rather than showing the full spectrum, it shows the leftmost and second bar correctly, but all additional bars to the right of the second simply match the second bar. The problem seems independent of resolution at least at 1080p and 720p. This is a longstanding issue (I've seen it since at least 0.20, maybe 0.19).

Change History (3)

comment:1 Changed 10 years ago by stuartm

Owner: changed from stuartm to paulh
Status: newassigned

comment:2 Changed 10 years ago by paulh

Version: 0.22Trunk Head

I can still reproduce this in trunk.

comment:3 Changed 9 years ago by paulh

Resolution: Duplicate
Status: assignedclosed

Duplicate of #9476 which has a patch. The patch doesn't actually fix the problem for me but may give a clue as to a proper fix.

Note: See TracTickets for help on using tickets.