Opened 10 years ago

Closed 10 years ago

#7667 closed defect (invalid)

Mythgallery (0-22-fixes) fails to compile on windows

Reported by: Jonathan Martens <jonathan@…> Owned by: Nigel
Priority: minor Milestone: 0.22
Component: Ports - Windows Version: 0.22
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Mythgallery fails to compile on windows against release-0-22-fixes with the following error:

cd mythgallery/ && make -f Makefile
make[1]: Entering directory `/u/mythtv/mythplugins/mythgallery'
cd mythgallery/ && make -f Makefile
make[2]: Entering directory `/u/mythtv/mythplugins/mythgallery/mythgallery'
g++ -c -march=pentium4 -g -Wall -Wno-switch -Wpointer-arith -Wredundant-decls -W
no-non-virtual-dtor -funit-at-a-time -D__STDC_CONSTANT_MACROS -fomit-frame-point
er -O3 -fomit-frame-pointer -DNDEBUG -frtti -fexceptions -mthreads -Wall -DUNICO
DE -DQT_LARGEFILE_SUPPORT -DUSING_MINGW -D_GNU_SOURCE -DPREFIX="/U/mythtv/build/
" -DMMX -Di386 -D_FILE_OFFSET_BITS=64 -DQT_THREAD_SUPPORT -DQT_DLL -DQT_NO_DEBUG
 -DQT_PLUGIN -DQT_SQL_LIB -DQT_XML_LIB -DQT_OPENGL_LIB -DQT_GUI_LIB -DQT_NETWORK
_LIB -DQT_CORE_LIB -I'../../../../Qt/4.5.3/include/QtCore' -I'../../../../Qt/4.5
.3/include/QtNetwork' -I'../../../../Qt/4.5.3/include/QtGui' -I'../../../../Qt/4
.5.3/include/QtOpenGL' -I'../../../../Qt/4.5.3/include/QtXml' -I'../../../../Qt/
4.5.3/include/QtSql' -I'../../../../Qt/4.5.3/include' -I'/U/mythtv/build//includ
e' -I'/usr/include' -I'/U/mythtv/build/' -I'/U/mythtv/build//include/mythtv' -I'
/U/mythtv/build//include/mythtv/libmythdb' -I'/U/mythtv/build//include/mythtv/li
bmythui' -I'/U/mythtv/build//include/mythtv/libmyth' -I'/U/mythtv/build//include
/mythtv' -I'../../../../Qt/4.5.3/include/ActiveQt' -I'.' -I'../../../../qt/4.5.3
/mkspecs/win32-g++' -o imageview.o imageview.cpp
imageview.cpp: In member function 'void ImageView::UpdateLCD(const ThumbItem*)':

imageview.cpp:155: error: 'class LCD' has no member named 'setFunctionLEDs'
imageview.cpp:155: error: 'FUNC_PHOTO' was not declared in this scope
imageview.cpp:159: error: 'class LCD' has no member named 'setFunctionLEDs'
imageview.cpp:159: error: 'FUNC_PHOTO' was not declared in this scope
make[2]: *** [imageview.o] Error 1
make[2]: Leaving directory `/u/mythtv/mythplugins/mythgallery/mythgallery'
make[1]: *** [sub-mythgallery-make_default] Error 2
make[1]: Leaving directory `/u/mythtv/mythplugins/mythgallery'
make: *** [sub-mythgallery-make_default] Error 2
bash-3.1$ 

Change History (4)

comment:1 Changed 10 years ago by Jonathan Martens <jonathan@…>

Looking through the changes for mythgallery I think this is caused by [22477].

comment:2 in reply to:  1 ; Changed 10 years ago by anonymous

Replying to Jonathan Martens <jonathan@…>:

Looking through the changes for mythgallery I think this is caused by [22477].

[22477] was not applied to 0.22-fixes. It seems like youre trying to build trunk mythplugins against 0.22-fixes mythtv.

comment:3 in reply to:  2 Changed 10 years ago by Jonathan Martens <jonathan@…>

Replying to anonymous:

It seems like youre trying to build trunk mythplugins against 0.22-fixes mythtv.

Oops, you are right, it turned out I was missing a folder in mythburn that made the switch fail, after fixing that and a manual switch on mythplugins it seems to compile OK, so please close this ticket.

comment:4 Changed 10 years ago by stuartm

Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.