Opened 11 years ago

Closed 10 years ago

Last modified 10 years ago

#7698 closed defect (worksforme)

A/V Sync Broken with HD-PVR and Dish Network

Reported by: bhuffman@… Owned by: danielk
Priority: minor Milestone: unknown
Component: MythTV - Recording Version: unknown
Severity: medium Keywords:
Cc: Ticket locked: no

Description

It appears that somewhere around the 17th of November, a problem cropped up with Dish Network and the HD-PVR recorder so that the video is just a little faster than the audio. So, by 10-15 minutes into every recording it's completely unbearable to watch (lips move obviously before the voice, etc. etc.). I notice that Hauppauge has released an update, but it says "Windows driver only" and I've already tried connecting a windows laptop to my HD-PVR and applying the update and it doesn't seem to have any effect on mythtv.

I'm attaching a 400kB snippit of a file that exhibits this behavior. It's starting from the beginning, so it won't be as obvious, but perhaps it can help.

Attachments (1)

output.mpg (400.0 KB) - added by bhuffman@… 11 years ago.

Download all attachments as: .zip

Change History (4)

Changed 11 years ago by bhuffman@…

Attachment: output.mpg added

comment:1 Changed 10 years ago by danielk

Resolution: worksforme
Status: newclosed

I don't see this with current recordings. If you still see it please provide more info, like what type of audio capture you are using, the hd-pvr firmware and the DishNet? receiver you are using.

comment:2 Changed 10 years ago by bhuffman@…

I still see this. I'm using SPDIF audio and Component video capture. I installed the hdpvr_1.5.6 from Hauppauge's site (using a Windows laptop) which I think contains both the firmware and driver for windows. When I boot into Fedora 12, kernel messages contain this line:

hdpvr 1-3:1.0: untested firmware version 0x12, the driver might not work

I have a Dish Network VIP-211 receiver.

I'm running on Fedora 12 with latest updates and MythtV SVN r23117

comment:3 Changed 10 years ago by Jim Stichnoth <stichnot@…>

I experienced this as well, using a Dish VIP-211 outputting 720p/AC3, firmware 1.5.6, SPDIF audio, and component video. This combination sometimes leads to recordings where the video framerate is 60fps but the audio is 59.94fps. This can be seen by running "mplayer -vo null -ao null -frames 10 -identify filename.mpg | grep FPS". I managed to fix this by downgrading the firmware to 1.0.5.301 and changing the VIP-211 audio output to PCM only (perhaps only one of those steps would be sufficient).

I tried reading through the hdpvr driver, and given the interface, I can't see any way this is a myth or linux driver problem. I'm almost certain it's a firmware problem.

Note: See TracTickets for help on using tickets.