Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#7798 closed defect (invalid)

Fedora 12 no sound on playback of recordings mythfrontend

Reported by: dhighley@… Owned by: Isaac Richards
Priority: minor Milestone: 0.22
Component: MythTV - General Version: 0.22
Severity: medium Keywords: Fedora 12 no sound
Cc: Ticket locked: no

Description

When first installed Fedora 12 with Mythtv the sound worked fine. After updates, wished I could pin down which one, to Fedora and Mythtv the sound quit working on playback through the mythfrontend application for recordings or live TV. I tried the reported fix of setting the mixer to ALSA:front but it did not fix the issue for me. I'm not sure what all component versions are needed for this report: kernel-2.6.31.6-166.fc12.x86_64 mythtv-0.22-2.fc12.x86_64

I ran the front end in a terminal window but it did not provide any information nor have the log files. Playing recordings with other players confirm that there is no issue with the content of the recording.

Change History (3)

comment:1 Changed 10 years ago by stuartm

Resolution: invalid
Status: newclosed

You should attempt to determine if this a mythtv bug on the mythtv-users mailing list first. Nothing in your descriptions suggests this is a bug in mythtv as opposed to a bug in Fedora or a configuration problem.

comment:2 Changed 10 years ago by anonymous

hint: Fedora 12 uses pulseaudio by defualt. either uninstall/disable pulse audio somehow or run this command in yor shell before starting your frontend from the same terminal: export EXPERIMENTALLY_ALLOW_PULSE_AUDIO=1

comment:3 Changed 10 years ago by anonymous

That works, and if you rename the /usr/bin/mythfrontend application to mythfrontend.orig create the following script: #!/bin/sh EXPERIMENTALLY_ALLOW_PULSE_AUDIO=1 exec /usr/bin/mythfrontend.orig

Make the script executables by chmod +x mythfrontend. It will work from the menu pull down as well.

Note: See TracTickets for help on using tickets.