Opened 11 years ago

Closed 11 years ago

#7877 closed defect (duplicate)

Never record error

Reported by: luca.ingianni@… Owned by: gigem
Priority: minor Milestone: 0.22
Component: MythTV - Scheduling Version: unknown
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Basic situation:
It seems my database got corrupted (still not sure how or why). I've tried using mythweb's database cleaning tools to clean up the corruption, but it seems it didn't work, or at least not entirely. Some specific planned recordings are not recorded. In one case, at least an entry in the recorded programs list is created (but apparently not even a single byte of recording data written), in the other, not even that. This channel can be watched live without problems, and until a few days ago, these very recording definitions worked.

Specific situation:
I tried to to further clean up the database: I noticed there was a planned recording in my listing that seemingly didn't have a channel attached to it, so I tried to delete it in mythweb (button "never record"). The reaction to my input was this backtrace.

I've attached a screenshot of the planned recordings with what clearly seem to be broken database entries.

Since all defective planned recordings seem not to be deleteable, I will now plunge into the database and remove the offending rows.

Expectations:
1) The database should not become corrupted at all (gee, who'd have thought :) ), and especially not seemingly without cause
2) Recordings (particularly corrupted ones) should always be deletable
3) the database checker should discover (and ideally also fix) the broken rows

Attachments (2)

mythtv-database-bug.png (150.2 KB) - added by luca.ingianni@… 11 years ago.
screenshot of planned recordings listing
mythtv-backtrace.zip (2.3 KB) - added by luca.ingianni@… 11 years ago.
backtrace as provided by mythweb (zipped to get it past trac)

Download all attachments as: .zip

Change History (3)

Changed 11 years ago by luca.ingianni@…

Attachment: mythtv-database-bug.png added

screenshot of planned recordings listing

Changed 11 years ago by luca.ingianni@…

Attachment: mythtv-backtrace.zip added

backtrace as provided by mythweb (zipped to get it past trac)

comment:1 Changed 11 years ago by Dibblah

Reporter: changed from anonymous to luca.ingianni@…
Resolution: duplicate
Status: newclosed
Summary: luca.ingianni@gmail.comNever record error

Duplicate of #7502.

Note: See TracTickets for help on using tickets.