Opened 10 years ago

Closed 10 years ago

#7947 closed defect (worksforme)

broken VDPAU playback after commit #23238

Reported by: craftyguy@… Owned by: markk
Priority: minor Milestone: 0.23
Component: MythTV - Video Playback Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

After upgrading to 23238, I am no longer to play back video using VDPAU.

Attachments (4)

-v playback.log (12.2 KB) - added by craftyguy@… 10 years ago.
output from -v playback
vdpau-playback2.log (16.1 KB) - added by craftyguy@… 10 years ago.
Here is a new playback log, I'm definitely running the latest SVN now. My video card is a 8400GS G98, nvidia-settings reports 512MB RAM. This same setup has played HD content using VDPAU before flawlessly in the past. I've tried tweaking the vdpaubuffersize from the default of 17 to 12, to 24. It fails every time.
vdpau.log (44.8 KB) - added by Simon Kenyon <simon@…> 10 years ago.
here is a log as requested. this is from svn 23242 on an amd athlon 64 x2 on an asustek M3N78-EM motherboard using the on-board nvidia geforce 8300
vdpau2.log (19.0 KB) - added by craftyguy@… 10 years ago.
Updated to 23357, rolled nvidia driver back to 190.53, and set 'normal' VDPAU profile (which worked in the past) with default buffer count, and still no go. I'm getting the same results with recorded TV (though live TV works fine)

Download all attachments as: .zip

Change History (12)

Changed 10 years ago by craftyguy@…

Attachment: -v playback.log added

output from -v playback

comment:1 Changed 10 years ago by markk

Milestone: unknown0.23
Owner: changed from Janne Grunau to markk
Status: newaccepted

comment:2 Changed 10 years ago by markk

Firstly, can you ensure you've done a make distclean and are fully up to date.

The file referenced here:-

2010-01-22 14:51:40.984 VDPAU Error: Error at util-vdpau.cpp:613 (#23, The system does not have enough resources to complete the requested operation at this time.)

was removed in r23237.

Secondly, if you are still having problems, can you attach a -v playback log from starting the frontend to the point where playback fails.

comment:3 Changed 10 years ago by markk

... and, what gpu are you using and how much memory does it have?

Changed 10 years ago by craftyguy@…

Attachment: vdpau-playback2.log added

Here is a new playback log, I'm definitely running the latest SVN now. My video card is a 8400GS G98, nvidia-settings reports 512MB RAM. This same setup has played HD content using VDPAU before flawlessly in the past. I've tried tweaking the vdpaubuffersize from the default of 17 to 12, to 24. It fails every time.

comment:4 Changed 10 years ago by markk

As requested, can you please attach a complete log from 'mythfrontend -v playback' from the point you start mythfrontend, not from the point you start playback - and remove any buffer size settings (increasing the buffer size is not going to help).

Changed 10 years ago by Simon Kenyon <simon@…>

Attachment: vdpau.log added

here is a log as requested. this is from svn 23242 on an amd athlon 64 x2 on an asustek M3N78-EM motherboard using the on-board nvidia geforce 8300

comment:5 Changed 10 years ago by markk

Status: acceptedinfoneeded

Can someone please confirm whether this is still happening with the latest trunk code.

Please also ensure you are using the official stable driver relase (190.53) and not the current beta (195.30). I've just confirmed some serious performance regressions in the beta driver which may be related.

Changed 10 years ago by craftyguy@…

Attachment: vdpau2.log added

Updated to 23357, rolled nvidia driver back to 190.53, and set 'normal' VDPAU profile (which worked in the past) with default buffer count, and still no go. I'm getting the same results with recorded TV (though live TV works fine)

comment:6 Changed 10 years ago by craftyguy@…

Mark: Do you require any more information for this bug?

I will not be able to contribute any more, I have since upgraded the video card to a GT220, and this issue seems to be corrected for me after the upgrade. However there are still quite a few users with lower-end hardware and there is definitely still an issue with VDPAU playback on those devices after the commit above.

comment:7 Changed 10 years ago by stuartm

I have a variant of the same board as Simon, with the 8200 instead of the 8300 and I have no problems with VDPAU in trunk. Considering that the 8200 is the absolute lowest end hardware, either this has been fixed, or it only affects videos with certain encoding options or quite possibly it's the result of faulty hardware. There have been occurrences of VDPAU capable hardware irreparably failing and refusing to decode anything, just ask Kormoc.

Craftguy didn't indicate whether reverting to an earlier revision worked and since he no longer has the hardware, that information won't be forthcoming. At this stage the only way to be sure one way or the other is to have some samples of video which are known to fail with current trunk, but not [23237].

Mark, I recommend closing as fixed/invalid because I don't think there is an issue. If I'm wrong then someone can produce those vid samples which demonstrate the problem.

comment:8 Changed 10 years ago by markk

Resolution: worksforme
Status: infoneededclosed

As stuartm has stated, there are no other reports of similar issues with the trunk code and it's pointless keeping this ticket open if nobody can produce the issue anymore. If it is a genuine issue, I guess we'll find out soon enough after 0.23 is released.

Note: See TracTickets for help on using tickets.