Opened 11 years ago

Closed 11 years ago

#8234 closed defect (duplicate)

mythfrontend crashed while arrowing around within mythvideo

Reported by: Marc Randolph <mrand@…> Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: MythTV - General Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Not much to say - was reorganizing mythvideo library. Did a rescan, then pushed the arrow keys a few times. Selection moved. Moved around some more, possibly going up or down a directory, and suddenly got a crash

$ mythfrontend --version
Please include all output in bug reports.
MythTV Version   : 23789
MythTV Branch    : branches/release-0-23-fixes
Network Protocol : 56
Library API      : 0.23.20100314-1
QT Version       : 4.5.2
Options compiled in:
 linux profile using_oss using_alsa using_pulse using_jack using_pulseoutput using_backend using_dvb using_firewire using_frontend using_glx_proc_addr_arb using_hdhomerun using_hdpvr using_iptv using_ivtv using_joystick_menu using_lirc using_mheg using_opengl_video using_opengl_vsync using_qtdbus using_qtwebkit using_v4l using_x11 using_xrandr using_xv using_xvmc using_xvmc_vld using_xvmcw using_bindings_perl using_bindings_python using_opengl using_vdpau using_ffmpeg_threads using_libavc_5_3 using_live using_mheg

apport might produce a better/different trace, but I didn't want to hold this report up on that in case the attached trace is helpful enough.

Frontend log doesn't contain anything interesting. It ended with the following (which occurs randomly throughout the log):

2010-03-27 15:51:06.373 Unable to find image file: No Cover
2010-03-27 15:51:09.376 Unable to find image file: No Cover

Attachments (2)

Stacktrace.txt (15.0 KB) - added by Marc Randolph <mrand@…> 11 years ago.
ThreadStacktrace.txt (33.3 KB) - added by Marc Randolph <mrand@…> 11 years ago.

Download all attachments as: .zip

Change History (6)

Changed 11 years ago by Marc Randolph <mrand@…>

Attachment: Stacktrace.txt added

Changed 11 years ago by Marc Randolph <mrand@…>

Attachment: ThreadStacktrace.txt added

comment:1 Changed 11 years ago by robertm

Status: newinfoneeded_new

think I'm going to need a proper backtrace on this one to have any idea what's going on.

comment:2 Changed 11 years ago by robertm

Resolution: invalid
Status: infoneeded_newclosed

Marc,

The dwarf expression error in what there is of the stacktrace strongly indicates that this is a problem outside of MythTV (or with the compile itself). If you are able to reproduce this (especially on a different machine), please re-open the ticket with a full backtrace and we'll see if we can find the issue.

comment:3 Changed 11 years ago by robertm

Resolution: invalid
Status: closednew

comment:4 Changed 11 years ago by robertm

Resolution: duplicate
Status: newclosed

Seems to be a similar sort of crash as in #7457.

Note: See TracTickets for help on using tickets.