Opened 10 years ago

Closed 9 years ago

#8296 closed defect (duplicate)

On the Hour Pauses / Crashes with LiveTV

Reported by: tortise <tortise@…> Owned by: Janne Grunau
Priority: minor Milestone: unknown
Component: MythTV - DVB Version: unknown
Severity: medium Keywords: LiveTV Pause Crash
Cc: Ticket locked: no

Description

On the hour a pause or occasional crash is noted during liveTV on DVB-T on JYA fixes 23893 (and for quite some versions earlier also) Mythbuntu 9.10.

To the attached FE log I've put in spaces to mark repeats on the hour.

The issue is not limited to on the hour but is predominantly noted then. Tortise wonders if this has something to do with the LiveTV file end / begin new changeovers?

http://svn.mythtv.org/trac/ticket/6728 might be related with similar initial error messages?

Can I assist with further information?

Attachments (9)

Mythbuntu Frontend Log.txt (29.1 KB) - added by tortise <tortise@…> 10 years ago.
Mythbuntu Backend Log.txt (314.8 KB) - added by tortise <tortise@…> 10 years ago.
Backend 2010-4-13.txt (133.9 KB) - added by tortise <tortise@…> 10 years ago.
Frontend 2010-4-13.txt (57.3 KB) - added by tortise <tortise@…> 10 years ago.
dmseg 2010-4-13.txt (47.7 KB) - added by tortise <tortise@…> 10 years ago.
Backend 2010-4-15.zip (102.7 KB) - added by tortise <tortise@…> 10 years ago.
Frontend 2010-4-15.zip (62.7 KB) - added by tortise <tortise@…> 10 years ago.
dmesg 2010-4-15.txt (48.5 KB) - added by tortise <tortise@…> 10 years ago.
shifty hour crashes.txt (18.8 KB) - added by tortise <tortise@…> 10 years ago.
Shifty's file as pastebin will probably delete

Download all attachments as: .zip

Change History (17)

Changed 10 years ago by tortise <tortise@…>

Attachment: Mythbuntu Frontend Log.txt added

Changed 10 years ago by tortise <tortise@…>

Attachment: Mythbuntu Backend Log.txt added

comment:1 Changed 10 years ago by robertm

Status: newinfoneeded_new

Your backend is set to a public IP, are you attempting to watch across the internet? Also, the excerpted logs do us no good, we need clean logs from backend and frontend startup.

comment:2 in reply to:  1 Changed 10 years ago by tortise <tortise@…>

Replying to robertm:

i) Your backend is set to a public IP, ii) are you attempting to watch across the internet?

i) Not to my understanding and ii) no current plans to do this. Will get you start logs as able. There may be two issues here. 1) That there is a viewing gap, which seems related to the tuner stopping and retuning on the hour and 2) crashes sometimes resulting. Will look to log from startup for the first and second.

comment:3 Changed 10 years ago by robertm

Go ahead and give dmesg output for around that time too.

comment:4 in reply to:  3 Changed 10 years ago by tortise <tortise@…>

Attachments being made now incl dmesg. At 17:00 there was a pause, no crash his time. 720p H264 content channel this occasion. Not sure if different content is related to crashing, have 576, 720p and 1080i to choose from, will observe all to see if makes any difference. Rebooted just prior with upgrades to NVIDIA 195.36.15 and now fixes 24035. (PS If I wanted to make LiveTV available over the internet there are other ways I'd do it in preference to using mythtv)

Changed 10 years ago by tortise <tortise@…>

Attachment: Backend 2010-4-13.txt added

Changed 10 years ago by tortise <tortise@…>

Attachment: Frontend 2010-4-13.txt added

Changed 10 years ago by tortise <tortise@…>

Attachment: dmseg 2010-4-13.txt added

Changed 10 years ago by tortise <tortise@…>

Attachment: Backend 2010-4-15.zip added

Changed 10 years ago by tortise <tortise@…>

Attachment: Frontend 2010-4-15.zip added

Changed 10 years ago by tortise <tortise@…>

Attachment: dmesg 2010-4-15.txt added

comment:5 Changed 10 years ago by tortise <tortise@…>

The 2010-4-15 file series include several crashes during liveTV. At 2010-04-15 19:00 there was a playback crash confirmed at that time with the message "irrecoverable recorder error" displayed on screen. Content was 720p.

Also I note there is a segfault in dmesg: "[139120.928817] gnome-system-mo[2433]: segfault at 0 ip 04c0c7bc sp bf8646e8 error 6 in libc-2.10.1.so[4b9d000+13e000]"

comment:6 Changed 10 years ago by shifty

I think I am experiencing this problem as well. My pauses appear on the top and bottom of the hour if no guide data exists, or on each program change if guide data exists.

Frontend log: http://pastebin.com/6gGa6QCs

Lt me know if I can provide any more details

Changed 10 years ago by tortise <tortise@…>

Attachment: shifty hour crashes.txt added

Shifty's file as pastebin will probably delete

comment:7 Changed 10 years ago by robertm

Status: infoneeded_newnew

comment:8 Changed 9 years ago by robertm

Resolution: duplicate
Status: newclosed

Dupe of #7697. As a note, casual perusal suggests all users were using VDPAU.

Note: See TracTickets for help on using tickets.