Modify
Warning Please read the Ticket HowTo before creating or commenting on a ticket. Failure to do so may cause your ticket to be rejected or result in a slower response.

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#8347 closed task (fixed)

'Lossless transcoding with cutlist' using Project-X

Reported by: J.Pilk@… Owned by: ijr
Priority: minor Milestone: unknown
Component: MythTV - General Version: Unspecified
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Relates to ticket 7595, which has just been closed. I use this script to preprocess mpeg2 recordings from dvb-t. Applying the cutlist via Project-X within MythArchive? sometimes gives the wrong sound channel and means that the size of the final file is not known when the recordings are selected. This script tells the user what PIDs are present and requires him/her to specify two: one video, one audio. The cutlist is not applied with single-frame accuracy but I have found it robust and 'good enough'. I have had very few failures when the script has been used on the original recording; it seemed less reliable when used on recordings that had been preprocessed using mencoder.

The script (still called mythcutprojectx) uses ideas from scripts found in the mythtv lists: mythcutprojectx and pxcut.sh

I also use a version of mythburn.py that I have hacked to use M2VRequantiser instead of the deprecated tcrequant and to create a dvd image with all video mean bitrates subject to a common upper limit. This version was not created under svn and includes changes addressing a number of issues. It has been used only under a narrow range of circumstances. I would like guidance on how to submit it. Regrettably the version of M2VRequantiser that I use seems to be no longer on the web.

Attachments (1)

mythcutprojectx (5.9 KB) - added by J.Pilk@… 4 years ago.

Download all attachments as: .zip

Change History (6)

Changed 4 years ago by J.Pilk@…

comment:1 Changed 4 years ago by robertm

  • Resolution set to fixed
  • Status changed from new to closed

J.Pilk, Thank you for your script. Since we are moving towards having contrib scripts in the wiki instead of in the source distribution, I have created a page for it here:

http://www.mythtv.org/wiki/Mythcutprojectx
http://www.mythtv.org/wiki/Category:User_Job_Scripts

Please feel free to improve the description and edit the script when you make changes. Thanks again for your contribution.

comment:2 Changed 4 years ago by J.Pilk@…

My final comment about M2VRequantiser above was true yesterday - but today it's back.
It's a 26 Kb tarball.

http://code.flexion.org/M2VRequantiser.html

comment:3 Changed 4 years ago by J.Pilk@…

I submitted the patch for mythburn.py at #8376. The parts of this that enable use of M2VRequantiser have been committed as r24416.

comment:4 Changed 4 years ago by J.Pilk@…

I just had a failure in DVD creation using the patched version of mythburn.py from #8376. It followed experiments using the Project-X GUI which left a modified version of ~/X.ini. $RECDIR/X.ini was not changed. If it existed it would be used by mythcutprojectx (#8347) Everything seems to work as intended with the configuration which is used if no X.ini is found in the expected location.

comment:5 Changed 4 years ago by J.Pilk@…

In the past few days I have had reports from two people running trunk who have used this script (because lossless mythtranscode seems to be actually broken in trunk) but found that it applied the cutlist in the inverse sense. A version modified to omit the original inversion logic in the MythTV > Project-X cutlist translation process was reported to apply the cutlist as intended.

The original version still works for me in 0.23-fixes r25138

http://www.gossamer-threads.com/lists/mythtv/users/442903#442903

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'new'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.