Opened 10 years ago

Closed 10 years ago

#8385 closed defect (invalid)

DVD/ISO playback issues

Reported by: bdgisme <bryanguidroz@…> Owned by: Isaac Richards
Priority: trivial Milestone: unknown
Component: MythTV - DVD Playback Version: 0.23rc2
Severity: low Keywords:
Cc: Ticket locked: no

Description (last modified by robertm)

I've tested this on two different sets of hardware using Mythdora 12.23 and Mythbuntu 10.04 with the same result. I wasn't able to find a ticket describing this problem.

When I insert a DVD and go to Optical Disk | Play DVD, I get an error "Video frame buffering failed too many times." I've tried 3 different DVDs. The same happens if I go to Media Library | Watch Vidoes and select an ISO (tried 3 different ISO... different ISOs than the DVD movies above.)

Attachments (4)

mythtv.log (9.1 KB) - added by bdgisme <bryanguidroz@…> 10 years ago.
MythOut-Alvin-DVD.log (132.1 KB) - added by bdgisme <bryanguidroz@…> 10 years ago.
MythOut-Ant-DVD.log (240.9 KB) - added by bdgisme <bryanguidroz@…> 10 years ago.
MythOut-Avatar-DVD.log (211.2 KB) - added by bdgisme <bryanguidroz@…> 10 years ago.

Download all attachments as: .zip

Change History (10)

Changed 10 years ago by bdgisme <bryanguidroz@…>

Attachment: mythtv.log added

comment:1 Changed 10 years ago by robertm

Description: modified (diff)
Status: newinfoneeded_new

ISO playback is not supported from Video Storage Groups. See:

http://www.mythtv.org/wiki/Mythvideo#Storage_Groups

Only the "Video Frame Buffering Failed" is a valid portion of this bug. We need "mythfrontend -v playback" from trying to play back an actual DVD to learn anything about that bug/determine if it's a duplicate of one of the other bugs.

comment:2 Changed 10 years ago by robertm

Component: MythTV - GeneralMythTV - DVD Playback
Priority: majortrivial
Severity: highlow

Also, please read the ticket howto, severity and priority should only be modified by triagers/developers.

comment:3 Changed 10 years ago by bdgisme <bryanguidroz@…>

I've attached 'mythfrontend -v playback' for 3 different DVDs and one ISO. This is a fresh install of Mythdora 10.23, fully updated. I only created the default storage group at /storage/recordings. Last night I tried 3 different DVD drives and two different IDE cables (in desperation.) Problems remain. All three DVDs and the ISO work fine in Mythdora 10.21 (upgraded to 0.22). Avatar played for a few minutes, but I see there were errors. The Ant Bullly played, but eventually froze and displayed the frame buffering error. Alvin and the Chipmunks would not play at all and displayed the frame buffering error. The Cloudy with a chance of meatballs iso did not play and I believe displayed the frame buffering error.

I don't know if this is of any relevance, but on this system, I'm using an MSI ATI graphics card (it's a Radeon X800 series card, don't know the exact model number.) It's the only graphics adapter I have available at this time.

Changed 10 years ago by bdgisme <bryanguidroz@…>

Attachment: MythOut-Alvin-DVD.log added

Changed 10 years ago by bdgisme <bryanguidroz@…>

Attachment: MythOut-Ant-DVD.log added

Changed 10 years ago by bdgisme <bryanguidroz@…>

Attachment: MythOut-Avatar-DVD.log added

comment:4 Changed 10 years ago by bdgisme <bryanguidroz@…>

Well, the log for the Cloudy ISO is about 4mb and that appears to be too big to upload. It has a large number of the following errors.

2010-04-26 21:44:04.783 [mpeg2video @ 0x11d7260]get_buffer() failed (stride changed) 2010-04-26 21:44:04.783 AFD Error: Unknown decoding error 2010-04-26 21:44:04.783 No codec context. Returning false

If there is a specific section that is useful, let me know what to copy/paste or if there is another way to get the file uploaded.

comment:5 Changed 10 years ago by bdgisme <bryanguidroz@…>

And, I meant this is a fresh install of Mythdora 12.23. Sorry...

comment:6 Changed 10 years ago by robertm

Resolution: invalid
Status: infoneeded_newclosed

This was fixed in r24252, you need to update to currect fixes. Also, you do have a video storage group for MythVideo?, your first log clearly shows that's where your ISO content is hosted. If you require further assistance with either issue, please follow up on the users list.

Note: See TracTickets for help on using tickets.