Opened 10 years ago

Closed 4 years ago

#8441 closed Bug Report - General (fixed)

Recordings screen update issue on some themes

Reported by: Kenni Lund <kenni@…> Owned by: jpabq
Priority: minor Milestone: 0.28
Component: MythTV - User Interface Library Version: Master Head
Severity: medium Keywords: MythUI mythbuntu childish
Cc: Ticket locked: no

Description (last modified by Kenni Lund [kenni a kelu dot dk])

Updated description:
In Metallurgy, Mythbuntu and Childish, when you have more recordings of one program than what can be shown in one screen, deleting the oldest recording should move the selection bar one up and empty the line containing the old recording. Metallurgy illustrates how this should work:
http://www.postimage.org/image.php?v=Pqdluz9

However, when you do this on the Mythbuntu or Childish theme, you'll get the recording from the other end of the list, instead of an empty line:
http://www.postimage.org/image.php?v=Pqdl5CJ

But this line should just be empty, as the line doesn't exist. You cannot select it, as illustrated by the arrows on the right side of the screen, in the Mythbuntu screenshot above. If you click down once, the selection will just jump to the top of the list, just like in Metallurgy.

Confirmed on trunk r26203

Attachments (1)

mythtv-buttonlistadjust1.patch (999 bytes) - added by Mark Spieth 4 years ago.
only move topselected if bottom was displayed

Download all attachments as: .zip

Change History (23)

comment:1 Changed 10 years ago by Kenni Lund <kenni@…>

This is btw. on 0.23-fixes r24486:

$ mythfrontend --version
Please attach all output as a file in bug reports.
MythTV Version   : 24486M
MythTV Branch    : branches/release-0-23-fixes
Network Protocol : 56
Library API      : 0.23.20100429-1
QT Version       : 4.6.2
Options compiled in:
 linux release using_oss using_alsa using_backend using_dvb using_frontend using_hdpvr using_iptv using_lirc using_mheg using_opengl_video using_opengl_vsync using_qtdbus using_qtwebkit using_v4l using_x11 using_xrandr using_xv using_bindings_perl using_bindings_python using_opengl using_vdpau using_ffmpeg_threads using_live using_mheg

comment:2 Changed 10 years ago by robertm

Status: newinfoneeded_new

Don't see anything to indicate this would be theme related, have you tried in other themes? The button ordering/changing of button orders shouldn't depend on theme at all.

comment:3 Changed 10 years ago by robertm

Resolution: invalid
Status: infoneeded_newclosed

It was pointed out to me that you are asking about the wrap behavior-- this is as the themer intended it-- he wants the list to wrap when full. As such, there is no bug to speak of here-- if this is unclear or we can answer questions about it, please follow up on the users list. You may also be interested in reading up on "wrapstyle" here:

http://www.mythtv.org/wiki/MythUI_Theme_Development#The_buttonlist_widget

comment:4 Changed 10 years ago by cpinkham

Resolution: invalid
Status: closednew

Here's a copy of some instructions for reproducing the bug. I also posted to the mailing list thread about this.

1) Set your sort order to "Sort all sub-titles/multi-titles Ascending".

2) Go back to Watch Recordings and scroll to a title that has more items than will fit on the right hand side of the screen.

3) Cursor Right to select the subtitle list.

4) Scroll down to the bottom-most (ie, newest) recording.

5) Delete it.

6) Watch the focus/selector bar move up one item and the very top (ie, oldest) item in the list magically appear at the bottom of the list.

7) Try to scroll down to that oldest item now visible at the bottom of the list.

8) Watch the list redraw and focus move to the top of the list and the oldest item.

comment:5 Changed 9 years ago by robertm

Owner: changed from Isaac Richards to cpinkham
Status: newassigned

comment:6 Changed 9 years ago by Kenni Lund [kenni AT kelu d0t dk] <kenni@…>

Just to be clear, this is not a MythBuntu? theme specific issue, Childish is affected as well (trunk r26135).

I've just noticed that the theme Metallurgy is functionally equal to MythBuntu? and Childish in that menu, but Metallurgy shows exactly how it *should* work, eg. on deletion it moves the selection bar one line up and replaces the deleted recording with an empty line (instead of replacing it with a recording from the other end of the recording list).

comment:7 Changed 9 years ago by Kenni Lund [kenni a kelu dot dk]

Component: ThemesMythTV - User Interface Library
Description: modified (diff)
Keywords: MythUI childish added; theme removed
Owner: changed from cpinkham to stuartm
Summary: MythBuntu theme update issue when deleting recordingsRecordings screen update issue on some themes
Version: 0.23-fixesTrunk Head

stuartm, assigning to you, since you committed a new wrapstyle the other day and seems to be the developer who works the most in this area.

comment:8 Changed 9 years ago by stuartm

Milestone: unknown0.24
Status: assignedaccepted

comment:9 Changed 9 years ago by stuartm

Status: acceptedinfoneeded

Kenni, which painter are you using?

comment:10 Changed 9 years ago by anonymous

I have also noticed this bug. I am using OpenGL.

comment:11 Changed 9 years ago by Kenni Lund [kenni a kelu dot dk]

Status: infoneededassigned

stuartm, Qt or OpenGL, I'm seeing the issue with both of them.

comment:12 Changed 9 years ago by stuartm

Milestone: 0.240.24.1

comment:13 Changed 9 years ago by stuartm

Status: assignedaccepted

comment:14 Changed 8 years ago by stuartm

Milestone: 0.24.10.24.2

comment:15 Changed 8 years ago by beirdo

Milestone: 0.24.2unknown

comment:16 Changed 8 years ago by stuartm

Milestone: unknown0.25
Type: defectBug Report - General

comment:17 Changed 8 years ago by stuartm

Milestone: 0.250.25.1

comment:18 Changed 7 years ago by Raymond Wagner

Milestone: 0.25.10.26

comment:19 Changed 7 years ago by stuartm

Owner: changed from stuartm to jpabq
Status: acceptedassigned

comment:20 Changed 7 years ago by Kenni Lund [kenni a kelu dot dk]

Milestone: 0.260.26.1

comment:21 Changed 6 years ago by paulh

Milestone: 0.26.10.28

comment:22 Changed 4 years ago by John Poet <jpoet@…>

Resolution: fixed
Status: assignedclosed

In 3342f6a3067c7ec5583dad73056f65f4a8f55f31/mythtv:

MythUIButtonList::CalculateButtonPositions?: Make sure m_topPosition is
adjusted if last item is delete ScrollFree? mode.

Fixes #8441

Changed 4 years ago by Mark Spieth

only move topselected if bottom was displayed

Note: See TracTickets for help on using tickets.