Opened 14 years ago

Closed 14 years ago

#849 closed defect (worksforme)

Mythweather acts "weird" undo Gentoo, Radar stays up to long

Reported by: anonymous Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythweather Version: head
Severity: medium Keywords: mythweather, radar, gentoo
Cc: turner@… Ticket locked: no

Description

Since someone is actually playing around with the mythweather code, maybe they can help me with the Gentoo "radar display hangs for 30 seconds and then blows by the first two or three screens" bug. It seems to be some kind of timing bug that only effects Gentoo users. If I was more of a C++ hacker, I'd try to run it down myself. As is, I'd be happy to work with someone who is proficient in this code to debug it.

Basically, the first time through, I see the three "text" screens for 10 seconds. Then I see the radar screen for about 30 seconds. Then the first two text screens fly by, the third screen holds for 10 seconds, and back to the overly long radar screen.

Change History (5)

comment:1 Changed 14 years ago by turner@…

Didn't mean to be anonymous, I'm the reporter

comment:2 Changed 14 years ago by anonymous

Cc: turner@… added

comment:3 Changed 14 years ago by paulh

I use Gentoo and have never seen this problem? Hard to fix something you can't reproduce.

One thing you could try to see if it improves things for you is change the interval between updates to the animated image. Look for the animatedimage element in the weather-ui.xml file used by the theme you are using and change the <interval>200</interval> to a higher value.

comment:4 Changed 14 years ago by cardoe@…

Priority: majorminor
Severity: highmedium

I've never seen this. Try re-emerging or de-voodooing your system. You also didn't say what versions you were using? Are you using the official ebuild? Changing severity since it's really a locally affected issue.

comment:5 Changed 14 years ago by cpinkham

Resolution: worksforme
Status: newclosed

If it's a locally affected issue, then it's not a Myth bug report. Closing ticket as "works for me (and Cardoe too)" :)

Note: See TracTickets for help on using tickets.