Opened 10 years ago

Closed 10 years ago

#8515 closed defect (worksforme)

Jamu fails to ignore directories with spaces on it

Reported by: callmegar Owned by: Anduin Withers
Priority: minor Milestone: 0.23-fixes
Component: Plugin - MythVideo Version: 0.23-fixes
Severity: low Keywords: jamu, ignore directory
Cc: Ticket locked: no

Description

Jamu fails to ignore a directory if the name has spaces on it. i.e. I added the following line under [ignore-directory]:

ignore01: /media/video/Carnival Show

directory is still processed, I tried the following lines also:

ignore01: /media/video/Carnival Show/ ignore01: /media/video/Carnival\ Show ignore01: /media/video/Carnival\ Show/ ignore01: "/media/video/Carnival Show" ignore01: "/media/video/Carnival Show/" ignore01: "/media/video/Carnival\ Show" ignore01: "/media/video/Carnival\ Show/"

none worked and got no error messages.

Change History (2)

comment:1 Changed 10 years ago by r.d.vaughan@…

I tried with the trunk version of jamu (should make no difference vs jamu in 0.23) the issue you describe and it seems to ignore the directory as specified. Here the the entry in the conf file:

[ignore-directory]

ignore01: /media/video/Carnival Show

When I run jamu from the command line with the -MVf options I get this in the output:

ignore-directory ([u'/media/video/Carnival Show'])

Which indicates that the directory is read properly from the conf file. Is there a chance you left the "#" in front of that entry in your conf file as that would mean it is commented out.

Try the -MVf test to see if the entry is being picked up as intended.

comment:2 Changed 10 years ago by robertm

Resolution: worksforme
Status: newclosed

Please seek help on the users list if you need additional assistance, this appears to be working fine.

Note: See TracTickets for help on using tickets.