Opened 10 years ago

Closed 9 years ago

#8520 closed defect (fixed)

program guide rendered underneath video when activated while watching a recording

Reported by: Jason Lewis <jason@…> Owned by: markk
Priority: minor Milestone: 0.24
Component: MythTV - Video Playback Version: 0.23-fixes
Severity: medium Keywords: program guide
Cc: Ticket locked: no

Description

If you are watching a recording and you press S to bring up the program guide, the program guide is rendered underneath the video so you can't actually see or use it.

MythTV Version : 24855

Steps to reproduce: Record a show, then watch recording. While watching recording press S to schedule another recording. you can see the guide momentarily flash but it seems to be displayed underneath the image of the current recording.

Attachments (6)

err.gz (8.0 KB) - added by jason@… 10 years ago.
output of mythfrontend -v playback
output.gz (5.3 KB) - added by jason@… 10 years ago.
please disregard previous attachment, this one is the correct output
8520.gz (49.4 KB) - added by keemllib@… 9 years ago.
mythfrontend -v most,novbi
8520.livetvSrecordingSok.log.gz (66.4 KB) - added by keemllib@… 9 years ago.
Successful s during a recording after pressing s during LiveTV
8520.fail.stripped (28.4 KB) - added by keemllib@… 9 years ago.
8520.good.stripped (28.2 KB) - added by keemllib@… 9 years ago.
'diffable' file (with previous upload), no timestamps/addresses, after s was pressed

Download all attachments as: .zip

Change History (25)

comment:1 Changed 10 years ago by Jason Lewis <jason@…>

Forgot to mention I use the MythCenter? theme.

comment:2 Changed 10 years ago by Jason Lewis <jason@…>

by the way, this bug also happens if you press # to bring up the program finder

comment:3 Changed 10 years ago by markk

Component: MythTV - GeneralMythTV - Video Playback
Milestone: 0.24
Status: newinfoneeded_new

Please attach the unabridged output of:-

mythfrontend -v playback

thanks

Mark

Changed 10 years ago by jason@…

Attachment: err.gz added

output of mythfrontend -v playback

Changed 10 years ago by jason@…

Attachment: output.gz added

please disregard previous attachment, this one is the correct output

comment:4 Changed 9 years ago by robertm

Status: infoneeded_newnew

comment:5 Changed 9 years ago by robertm

Status: newinfoneeded_new

Still present in trunk?

comment:6 Changed 9 years ago by robertm

Status: infoneeded_newnew

comment:7 Changed 9 years ago by robertm

Status: newinfoneeded_new

comment:8 Changed 9 years ago by robertm

Status: infoneeded_newnew

comment:9 Changed 9 years ago by robertm

Owner: changed from Isaac Richards to markk
Status: newassigned

comment:10 Changed 9 years ago by robertm

Status: assignedinfoneeded

Changed 9 years ago by keemllib@…

Attachment: 8520.gz added

mythfrontend -v most,novbi

comment:11 Changed 9 years ago by keemllib@…

Ran mythfrontend -v most,novbi watched a recorded show and pressed s. The recording pauses. Can't comment on the 'underneath' description, however the schedule does only flash. Pressing escape restarts the recording.

MythTV Version : 26058 MythTV Branch : trunk Network Protocol : 59 Library API : 0.23.20100830-2 QT Version : 4.6.2 Options compiled in:

linux debug using_alsa using_jack using_oss using_pulse using_pulseoutput using_backend using_bindings_perl using_bindings_python using_dvb using_frontend using_iptv using_ivtv using_mheg using_opengl_video using_opengl_vsync using_qtdbus using_qtwebkit using_v4l using_x11 using_xrandr using_xv using_xvmc using_xvmc_vld using_xvmcw using_bindings_perl using_bindings_python using_mythtranscode using_opengl using_vdpau using_ffmpeg_threads using_live using_mheg

comment:12 Changed 9 years ago by keemllib@…

Status: infoneededassigned

Additional data and workaround.

On trunk 26115, if s is pressed while watching LiveTV the schedule appears. If LiveTV is then exited and a recording is watched, the s feature works. If the frontend is stopped, pressing s during LiveTV has to be repeated in order for s to work during a recording.

Changed 9 years ago by keemllib@…

Successful s during a recording after pressing s during LiveTV

Changed 9 years ago by keemllib@…

Attachment: 8520.fail.stripped added

Changed 9 years ago by keemllib@…

Attachment: 8520.good.stripped added

'diffable' file (with previous upload), no timestamps/addresses, after s was pressed

comment:13 Changed 9 years ago by markk

Status: assignedaccepted

comment:14 Changed 9 years ago by markk

see #8165 for additional logs on same issue.

comment:15 Changed 9 years ago by Bill Meek <keemllib@…>

Just built [26410] and retested. Pressing s now works while watching a recording (and LiveTV too.) See #8949.

comment:16 Changed 9 years ago by danielk

Can someone who can repro the problem test the patch in #8950 ?

comment:17 Changed 9 years ago by danielk

(In [26414]) Refs #8520. Don't disable XVideo chromakey draw while embedding.

comment:18 Changed 9 years ago by danielk

No need to test the patch in #8950, the pertinent part has been applied in [26414] but it doesn't fix this issue.

comment:19 Changed 9 years ago by markk

Resolution: fixed
Status: acceptedclosed

(In [26421]) Effectively disable video rendering when embedded and the video is fully obscured. Closes #8520

If we are 'embedding' but don't actually have a preview window, tell the player to display in an empty rect, this disabling any actual framebuffer updates but maintaining all other aspects of playback - such as audio and a/v sync.

This doesn't actually address the root cause of the problem noted in #8520 (which I think is related to the painter window mask when using the Qt UI painter) but it seems to be an effective solution without any unwanted side effects. After all of the recent fixes to embedded playback and colourkey repainting etc, I could replicate the problem in #8520 with any video renderer in conjunction with the Qt UI painter.

Note: See TracTickets for help on using tickets.