Opened 9 years ago

Closed 9 years ago

#8545 closed defect (duplicate)

Zone Minder Live Player Wrong Colours

Reported by: dscoular@… Owned by: paulh
Priority: minor Milestone: unknown
Component: Plugin - MythZoneminder Version: 0.23-fixes
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Hi,

After wondering why the live picture in mythzoneminder had weird colours I googled looking for others experiencing the same issue. I stumbled on a posting that appears to offer a fix at:

http://ubuntuforums.org/showthread.php?t=1397950

The fix suggests that the order of the bit vector assignments may be wrong for r,g and b in .../mythplugins/mythzoneminder/mythzoneminder/zmliveplayer.cpp:

445 else
446 {
447 // all other color palettes
448 for (pos_data = 0; pos_data < (unsigned int) (m_monitor.width * m_monitor.height * 3); )
449 {
450 r = buffer[pos_data++];
451 g = buffer[pos_data++];
452 b = buffer[pos_data++];
453 m_rgba[pos_rgba++] = b;
454 m_rgba[pos_rgba++] = g;
455 m_rgba[pos_rgba++] = r;
456 m_rgba[pos_rgba++] = 0xff;
457 }

Should be:

453 m_rgba[pos_rgba++] = g;
454 m_rgba[pos_rgba++] = r;
455 m_rgba[pos_rgba++] = b;

This may be dependant on the palette being used by the camera, but it's interesting that the recorded streams all appear to have the correct colours. I'm experiencing the above with a foscam FI8908W which has been configured as a remote 24 bit camera in zoneminder.

Any thoughts or consideration of this issue hugely appreciated.

Cheers,

Doug

Change History (1)

comment:1 Changed 9 years ago by paulh

Resolution: duplicate
Status: newclosed

Duplicate of #8182

Note: See TracTickets for help on using tickets.