Opened 9 years ago

Closed 9 years ago

#8550 closed defect (duplicate)

mythfrontend exits when watching a recording at live point

Reported by: James Linder <jam@…> Owned by: Isaac Richards
Priority: minor Milestone: 0.24
Component: MythTV - General Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Recent change of behaviour

I record the news daily A while later I watch the recording Skip over commercials, boring bits ...

On skip to the current recording point mythfrontend exits !!! It used to skip upto the current point then play from that point

All the cute setup buttons/options that purport to relate, do not have the desired effect

The painful workaround is: skip till near end pause big skip (down-key) until recording is past the next bit to be watched un-pause <back><back> to the start of interesting stuff

Daniel said: It's a bug. It may be related to NVP::IsNearEnd?() not working as intended after the ProgramInfo? refactor, or it may be related to the MythUI OSD merge, or it could possibly be something else. Please open a ticket with a script of how to reproduce plus a mythfrontend -v playback log of you performing that script.

It does not fail running with -v all !! Behaviour is as it used to be.

What else can I contribute ?

Thanks James

Change History (4)

comment:1 Changed 9 years ago by James Linder <jam@…>

Just to avoid confusing anybody: mythfrontend version: trunk [25023]

comment:2 Changed 9 years ago by markk

Status: newinfoneeded_new

Can you confirm whether this is still an issue in trunk? I've just started looking at it and can't reproduce as of r25100

comment:3 Changed 9 years ago by James Linder <jam@…>

As at 25100 the problem is NOT present. Unrelated, but reported 'bookmark is set but then lost' is also NOT present. (both problems were visible in 25077) James

comment:4 Changed 9 years ago by danielk

Resolution: duplicate
Status: infoneeded_newclosed

Thanks for reporting back. It appears this was a dup of #8527 fixed in [25091].

Note: See TracTickets for help on using tickets.