Opened 9 years ago

Closed 9 years ago

#8654 closed defect (duplicate)

録画予約削除時のエラー

Reported by: elly.kumagai@… Owned by: Isaac Richards
Priority: blocker Milestone: unknown
Component: MythTV - General Version: Unspecified
Severity: medium Keywords:
Cc: Ticket locked: no

Description

録画予約を削除しようとしますとエラーが表示され、削除ができずにいます。 操作法を教えてください。 よろしくお願いいたします。

Fatal Error at /var/www/html/mythweb/modules/tv/includes/objects/Program.php, line 817: Unknown schedule for this program's recordid:

If you choose to submit a bug report, please make sure to include a brief description of what you were doing, along with the following backtrace as an attachment (please don't paste the whole thing into the ticket). Backtrace:

datetime: 2010-07-15 21:52:10 (JST) errornum: 256

error type: User Error

error string: Unknown schedule for this program's recordid:

filename: /var/www/html/mythweb/modules/tv/includes/objects/Program.php

error line: 817

==========================================================================

Backtrace:

file: /var/www/html/mythweb/modules/tv/includes/objects/Program.php line: 817

class:

function: trigger_error

type: args: Array

(

[0] => Unknown schedule for this program's recordid: [1] => 256

)

file: /var/www/html/mythweb/modules/tv/upcoming.php line: 52

class: Program

function: rec_override

type: -> args: Array

(

[0] => 7

)

file: /var/www/html/mythweb/modules/tv/handler.php line: 83

class:

function: require_once

type: args: Array

(

[0] => /var/www/html/mythweb/modules/tv/upcoming.php

)

file: /var/www/html/mythweb/mythweb.php line: 28

class:

function: require_once

type: args: Array

(

[0] => /var/www/html/mythweb/modules/tv/handler.php

)

==========================================================================

$_GET: Array (

[record] => yes [chanid] => 5 [starttime] => 1279490400 [manualid] => 82

)

==========================================================================

$_SESSION: Array (

[language] => Japanese [tmpl] => default [skin] => default [prefer_channum] => 1 [date_statusbar] => %Y %b %e, %I:%M %p [date_scheduled] => %Y %b %e (%I:%M %p) [date_scheduled_popup] => %Y %b %e [date_recorded] => %Y %b %e (%I:%M %p) [date_search] => %Y %b %e, %I:%M %p [date_listing_key] => %Y %b %e, %I:%M %p [date_listing_jump] => %Y %b %e [date_channel_jump] => %Y %b %e [date_job_status] => %Y %b %e, %I:%M %p [time_format] => %I:%M %p [recorded_pixmaps] => 1 [guide_favonly] => [timeslot_size] => 300 [num_time_slots] => 36 [timeslot_blocks] => 3 [timeslotbar_skip] => 20 [max_stars] => 4 [star_character] => ♦ [show_popup_info] => 1 [show_channel_icons] => 1 [sortby_channum] => 1 [show_video_covers] => 1 [tv] => Array

(

[last] => Array

(

[0] => upcoming [1] => 5 [2] => 1279490400 [3] => 82

)

)

[list_time] => 1279197900 [recording_details] => Array

(

[show_Conflict] => 1 [show_PreviousRecording] => 1 [show_EarlierShowing] => 1 [show_CurrentRecording] => 1 [show_WillRecord] => 1

)

[scheduled_recordings] => Array

(

[disp_scheduled] => 1 [disp_duplicates] => 1 [disp_deactivated] => 1 [disp_conflicts] => 1

)

[scheduled_sortby] => Array

(

[0] => Array

(

[field] => airdate [reverse] =>

)

[1] => Array

(

[field] => title [reverse] =>

)

)

[recorded_title] => [recorded_recgroup] => [recorded_sortby] => Array

(

[0] => Array

(

[field] => airdate [reverse] => 1

)

[1] => Array

(

[field] => title [reverse] =>

)

)

[] => Array ( )

)

==========================================================================

$_SERVER: Array (

[REDIRECT_STATUS] => 200 [HTTP_HOST] => localhost:8080 [HTTP_USER_AGENT] => Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; ja-JP-mac; rv:1.9.2) Gecko/20100115 Firefox/3.6 [HTTP_ACCEPT] => text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8 [HTTP_ACCEPT_LANGUAGE] => ja,en-us;q=0.7,en;q=0.3 [HTTP_ACCEPT_ENCODING] => gzip,deflate [HTTP_ACCEPT_CHARSET] => Shift_JIS,utf-8;q=0.7,*;q=0.7 [HTTP_KEEP_ALIVE] => 115 [HTTP_CONNECTION] => keep-alive [HTTP_REFERER] => http://localhost:8080/mythweb/tv/upcoming [HTTP_COOKIE] => mythweb_id=ercrl1oa23qg2v7qu67nais5n7 [PATH] => /sbin:/usr/sbin:/bin:/usr/bin [SERVER_SIGNATURE] => <address>Apache/2.2.10 (Fedora) Server at localhost Port 80</address>

[SERVER_SOFTWARE] => Apache/2.2.10 (Fedora) [SERVER_NAME] => localhost [SERVER_ADDR] => 127.0.0.1 [SERVER_PORT] => 80 [REMOTE_ADDR] => 127.0.0.1 [DOCUMENT_ROOT] => /var/www/html [SERVER_ADMIN] => root@localhost [SCRIPT_FILENAME] => /var/www/html/mythweb/mythweb.php [REMOTE_PORT] => 58730 [REDIRECT_QUERY_STRING] => record=yes [REDIRECT_URL] => /mythweb/tv/upcoming/5/1279490400/82 [GATEWAY_INTERFACE] => CGI/1.1 [SERVER_PROTOCOL] => HTTP/1.1 [REQUEST_METHOD] => GET [QUERY_STRING] => record=yes [REQUEST_URI] => /mythweb/tv/upcoming/5/1279490400/82?record=yes [SCRIPT_NAME] => /mythweb/mythweb.php [PATH_INFO] => /tv/upcoming/5/1279490400/82 [PATH_TRANSLATED] => /var/www/html/tv/upcoming/5/1279490400/82 [PHP_SELF] => /mythweb/mythweb.php/tv/upcoming/5/1279490400/82 [REQUEST_TIME] => 1279198330 [STATUS] => 200 [URL] => /mythweb/tv/upcoming/5/1279490400/82

)

Attachments (1)

mythweb.backtrace (5.8 KB) - added by Raymond Wagner 9 years ago.
move backtrace to attachment as requested by the error

Download all attachments as: .zip

Change History (2)

Changed 9 years ago by Raymond Wagner

Attachment: mythweb.backtrace added

move backtrace to attachment as requested by the error

comment:1 Changed 9 years ago by robertm

Resolution: duplicate
Status: newclosed

Error type is user error, and this is a dupe of multiple other tickets (namely, the ones about deleting a manual rule)

Note: See TracTickets for help on using tickets.