Opened 8 years ago

Closed 8 years ago

#8684 closed defect (fixed)

Screensaver not disabled when watching livetv

Reported by: Matthew Wire <devel@…> Owned by: danielk
Priority: minor Milestone: 0.24
Component: MythTV - General Version: Master Head
Severity: medium Keywords: screensaver tv dpms
Cc: Ticket locked: no

Description

Since around this commit I no longer see the log message: "ScreenSaverX11Private: DPMS Deactivated 1" and sure enough the screen turns off after about 10 minutes.

A call to GetMythUI()->DisableScreensaver?(); at line 1959 of tv_play.cpp was removed so the screensaver is never disabled for livetv (but is for other video modes). Please see attached one line patch

Attachments (1)

fix_livetv_disablescreensaver.patch (506 bytes) - added by Matthew Wire <devel@…> 8 years ago.

Download all attachments as: .zip

Change History (11)

Changed 8 years ago by Matthew Wire <devel@…>

comment:1 Changed 8 years ago by robertm

Resolution: duplicate
Status: newclosed

Dupe of #8639.

comment:2 Changed 8 years ago by robertm

(and I'm sorry, for reference, thank you for the patch! I have referenced it on the other ticket)

comment:3 Changed 8 years ago by robertm

Resolution: duplicate
Status: closednew

Matt is correct, these are distinct issues, reopening with my apologies.

comment:4 Changed 8 years ago by Marcus Brown <marcusbrutus@…>

This patch is a pain. My intention is to have the screen turn off when (all) playback is stopped ... not while it's busy playing (including liveTV). This patch prevents me from watching liveTV for hours unless I increase the DPMS timeout accordingly ... which also means it would take hours for the screen to turn off at night (while in menu, for eg). Please find a better way.

Current status:

DPMS is enabled when frontend starts. (regardless of DPMS setting in xorg.conf) DPMS is disabled for recording playback. DPMS is unchanged for livetv (ie: disabled).

Desired result: DPMS is disabled for livetv.

comment:5 Changed 8 years ago by Marcus Brown <marcusbrutus@…>

Completely scratch my previous comment ... I had assumed the patch had been applied to trunk.
Having now applied it I support the patch!
ie: DPMS is now disabled for livetv .... THANK YOU!

comment:6 Changed 8 years ago by sphery

Owner: set to danielk
Status: newassigned

Daniel, your commit at [25319] ( http://svn.mythtv.org/trac/changeset/25319/trunk/mythtv/libs/libmythtv/tv_play.cpp ) removed the line. I'm assigning this to you because I'm not sure if it was just accidentally removed or if you had some plan for it.

comment:7 Changed 8 years ago by anonymous

I can confirm the issue with screensaver during Live-TV. Screensaver is activated while watching Live-TV. Watching Recordings works as normal and disables screensaver.

The patch in this ticket does resolve the screensaver issue, but as said before it could be that the removed line in tv_play.cpp was according to plan.

comment:8 Changed 8 years ago by paulh

Milestone: unknown0.24

comment:9 Changed 8 years ago by anonymous

I can confirm this issue, too. I think

--- libs/libmythtv/tv_play.cpp	(revision 26192)
+++ libs/libmythtv/tv_play.cpp	(working copy)
@@ -2053,8 +2053,6 @@
 
         if (ctx->buffer && ctx->buffer->IsOpen())
         {
-            GetMythUI()->DisableScreensaver();
-
             if (GetMythMainWindow() && !weDisabledGUI)
             {
                 weDisabledGUI = true;
@@ -2224,6 +2222,7 @@
 
         // hide the GUI paint window
         GetMythMainWindow()->GetPaintWindow()->hide();
+        GetMythUI()->DisableScreensaver();
     }
 
     VERBOSE(VB_PLAYBACK, LOC +

is a better place, because if I understand it right all playbacks go through this if?

comment:10 Changed 8 years ago by danielk

Resolution: fixed
Status: assignedclosed

(In [26205]) Fixes #8684. Disable screensaver when live tv starts successfully.

Note: See TracTickets for help on using tickets.