Opened 10 years ago

Closed 10 years ago

#8699 closed defect (fixed)

OpenGl Painter is broken (text is solid white block, images overlap incorrectly)

Reported by: Rob Smith Owned by: markk
Priority: blocker Milestone: 0.24
Component: MythTV - General Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: yes

Description

OpenGl? Painter is broken (text is solid white block, images overlap incorrectly)

Log with -v playback attached, as is screen shot of brokenness

Attachments (3)

mythfrontend.log (25.0 KB) - added by Rob Smith 10 years ago.
mythfrontend log with -v playback
2010-07-27-133727_1920x1080_scrot.png (412.4 KB) - added by Rob Smith 10 years ago.
Screen Shot of opengl painter
mythfrontend.2.log (44.7 KB) - added by Rob Smith 10 years ago.
mythfrontend log with -v playback with opengl painter and opengl render showing opengl failure

Download all attachments as: .zip

Change History (14)

Changed 10 years ago by Rob Smith

Attachment: mythfrontend.log added

mythfrontend log with -v playback

Changed 10 years ago by Rob Smith

Screen Shot of opengl painter

comment:1 Changed 10 years ago by managementboy@…

I had exactly these issues using QT 4.7 beta. Downgrading to 4.6 fixed it.

comment:2 Changed 10 years ago by Rob Smith

I'm on QT 4.6.2

Changed 10 years ago by Rob Smith

Attachment: mythfrontend.2.log added

mythfrontend log with -v playback with opengl painter and opengl render showing opengl failure

comment:3 Changed 10 years ago by managementboy@…

are you using Ubuntu packages of the Nvidia binary driver 256.35? I opted to use the vanilla install method (from the Nvidia site) as the packages sometimes break OpenGL symlinks on my system. This also leads to the errors you are describing.

comment:4 Changed 10 years ago by Rob Smith

I'm a gentoo user with my own ebuilds for nvidia cards, they're as vanilla as they come.

comment:5 Changed 10 years ago by robertm

Status: newassigned

comment:6 Changed 10 years ago by Rob Smith

Resolution: fixed
Status: assignedclosed

Updated to HEAD and the issue is gone.

comment:7 Changed 10 years ago by stuartm

Milestone: unknown0.24

comment:8 Changed 10 years ago by anonymous

I got trunk rev 26451 and seems this problem still exist, there is no difference with ati (driver version 10.9) or nvidia card (driver version 256.53). I use gentoo linux with qt 4.7.0.

comment:9 Changed 10 years ago by stuartm

Ticket locked: set

Sounds very much like a Gentoo specific breakage. Seek help from the Gentoo packagers, or whatever they are called.

comment:10 Changed 10 years ago by stuartm

Priority: minorblocker
Resolution: fixed
Status: closednew

comment:11 Changed 10 years ago by markk

Resolution: fixed
Status: newclosed

Fixed in r26455 (thanks to Chutt)

Note: See TracTickets for help on using tickets.