Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#8698 closed defect (fixed)

lossless transcoder errors with infinite "No more queue slots!"

Reported by: managementboy@… Owned by: Isaac Richards
Priority: minor Milestone: 0.24
Component: MythTV - Mythtranscode Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

when I try to edit a DVB-S recording made in Germany and transcode it with a lossless mpeg2 user job it sends mythtranscode into an endless loop. The backend starts spitting "No more queue slots!" and can only be saved by killing the mythtranscode process. Not having a cutlist does not show this behavior. Attached a cutout of the backend logs.

running on Avenard Ubuntu packages from trunk.

some information: mythfrontend --version Please attach all output as a file in bug reports. MythTV Version : 25426 MythTV Branch : trunk Network Protocol : 58 Library API : 0.23.20100717-1 QT Version : 4.6.2 Options compiled in:

linux debug using_alsa using_jack using_oss using_pulse using_pulseoutput using_backend using_dvb using_firewire using_frontend using_glx_proc_addr_arb using_hdhomerun using_hdpvr using_iptv using_ivtv using_joystick_menu using_lirc using_mheg using_opengl_video using_opengl_vsync using_qtdbus using_qtwebkit using_v4l using_x11 using_xrandr using_xv using_xvmc using_xvmc_vld using_xvmcw using_bindings_perl using_bindings_python using_opengl using_vdpau using_ffmpeg_threads using_live using_mheg

Attachments (1)

error.log (13.6 KB) - added by managementboy@… 9 years ago.
backendlog

Download all attachments as: .zip

Change History (8)

Changed 9 years ago by managementboy@…

Attachment: error.log added

backendlog

comment:1 Changed 9 years ago by robertm

Probable dupe of #8546, which causes lossless to fail in multiple ways.

comment:2 Changed 9 years ago by managementboy@…

may be a dupe, but applying r25077 did not fix the issues I reported.

comment:3 Changed 9 years ago by robertm

(In [25511]) MythTranscode?: avcodec_encode_video will never return 0 when everything is okay. Handle 0 (and -1) returns with debug and and error. Debugging could probably be better. Possibly refs #8698.

comment:4 Changed 9 years ago by robertm

Status: newinfoneeded_new

managementboy,

Can you please update to r25511 or later, leave r25077 applied to your system, and test to see if you can reproduce?

comment:5 Changed 9 years ago by managementboy@…

I updated to trunk 25612 and DVB recordings now cut out correctly. Issue is solved, thanks.

comment:6 Changed 9 years ago by robertm

Resolution: fixed
Status: infoneeded_newclosed

comment:7 Changed 9 years ago by stuartm

Milestone: unknown0.24
Note: See TracTickets for help on using tickets.