Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#8718 closed defect (fixed)

Network Interface: play speed does not respond to expected speed values

Reported by: James P. Barrett <james.barrett@…> Owned by: cpinkham
Priority: trivial Milestone: 0.24
Component: MythTV - General Version: Master Head
Severity: low Keywords: network interface telnet speed play
Cc: Ticket locked: no

Description (last modified by sphery)

When using the telnet interface the documentation on the wiki and the built in help command indicate that the following are valid speed control commands:

  play speed 2x
  play speed 4x
  play speed 8x
  play speed 16x
  play speed -1x
  play speed 1/2x
  play speed 1/4x
  play speed 1/8x
  play speed 1/16x

In reality the commands above mostly have no effect, the following commands work in the expected manner:

  play speed 3x
  play speed 5x
  play speed 10x
  play speed 20x
  play speed 30x
  play speed -3x
  play speed -5x
  play speed -10x
  play speed -20x
  play speed -30x

The command

play speed -1x

does not function at all, and the following commands produce unexpected behaviour:

 play speed 1/2x  (actually sets the play speed to 1/3 normal)
 play speed 1/3x  (actually sets the play speed to 1/8 normal)
 play speed 1/4x  (actually sets the play speed to 1/16 normal)

It seems highly unlikely that this is intended behaviour

Attachments (2)

mythtv-network-control-speed-control.patch (9.9 KB) - added by james.barrett@… 9 years ago.
Patch to Correct network speed control bug (to be applied to repository revision 25165)
indent-fixed-playspeed.patch (15.0 KB) - added by james.barrett@… 9 years ago.
Fix for playspeed control and redout formatted correctly (hopefully)

Download all attachments as: .zip

Change History (8)

comment:1 Changed 9 years ago by robertm

Priority: minortrivial
Severity: highlow

Please see the ticket howto, do not set severity.

comment:2 Changed 9 years ago by sphery

Description: modified (diff)
Owner: set to cpinkham
Status: newassigned

Changed 9 years ago by james.barrett@…

Patch to Correct network speed control bug (to be applied to repository revision 25165)

comment:3 Changed 9 years ago by james.barrett@…

I've added a patch, which when applied to repository revision 25565 (not 25165 that's a typo) should fix this issue (and cleans up the speed changing code a fair amount in the process).

Changed 9 years ago by james.barrett@…

Fix for playspeed control and redout formatted correctly (hopefully)

comment:4 Changed 9 years ago by cpinkham

Milestone: unknown0.24
Version: 0.23.0Trunk Head

comment:5 Changed 9 years ago by cpinkham

Resolution: fixed
Status: assignedclosed

(In [26217]) Fix some issues with the playback speed control in the Network Control interface.

Closes #8718 using patch by James P. Barrett.

comment:6 Changed 9 years ago by cpinkham

(In [26218]) Consistency fix for something in [26217]. Use lowercase 'x' for all the speed indicator strings.

References #8718.

Note: See TracTickets for help on using tickets.