Opened 9 years ago

Closed 7 years ago

#8717 closed defect (Works for me)

DTS tracks on DVD as iso won't play using internal player

Reported by: rconstantine1@… Owned by: JYA
Priority: minor Milestone: 0.25
Component: MythTV - Video Playback Version: 0.23-fixes
Severity: medium Keywords: dvd, dts, audio
Cc: Ticket locked: no

Description

I guess the info I provided on another ticket was unrelated(?) to the issue I posted it to and is therefore being ignored, so here is a new ticket. Sorry for the mix up.

If I rip a DVD and only keep the DTS audio track, it will not play on 0.23-fixes using the internal player. All other players I have tried work just fine.

The original issue I posted into was this: http://svn.mythtv.org/trac/ticket/8517

An edited copy/paste of my portion of that thread is this:

Out of about 200 DVDs turned ISOs, the following won't play sound. All were ripped with DVDFab (v5 I think). Most are only the main movie, but a few have the menu.

  • Movies
    • The Bourne Identity
    • Bringing Gollum to Life
    • Chain Reaction
    • The Lion, The Witch and The Wardrobe
    • Clear and Present Danger
    • Die Another Day
    • Galaxy Quest
    • Gattaca
    • The Hitchhiker's Guide to the Galaxy
    • I, Robot
    • All discs from The Lord of the Rings Extended Edition
    • The Mask of Zorro
    • Minority Report
    • Moulin Rouge
    • Monty Python and the Holy Grail
    • Mr. & Mrs. Smith
    • O, Brother Where Art Thou
    • Pearl Harbor Pirates of the Caribbean: Curse of the Black Pearl
    • The Recruit
    • Serenity
    • Spiderman 2
    • Stargate - Ultimate Edition
    • Titan A.E.
    • U-571
    • Unbreakable
    • X2
    • X-Men: The Last Stand

Like I said, I have a zillion others that work. For now, I'm using the field (can't remember what it is named) in the DB table to use Xine on just those movies. I'm running Mythdora 12.23 with MythTV 0.23-fixes.

My original install of Myth was from Mythdora 4, which I think was running 0.20. I couldn't use the internal player for movies at all with that, so I'd say this is a huge improvement. I suppose it must be pretty tricky to figure out why Xine and VLC play these ISOs just fine when the internal Myth player won't or you'd have worked it all out by now.

I'm wondering if the tool used to rip has anything to do with it. I tried to re-rip The Bourne Identity [using Myth's built-in tools], but my DVD drive in my Myth box is either busted (which I'm just now learning about since I never use it), or it can't read these discs for some reason. I'll try some others.

I have a hunch that Myth may not handle DTS audio. I need to check, but as I was messing with The Bourne Identity last night, I noticed it had DTS and historically, if I have had a choice between DD and DTS, I have chosen DTS. I'll check tonight to see whether all movies in my list have DTS. I will also try to re-rip Bourne using the Dolby Digital audio and see if it plays.

Tonight I re-ripped The Bourne Identity with the Dolby Digital audio track and it indeed works fine. I haven't checked to see whether the others are DTS too, but it's looking good that this is the problem. That would explain why menu audio plays OK on ISOs that have them. Menus aren't in DTS. I'm going to start re-ripping my other discs and I'll note here if there are any that aren't "fixed". But still, Xine and VLC play the DTS audio just fine, so there must be a way to get Myth's internal player to do so as well. And for all I know, some of my ISOs that work may be DTS too. I usually only rip one 5.1 audio stream and I can't believe my list above are the only ones in DTS.

So if a fix is to be worked on, what data (logs) are needed? If it isn't, then I suppose the wiki should get a note not to rip DVDs using the DTS stream. I suppose I'll see how one goes about adding content to the wiki. Cheers.

Attachments (1)

playbacklog.txt (81.8 KB) - added by rconstantine1@… 9 years ago.
Log of video (DVD ISO) playback

Download all attachments as: .zip

Change History (19)

comment:1 Changed 9 years ago by robertm

Component: MythTV - DVD PlaybackMythTV - Video Playback
Milestone: 0.23-fixesunknown
Status: newinfoneeded_new

Myth *does* handle DTS, so you will need to provide -v playback logs. Also, please read the ticket howto for future reference, please do not set milestone on tickets.

comment:2 Changed 9 years ago by anonymous

Sorry about the milestone setting. I'll poke around the wiki to see if I can find where to set the -v option. Can I just put it where I also specify 'internal'? Hmm. I don't recall seeing anywhere on the wiki all about logs. That might make a good page - i.e where all of the logs are that are useful, how to get them generated, options, what they mean, etc.

In any case, I'll do what you ask as soon as I can.

BTW, if I didn't mention it before, for those titles that did still have the menus, the menu audio played but the movie audio didn't.

comment:3 Changed 9 years ago by robertm

Testing by one of the myth devs suggests this should be solved in trunk, can you possibly test against head?

comment:4 Changed 9 years ago by anonymous

Although I'm not afraid of Linux, I certainly am not an expert. Yes, I could physically do it, but with the heavy use my one box gets, I'd be in real trouble if I messed it up. I'll think about alternatives. Perhaps I could scrape together another box. Or if it is easy to update to trunk and then backout back to 0.23-fixes, I could do that. Is that possible or easy?

comment:5 Changed 9 years ago by robertm

Database upgrades are a one-way street. Rolling back requires a proper database backup, and a restore. If you have further procedural questions, let's please take them to the users list rather than clutter the ticket with them. Thanks.

comment:6 Changed 9 years ago by rconstantine1@…

I finally got around to running myth using the -V flag. I assume that you meant myth itself. I tried a couple of films. First Chain Reaction, here:

2010-08-15 14:56:24.823 Unable to find image file: fanart_large.png
QColor::setNamedColor: Unknown color name 'FFFFFF'
libdvdread: Using libdvdcss version 1.2.10 for DVD access
libdvdnav: Using dvdnav version svnR1169
libdvdnav: DVD Title: CHAIN_REACTION
libdvdnav: DVD Serial Number: 3B3E1356
libdvdnav: DVD Title (Alternative): CHAIN_REACTION
libdvdnav: Unable to find map file '/home/mythtv/.dvdnav/CHAIN_REACTION.map'
libdvdnav: DVD disk reports itself with Region mask 0x00000000. Regions: 1 2 3 4 5 6 7 8
2010-08-15 14:56:27.304 Opened DVD device at /nas/video/DVD MAIN/CHAIN_REACTION.iso
2010-08-15 14:56:27.310 There are 1 titles on the disk
2010-08-15 14:56:27.310 Title 0 has 0 parts.

libdvdread: Attempting to retrieve all CSS keys
libdvdread: This can take a _long_ time, please be patient

libdvdread: Get key for /VIDEO_TS/VTS_01_1.VOB at 0x00000140
libdvdread: Elapsed time 0
libdvdread: Found 1 VTS's
libdvdread: Elapsed time 0
2010-08-15 14:56:27.490 NVP(1): Disabling Audio, params(-1,-1,-1)
2010-08-15 14:56:27.513 VideoOutputXv?: XvMC Adaptor Name: 'NV17 Video Texture'
2010-08-15 14:56:27.534 NVP(1): Forcing decode extra audio option on (Video method requires it).
2010-08-15 14:56:27.765 OpenGLVideoSync()
2010-08-15 14:56:27.888 NVP(1): Forcing decode extra audio option on (Video method requires it).
2010-08-15 14:56:27.894 AFD: Warning, video codec 0xab030a0 id(MPEG2VIDEO_XVMC) type (Video) already open.
2010-08-15 14:56:28.466 AFD: Warning, video codec 0xab030a0 id(MPEG2VIDEO_XVMC) type (Video) already open.
2010-08-15 14:56:28.526 AFD: Setting channels to -1
2010-08-15 14:56:28.526 NVP(1): Disabling Audio, params(0,-1,48000)
2010-08-15 14:57:25.440 ~OpenGLVideoSync() -- closing opengl vsync

Next was Gattaca

2010-08-15 15:05:49.678 Unable to find image file: fanart_large.png
QColor::setNamedColor: Unknown color name 'FFFFFF'
libdvdread: Using libdvdcss version 1.2.10 for DVD access
libdvdnav: Using dvdnav version svnR1169
libdvdnav: DVD Title: GATTACA
libdvdnav: DVD Serial Number: 3B45076A
libdvdnav: DVD Title (Alternative): GATTACA
libdvdnav: Unable to find map file '/home/mythtv/.dvdnav/GATTACA.map'
libdvdnav: DVD disk reports itself with Region mask 0x00000000. Regions: 1 2 3 4 5 6 7 8
2010-08-15 15:05:51.776 Opened DVD device at /nas/video/DVD MAIN/GATTACA.iso
2010-08-15 15:05:51.812 There are 1 titles on the disk
2010-08-15 15:05:51.812 Title 0 has 0 parts.

libdvdread: Attempting to retrieve all CSS keys
libdvdread: This can take a _long_ time, please be patient

libdvdread: Get key for /VIDEO_TS/VTS_01_1.VOB at 0x0000013f
libdvdread: Elapsed time 0
libdvdread: Found 1 VTS's
libdvdread: Elapsed time 0
2010-08-15 15:05:51.967 NVP(2): Disabling Audio, params(-1,-1,-1)
2010-08-15 15:05:51.982 VideoOutputXv?: XvMC Adaptor Name: 'NV17 Video Texture'
2010-08-15 15:05:52.004 NVP(2): Forcing decode extra audio option on (Video method requires it).
2010-08-15 15:05:52.152 OpenGLVideoSync()
2010-08-15 15:05:52.229 AFD: Warning, video codec 0xde96a00 id(MPEG2VIDEO_XVMC) type (Video) already open.
2010-08-15 15:05:52.287 AFD: Setting channels to -1
2010-08-15 15:05:52.288 NVP(2): Disabling Audio, params(0,-1,48000)
2010-08-15 15:05:52.288 AFD: Warning, audio codec 0xa4e73d40 id(DTS) type (Audio) already open, leaving it alone.
2010-08-15 15:06:11.536 ~OpenGLVideoSync() -- closing opengl vsync

They look about the same to me. Is anything else needed from me?

comment:7 Changed 9 years ago by robertm

This is not a -v playback log.

mythfrontend -v playback

Attach as a file, please.

Changed 9 years ago by rconstantine1@…

Attachment: playbacklog.txt added

Log of video (DVD ISO) playback

comment:8 Changed 9 years ago by anonymous

Sorry about that. Hopefully I got it right this time. I'm not great with linux and thought that adding -v to the desktop shortcut's command line would have been enough.

In any case, I just ran this command: mythfrontend -v playback > /home/mythtv/playbacklog.txt

I attached the file above, but here is what was output to the command line too:

QColor::setNamedColor: Unknown color name 'FFFFFF'
libdvdread: Using libdvdcss version 1.2.10 for DVD access

libdvdread: Attempting to retrieve all CSS keys
libdvdread: This can take a _long_ time, please be patient

libdvdread: Get key for /VIDEO_TS/VTS_01_1.VOB at 0x00000140
libdvdread: Elapsed time 0
libdvdread: Found 1 VTS's
libdvdread: Elapsed time 0
QColor::setNamedColor: Unknown color name 'FFFFFF'
libdvdread: Using libdvdcss version 1.2.10 for DVD access

libdvdread: Attempting to retrieve all CSS keys
libdvdread: This can take a _long_ time, please be patient

libdvdread: Get key for /VIDEO_TS/VTS_01_1.VOB at 0x0000013f
libdvdread: Elapsed time 0
libdvdread: Found 1 VTS's
libdvdread: Elapsed time 0
Error in my_thread_global_end(): 1 threads didn't exit

Let me know if I got it wrong again or if anything else is needed. I'm running the latest MythDora? but with MythTV updated to 23.1.

comment:9 Changed 9 years ago by stuartm

Status: infoneeded_newnew

comment:10 Changed 9 years ago by robertm

Status: newassigned

comment:11 Changed 8 years ago by beirdo

Owner: changed from skamithi to markk

comment:12 Changed 8 years ago by beirdo

Component: MythTV - Video PlaybackMythTV - DVD Playback

comment:13 Changed 8 years ago by beirdo

Component: MythTV - DVD PlaybackMythTV - Video Playback

Sorry, I just noticed this got punted the other direction. putting it back

comment:14 Changed 8 years ago by markk

Milestone: unknown0.25
Status: assignedaccepted

comment:15 Changed 7 years ago by markk

Owner: markk deleted
Status: acceptedassigned

comment:16 Changed 7 years ago by danielk

Owner: set to JYA

jya, any interest in this.. close as won't fix if not.

comment:17 Changed 7 years ago by JYA

Status: assignedinfoneeded

Could someone try this again in 0.24 and later. I remember a bug in 0.23 where DTS could be decoded under some circumstances and re-encoded as AC3.

But I can't think of a reason why a video with only a DTS track wouldn't play..

comment:18 Changed 7 years ago by JYA

Resolution: Works for me
Status: infoneededclosed

I ripped a DVD into a mkv, only keeping the DTS track.

Plays just fine on my system.

Marking it as works for me.

If you can still reproduce it in 0.24 and later, re-open this ticket

Note: See TracTickets for help on using tickets.