Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#8730 closed defect (invalid)

Input Connections: Initial input group for multirec cards displayed as "Generic"

Reported by: Nick Morrott <knowledgejunkie (at) gmail (dot) com> Owned by: danielk
Priority: minor Milestone: unknown
Component: MythTV - Mythtv-setup Version: Master Head
Severity: medium Keywords: multirec input group
Cc: Ticket locked: no

Description

Using the same configuration as reported in #8726.

When configuring the input connection for a new card with multirec enabled, the input group given for the connection is initially shown as "Generic", even though it is automatically created (based on the capture card device path) and correctly stored in the inputgroups table to ensure mutlirec does not break.

Re-editing the relevant input connection displays the value stored in the inputgroups table.

Change History (5)

comment:1 Changed 10 years ago by robertm

Owner: changed from Isaac Richards to danielk
Status: newassigned

For closure upon rewrite.

comment:2 Changed 10 years ago by sphery

Ref #6637

comment:3 Changed 10 years ago by danielk

Resolution: invalid
Status: assignedclosed

The automatic input group is not created until after the multirec is configured, this is to allow you to enter some other pre-existing input group.

comment:4 Changed 10 years ago by sphery

(In [25639]) Fix some breakage in comboboxes populated item by item caused by [23803] using a patch by Daniel K. Refs #6662, Refs #8726, Refs #8729, Refs #8730.

comment:5 Changed 10 years ago by Nick Morrott <knowledgejunkie <at> gmail <dot> com>

Tested with trunk @ r25642.

After a full scan, Input group 1 is set to "Generic". This looks to be intentional as Daniel wrote above,

The automatically created DVB-path-based group is in the selection list, and the value of Input group 1 automatically changes to it if the user finishes and later re-enters the input connections. It might be clearer to an end-user to have the DVB-group selected by default instead of generic, as this still lets the user choose another input group if they wish, but selects the multirec group by default.

Note: See TracTickets for help on using tickets.