Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#8851 closed enhancement (Fixed)

mythweb failure message isn't helpful and is outdated

Reported by: aerickson@… Owned by: Rob Smith
Priority: minor Milestone: 0.24
Component: Plugin - MythWeb Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

I don't think mythtv-setup adds MythBackendServer? and MythBackendIP for the NULL host as I've ran it several times and mythweb continued to fail. The error message isn't helpful and didn't lead me to a solution. I ended up putting error_log output in the code and debugging to find the solution.

Attachments (2)

MythBackend-mod.php (8.2 KB) - added by anonymous 9 years ago.
modified mythplugins/mythweb/classes/MythBackend.php file with improved message
improved_error_message.diff (860 bytes) - added by anonymous 9 years ago.

Download all attachments as: .zip

Change History (11)

Changed 9 years ago by anonymous

Attachment: MythBackend-mod.php added

modified mythplugins/mythweb/classes/MythBackend.php file with improved message

comment:1 Changed 9 years ago by aerickson@…

correction: fields are MythBackendPort? and MythBackendIP

attaching error users receive if both fields are not defined for the NULL host

comment:2 Changed 9 years ago by sphery

Component: MythTV - GeneralPlugin - MythWeb
Status: newinfoneeded_new

Please create a unified diff (using diff -u or svn diff) of the changes rather than attaching a complete copy of the PHP source file. If you have questions about how to create the diff, please ask on the mailing lists or in IRC. Thanks.

comment:3 Changed 9 years ago by stuartm

Owner: set to Rob Smith

Changed 9 years ago by anonymous

Attachment: improved_error_message.diff added

comment:4 Changed 9 years ago by stuartm

Status: infoneeded_newnew

comment:5 Changed 9 years ago by robertm

Status: newassigned

This updated message isn't acceptable, we under no circumstances suggest that people insert rows directly into the database. Please remove that content.

comment:6 Changed 9 years ago by robertm

Resolution: Invalid
Status: assignedclosed

This is also invalid-- mythtv-setup absolutely *does* set the global (NULL host) values for these settings.

comment:7 Changed 9 years ago by sphery

As an update, the problem is not that mythtv-setup is not inserting global values for these settings, but that something--outside of MythTV--is editing the database and inserting host-specific values for these settings (which then override the global values for that particular host). Someone needs to find that application/package/whatever and fix it.

comment:8 Changed 9 years ago by Rob Smith

Resolution: InvalidFixed

(In [26688]) Fixes #8851, this changes a refernce to settings.php to mythweb.conf

comment:9 Changed 9 years ago by Rob Smith

Milestone: unknown0.24
Version: UnspecifiedTrunk Head
Note: See TracTickets for help on using tickets.