Opened 9 years ago

Closed 9 years ago

#8978 closed defect (Fixed)

Deadlock in backend on starting a new recording

Reported by: danielk Owned by: jpoet
Priority: blocker Milestone: 0.24
Component: MythTV - General Version: Master Head
Severity: high Keywords:
Cc: Ticket locked: no

Description

I'm setting this as a blocker for now. If it turns out to be rare I will reduce the priority. But I want to investigate this to at least determine if it is a recent regression.

Attachments (1)

8978-dbg.txt (22.1 KB) - added by danielk 9 years ago.

Download all attachments as: .zip

Change History (4)

Changed 9 years ago by danielk

Attachment: 8978-dbg.txt added

comment:1 Changed 9 years ago by danielk

Very little of value is in the backend log:

2010-09-21 11:59:00.209 TVRec(56): ASK_RECORDING 56 29 0 0
2010-09-21 11:59:12.880 Maximal bitrate of busy encoders is 0 KB/min
2010-09-21 11:59:27.910 Cardid 56: max bitrate 162597 KB/min
2010-09-21 11:59:27.912 Maximal bitrate of busy encoders is 162597 KB/min
2010-09-21 11:59:31.398 RecordingInfo(2101_20100921120000.mpg): StartedRecording: Recording to '/video/2101_20100921120000.mpg'
2010-09-21 11:59:31.459 TVRec(56): Changing from None to RecordingOnly
2010-09-21 11:59:31.464 TVRec(56): HW Tuner: 56->56
2010-09-21 11:59:34.857 AutoExpire: Adding Programs to 'Do Not Expire' List
2010-09-21 11:59:34.859     2111 at 2010-09-21T03:00:00 in use by recorder on living.kristjansson.com
2010-09-21 11:59:34.859     2101 at 2010-09-21T12:00:00 in use by recorder on living.kristjansson.com

comment:2 Changed 9 years ago by danielk

Owner: changed from danielk to jpoet
Severity: mediumhigh
Status: newassigned

It looks like m_SMpending is set and StartRecording?() will consequently block forever waiting for the signal quality to improve. This needs to be fixed, we can't have a poor signal on one recorder prevent all other recorders and the fronteds from working.. When StartRecording?() blocks it prevents the scheduler from running and prevents all backend calls that require a scheduler lock from completing...

comment:3 Changed 9 years ago by jpoet

Resolution: Fixed
Status: assignedclosed

Fixed by [26440]

Note: See TracTickets for help on using tickets.