Opened 9 years ago

Closed 8 years ago

Last modified 8 years ago

#9014 closed Bug Report - General (Won't Fix)

closing page with FLV playback sends HUP to other processes

Reported by: warpme@… Owned by: Rob Smith
Priority: minor Milestone:
Component: Plugin - MythWeb Version: Master Head
Severity: high Keywords:
Cc: Ticket locked: no

Description

Hi,

I have BE 26493 running on ArchLinux?. All my processes/daemons are started/supervises via runit. When I launch FLV playback in mythweb and pressing back in browser (or close) web page - all processes in my BE which are enabled to HUP are closed (e.g. dhcpd, smartmod, xined, nfsd, etc). It looks like mythweb after detecting closed web page - sends HUP and this is affecting many system processes. I'm not sure is this issue an result of my system miss-configuration, or bug in mythweb.

Steeps to reproduce:

1.Launch FLV playback in mythweb

2.wait till it start play

3.close page in web browser or press BACK on web browser

4.after few seconds there is HUP signal sent to daemons/processes - and some of them are exiting.

Attachments (1)

lighttpd.conf (12.0 KB) - added by warpme@… 9 years ago.
my webserver config

Download all attachments as: .zip

Change History (22)

comment:1 Changed 9 years ago by Kenni Lund [kenni a kelu dot dk]

Priority: majorminor
Severity: highmedium
Status: newassigned

Please read the ticket howto, don't set the milestone, priority or severity - A developer will set these.

comment:2 Changed 9 years ago by beirdo

Milestone: 0.24unknown

comment:3 Changed 9 years ago by Rob Smith

Milestone: unknown0.24

comment:4 Changed 9 years ago by Rob Smith

Resolution: Fixed
Status: assignedclosed

(In [26648]) Fixes #9014, this prevents any accidental signals to the wrong processes

comment:5 Changed 9 years ago by warpme@…

Kormoc, Thx for keeping eye on this ticket. Unfortunately issue seems to be still present. If You need me for debugging - I'm happy to help. Pls advice how to progress.

comment:6 Changed 9 years ago by Kenni Lund [kenni a kelu dot dk]

Resolution: Fixed
Status: closednew

comment:7 Changed 9 years ago by Kenni Lund [kenni a kelu dot dk]

Status: newassigned

Not fixed according to reporter.

comment:8 Changed 9 years ago by Rob Smith

Status: assignedinfoneeded

What's your webserver setup? Apache? Lighthttpd? SELinux? AppArmor?

We try to group the ffmpeg processes and term them all, but that only works if the isolation level we expect exists, so we need to figure out why it doesn't in your case.

comment:9 Changed 9 years ago by warped@…

Hi, OS is ArchLinux?. Webserver is Lighttpd 1.4.26. Despite I replace whole init subsystem (my is based on runit) - rest of the system is standard Arch. Many packages are built be me but I don't think it is root cause. Interesting is HUP looks to system wide as all processes enabled to interpret HUP are exiting. I attach my webserver config. What else You need to know ?

Changed 9 years ago by warpme@…

Attachment: lighttpd.conf added

my webserver config

comment:10 Changed 9 years ago by Rob Smith

What user is your web server running as?

comment:11 Changed 9 years ago by warpme@…

Daemon is launched from root. HTTP docs dir has httpd:httpd but I turned off rights checking for server-side scripts execution, as I'm using some perl based remote maintenance scripts on my web server.

comment:12 Changed 9 years ago by Rob Smith

Can you comment out line #32 of modules/stream/stream_flv.pl

Should be

kill(-1, $ffmpeg_pgid) if ($ffmpeg_pgid); 

I believe that the grouping is failing under lighttpd and thus sending the signal to all the root user processes. If so, we'll have to detect lighttpd and bypass that signal, but verification would be nice

comment:13 Changed 9 years ago by warped <warpme@…>

Hi. I can confirm. Comenting line #32 solves problem (but of course now exiting/closing browser lefts zombie ffmpeg proc.).

comment:14 Changed 9 years ago by Rob Smith

Can you find out what value $ffmpeg_pgid is getting?

comment:15 Changed 9 years ago by warped <warpme@…>

Hi. Sorry for late replay. I modified stream_flv.pl shutdown handler in a following way:

sub shutdown_handler {

kill(1, $ffmpeg_pid) if ($ffmpeg_pid); kill(-1, $ffmpeg_pid) if ($ffmpeg_pid);

}

This is good compromise as I don't have original issue, ffmpeg proc is killed when page is exited/closed and I can still use buggy lighttpd. br

comment:16 Changed 9 years ago by stuartm

Milestone: 0.240.24.1

comment:17 Changed 9 years ago by robertm

Status: infoneededassigned

comment:18 Changed 8 years ago by stuartm

Severity: mediumhigh
Type: defectBug Report - General

comment:19 Changed 8 years ago by stuartm

Milestone: 0.24.10.24.2

comment:20 Changed 8 years ago by Raymond Wagner

Resolution: Won't Fix
Status: assignedclosed

I'm closing this one as Won't Fix for now. The code in question is slated for replacement with the new transcoding interface available through the Services API.

comment:21 Changed 8 years ago by stuartm

Milestone: 0.24.2

Milestone 0.24.2 deleted

Note: See TracTickets for help on using tickets.