Opened 9 years ago

Closed 9 years ago

Last modified 8 years ago

#9140 closed defect (Duplicate)

AC3 passthrough causes accelerated OSX playback

Reported by: myth@… Owned by: Nigel
Priority: minor Milestone: unknown
Component: Ports - OSX Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Digital audio passthrough can cause the OSX frontend to speed up playback of the video and audio by a large factor.

This has been previously discussed in #5552 . It's 'locked', hence this new ticket and hopes I'm not breaching protocol, as the wiki does not mention locks.

I observed this with svn rev 26959 on Snow Leopard 10.6.4 running on a Mac Pro. It happened after I changed channels twice while watching LiveTV (Chicago, HDHomerun on broadcast networks). Switching between channels was enough to trigger the bug, as I used no other controls. I attach two logfiles...one showing verbose=most from the frontend during the action, and another showing verbose=all from the backend.

Perhaps it is notable that I see several messages like this:

Video is 3.17581 frames behind audio (too slow), dropping frame to catch up.

and

Waited 100ms for video buffers

A typical snippet from the backend log read as follows

2010-10-23 16:38:18.034 XDS: failed CRC 845/1230
2010-10-23 16:38:18.034 AFD: video timecode 6782378273 6782381276 6782378273 75359758 75359725
2010-10-23 16:38:18.034 RingBuf(/Volumes/Brobits/TV/1111_20101023160000.mpg): ReadPriv(..32768, normal) @983040 -- begin
2010-10-23 16:38:18.034 RingBuf(/Volumes/Brobits/TV/1111_20101023160000.mpg): ReadPriv(..32768, normal) -- copying data
2010-10-23 16:38:18.034 RingBuf(/Volumes/Brobits/TV/1111_20101023160000.mpg): ReadPriv(..32768, normal) -- checksum 4739
2010-10-23 16:38:18.034 GetNextFreeFrame() served a busy frame D. Dropping. UUUUUUUUUUUUUUUUUUUUUUUUUUUUUUU
2010-10-23 16:38:18.034 GetNextFreeFrame() is getting a busy frame P.       UUUUUUUUUUUUUUUUUUUUUUUUUUUUUUU
2010-10-23 16:38:18.041 AFD: video timecode 6782381276 6782384279 6782381276 75359791 75359758
2010-10-23 16:38:18.051 RingBuf(/Volumes/Brobits/TV/1111_20101023160000.mpg): ReadPriv(..32768, normal) @1015808 -- begin
2010-10-23 16:38:18.051 RingBuf(/Volumes/Brobits/TV/1111_20101023160000.mpg): ReadPriv(..32768, normal) -- copying data
2010-10-23 16:38:18.051 RingBuf(/Volumes/Brobits/TV/1111_20101023160000.mpg): ReadPriv(..32768, normal) -- checksum 38213
2010-10-23 16:38:18.059 AFD: video timecode 6782384279 6782387282 6782384279 75359825 75359791
2010-10-23 16:38:18.059 AFD: audio timecode 6782329810 6782329810 75359220 75359252
2010-10-23 16:38:18.060 AFD: audio timecode 6782332690 6782332690 75359252 75359284
2010-10-23 16:38:18.060 AFD: audio timecode 6782335570 6782335570 75359284 75359316
2010-10-23 16:38:18.060 AFD: audio timecode 6782338450 6782338450 75359316 75359348
2010-10-23 16:38:18.060 AFD: audio timecode 6782341330 6782341330 75359348 75359380
2010-10-23 16:38:18.060 RingBuf(/Volumes/Brobits/TV/1111_20101023160000.mpg): ReadPriv(..32768, normal) @1048576 -- begin
2010-10-23 16:38:18.060 RingBuf(/Volumes/Brobits/TV/1111_20101023160000.mpg): ReadPriv(..32768, normal) -- copying data
2010-10-23 16:38:18.060 RingBuf(/Volumes/Brobits/TV/1111_20101023160000.mpg): ReadPriv(..32768, normal) -- checksum 34553
2010-10-23 16:38:18.060 RingBuf(/Volumes/Brobits/TV/1111_20101023160000.mpg): safe_read(...@0, 1048576) -- begin
2010-10-23 16:38:18.061 GetNextFreeFrame() served a busy frame M. Dropping. UUULUUUUUUUUUUUUUUUUUUUUUUUUUUU
2010-10-23 16:38:18.061 GetNextFreeFrame() is getting a busy frame P.       UUULUUUUUUUUUUUUUUUUUUUUUUUUUUU
2010-10-23 16:38:18.061 RingBuf(/Volumes/Brobits/TV/1111_20101023160000.mpg): safe_read(...@0, 1048576) -> 1048576
2010-10-23 16:38:18.061 RingBuf(/Volumes/Brobits/TV/1111_20101023160000.mpg): rbwpos += 1024K requested 1024K in read

Please indicate if there are any other diagnostics that may be valuable: myth [at] boonstra [dt] org .

Attachments (2)

toofast_backend.log.gz (341.5 KB) - added by myth@… 9 years ago.
OSX speedup backend log
toofast_frontend.log (78.0 KB) - added by myth@… 9 years ago.
OSX speedup frontend log

Download all attachments as: .zip

Change History (4)

Changed 9 years ago by myth@…

Attachment: toofast_backend.log.gz added

OSX speedup backend log

Changed 9 years ago by myth@…

Attachment: toofast_frontend.log added

OSX speedup frontend log

comment:1 Changed 9 years ago by robertm

Resolution: Duplicate
Status: newclosed

Dupe of #5552, please see the ticket howto at svn.mythtv.org, it's locked because people couldn't help themselves and kept adding "me too" and "I really want this fixed" that does nothing but make the ticket harder to read. Please don't open new tickets that are dupes of locked tickets. Tickets are locked for behavior, not because we don't plan to fix them.

comment:2 Changed 8 years ago by beirdo

Milestone: 0.25unknown
Note: See TracTickets for help on using tickets.