Modify
Warning Please read the Ticket HowTo before creating or commenting on a ticket. Failure to do so may cause your ticket to be rejected or result in a slower response.

Opened 4 years ago

Closed 3 years ago

#9143 closed defect (fixed)

Playback of certain ISO fails

Reported by: Jim Stichnoth <stichnot@…> Owned by: markk
Priority: minor Milestone: 0.25
Component: MythTV - DVD Playback Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

A DVD rip of the main title of Toy Story fails to play under mythfrontend, but works with vlc on Windows. Excerpt of playback log with -v important,general,playback,extra is attached.

10MB excerpt showing the problem is uploaded to
https://docs.google.com/leaf?id=0BxETmfuHvGPQMmVkZTVlZGMtODdmNi00ZDU2LTkxOTAtM2RlZWQwNzg4NDRh&sort=name&layout=list&num=50

Please attach all output as a file in bug reports.
MythTV Version   : 26972M
MythTV Branch    : trunk
Network Protocol : 63
Library API      : 0.25.20101017-1
QT Version       : 4.5.3
Options compiled in:
 linux release using_alsa using_oss using_backend using_bindings_perl using_bindings_python using_dvb using_frontend using_hdhomerun using_hdpvr using_iptv using_ivtv using_joystick_menu using_lirc using_mheg using_opengl_video using_opengl_vsync using_qtdbus using_qtwebkit using_v4l using_x11 using_xrandr using_xv using_bindings_perl using_bindings_python using_mythtranscode using_opengl using_vdpau using_ffmpeg_threads using_live using_mheg

Attachments (2)

mythfrontend.log (25.5 KB) - added by Jim Stichnoth <stichnot@…> 4 years ago.
dvd-reset.diff (531 bytes) - added by markk 3 years ago.

Download all attachments as: .zip

Change History (12)

Changed 4 years ago by Jim Stichnoth <stichnot@…>

comment:1 Changed 4 years ago by robertm

  • Status changed from new to infoneeded_new

Since you specify that it works in Windows, what about mplayer, xine, and vlc or Linux? Disney/Pixar? DVDs are usually protected with ArcOSS/bad block insertion, and the DVD Nav Packet read failed stuff suggests that that might be at issue here.

Has this disc ever worked in Myth?

comment:2 Changed 4 years ago by J.Pilk@…

This excerpt plays for me under 64-bit fedora 12, with vlc and with 0.23-fixes. HTH

comment:3 Changed 4 years ago by robertm

  • Owner changed from janne to markk
  • Status changed from infoneeded_new to assigned

comment:4 Changed 4 years ago by robertm

  • Component changed from MythTV - Video Playback to MythTV - DVD Playback

comment:5 Changed 4 years ago by Jim Stichnoth <stichnot@…>

This ISO used to work in Myth, but I can't say how long ago. Under linux, mplayer and vlc both work; xine complains about not finding a demuxer plugin.

Changed 3 years ago by markk

comment:6 Changed 3 years ago by markk

  • Milestone changed from unknown to 0.25

Jim - the attached hack should get this working temporarily. Still trying to figure out a simple approach to fix this that does not involve re-opening the disc again for the 99% that do work.

comment:7 Changed 3 years ago by markk

  • Status changed from assigned to accepted

comment:8 Changed 3 years ago by markk

  • Status changed from accepted to infoneeded

Jim

Can you confirm you see the same problem with the full ISO? I was hoping this had been fixed with some of the recent dvd playback changes, but still no joy.

comment:9 Changed 3 years ago by Jim Stichnoth <stichnot@…>

Mark,

I'm still seeing the problem with the original main title ISO rip. The dvd-reset.diff patch still makes it work.

comment:10 Changed 3 years ago by Github

  • Resolution set to fixed
  • Status changed from infoneeded to closed

DVD startup fixes.

  • re-implement the dvdnav_first_play method that Stanley Skamithi added

some time ago and I removed some time later...

  • minor tidy up of the CloseDVD method.
  • use the dvdnav_first_play call when 're-starting' the dvd following

the codec scan.

Closes #9143

Branch: master
Changeset: ec474d0b3eea4506b7a36612eea3397e054b406d

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'new'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.