Modify
Warning Please read the Ticket HowTo before creating or commenting on a ticket. Failure to do so may cause your ticket to be rejected or result in a slower response.

Opened 3 years ago

Closed 3 years ago

#9144 closed defect (Invalid)

Massive memory consumption with nvidia driver 260.19.xx when using shapes in the osd.

Reported by: harley@… Owned by: markk
Priority: minor Milestone: unknown
Component: MythTV - General Version: Unspecified
Severity: medium Keywords:
Cc: Ticket locked: no

Description

I maintain the TintedGlass? theme and I have noticed that with the Nvidia drivers 260.19.xx that when using shapes in the osd windows that memory consumption continues to grow every time you bring up the window.
By scrolling in the menu popup window I can go threw 4g of memory in a matter of seconds.
I tested this with the Arclight theme too and it has the same problem. ( Not as bad do to using less shapes ).
If I replace the shapes with images there is no problem.
This only happens in the osd the main theme is fine.
The previous Nvidia drivers didn't have this problem ( 256.xx )
I don't know if this is a Mythtv problem or a Nvidia driver problem but thought I should report it.

Attachments (0)

Change History (8)

comment:1 Changed 3 years ago by harley@…

After running Mythtv for a longer time even though replacing the shapes for the button backgrounds in the menu popup window did help that window replacing the shapes with images did nothing for the status window.
It appears that anything that cause's the display window to change example clock, video position, button poistion etc will cause it to use more memory.
So things like the status window with the position indicator (textarea description) or the popup menu with the button list ( when using shapes for the button background ) use tons of memory.

comment:2 Changed 3 years ago by beirdo

  • Milestone changed from 0.24 to unknown

comment:3 Changed 3 years ago by robertm

  • Owner set to markk
  • Status changed from new to assigned

Assigning this because I think you're looking at this, Mark, feel free to put it elsewhere.

comment:4 Changed 3 years ago by markk

  • Status changed from assigned to infoneeded

Can you please test with latest trunk or release-0-24-fixes (r27036 or newer)

comment:5 Changed 3 years ago by harley@…

mythtv-0.24 r27041
Theme TintedGlass?-1.16

nvidia-driver-260.19.12

After bringing up the program info, status, pausing, pressing channel number, scrolling in the popup menu repeatedly the memory consumed by mythfrontend was 756M.
Also scrolling in the popup menu was not as smooth as before.
Better than is was before when scrolling in the popup menu would run me out of memory in seconds.

nvidia-driver-256.53

Doing the same as above memory consumed 210M.
Also scrolling in the popup menu was smooth.

Harley

comment:6 Changed 3 years ago by mdean

  • Status changed from infoneeded to assigned

comment:7 Changed 3 years ago by harley@…

Nvidia driver version 260.19.21 has been released and fixes this problem.

From the changelog:
Fixed a bug in VDPAU that caused it to attempt allocation of huge blocks of system memory. This regression was introduced in the 260.* driver series.

comment:8 Changed 3 years ago by robertm

  • Resolution set to Invalid
  • Status changed from assigned to closed

Driver bug, thank you Harley.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'new'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.