Modify
Warning Please read the Ticket HowTo before creating or commenting on a ticket. Failure to do so may cause your ticket to be rejected or result in a slower response.

Opened 3 years ago

Closed 3 years ago

#9149 closed defect (Fixed)

Block artifacts when playing video

Reported by: anonymous Owned by: janne
Priority: minor Milestone: 0.25
Component: MythTV - Video Playback Version: 0.24-fixes
Severity: medium Keywords:
Cc: Ticket locked: no

Description

the internal players shows block artifacts while playing some videos both mplayer and FFPlay(0.6,Trunk and the version in mythtv source) all render the videos correctly i have tried to change playback profiles in myth all seem to show the artifacts

sample of a video that shows the problem: http://filebin.ca/oybqjo/RaXGundam_00_Season_2_-_11_-_x264_aac_9F494F5E_sample.mkv

MediaCenter?

Please attach all output as a file in bug reports.
MythTV Version   : 0.24rc1
MythTV Branch    : exported
Network Protocol : 63
Library API      : 0.23.20101017-1
QT Version       : 4.6.2
Options compiled in:
 linux release using_alsa using_oss using_backend using_bindings_perl using_bindings_python using_dvb using_frontend using_hdpvr using_iptv using_ivtv using_joystick_menu using_lirc using_mheg using_opengl_video using_opengl_vsync using_qtdbus using_qtwebkit using_v4l using_x11 using_xrandr using_xv using_xvmc using_xvmcw using_bindings_perl using_bindings_python using_mythtranscode using_opengl using_vdpau using_ffmpeg_threads using_live using_mheg

TestPC

Please attach all output as a file in bug reports.
MythTV Version   : 26972
MythTV Branch    : branches/release-0-24-fixes
Network Protocol : 63
Library API      : 0.24.20101017-1
QT Version       : 4.6.2
Options compiled in:
 linux release using_alsa using_oss using_backend using_bindings_python using_dvb using_frontend using_hdhomerun using_hdpvr using_iptv using_ivtv using_joystick_menu using_lirc using_mheg using_opengl_video using_opengl_vsync using_qtdbus using_qtwebkit using_v4l using_x11 using_xrandr using_xv using_xvmc using_xvmc_vld using_xvmcw using_bindings_python using_mythtranscode using_opengl using_ffmpeg_threads using_live using_mheg

mythavtest-v general,playback on TestPC attached

Attachments (1)

mythavtestlog (38.1 KB) - added by anonymous 3 years ago.
Log of mythavtest -v general,playback

Download all attachments as: .zip

Change History (7)

Changed 3 years ago by anonymous

Log of mythavtest -v general,playback

comment:1 Changed 3 years ago by robertm

  • Status changed from new to assigned

comment:2 Changed 3 years ago by robertm

  • Resolution set to Duplicate
  • Status changed from assigned to closed

Dupe of the more-handled #9307

comment:3 Changed 3 years ago by robertm

That is, of #9311

comment:4 Changed 3 years ago by robertm

  • Resolution Duplicate deleted
  • Status changed from closed to new

OP wasn't using VDPAU, re-opening as a distinct issue.

comment:5 Changed 3 years ago by slackerlinux85@…

buffer changes in f8c108ef9a5c6bac9ec2 seems to fix this issue

comment:6 Changed 3 years ago by tralph

  • Milestone changed from unknown to 0.25
  • Resolution set to Fixed
  • Status changed from new to closed

Submitter reporting problem fixed. Thanks for the follow-up.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'new'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.