Modify
Warning Please read the Ticket HowTo before creating or commenting on a ticket. Failure to do so may cause your ticket to be rejected or result in a slower response.

Opened 3 years ago

Closed 3 years ago

#9311 closed Bug Report (Fixed)

Internal player has problems playing some MKV files

Reported by: anonymous Owned by: markk
Priority: minor Milestone: 0.25
Component: MythTV - Video Playback Version: 0.24-fixes
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Some MKV files can't be played with the internal player, as the internal player shows a lot of pixelation. The same files plays fine in mplayer.

A 20MB sample:
http://filebin.ca/gtsswe/Sample.mkv

Tested on 0.24-fixes r27364.

Attachments (1)

Sample.log (39.7 KB) - added by anonymous 3 years ago.
mythavtest -v playback

Download all attachments as: .zip

Change History (8)

Changed 3 years ago by anonymous

mythavtest -v playback

comment:1 Changed 3 years ago by wagnerrp

  • Status changed from new to infoneeded_new

Looking at the video sample and log, you are using b_pyramid=2 along with VDPAU. B-pyramid support in x264 has long caused problems with hardware decoders, and most commonly available profiles either disable it, or reduce the number of reference frames, in order to ensure L4.1 compliance.

The video plays fine here without VDPAU. Try using the Standard (libav*) decoder instead.

comment:2 Changed 3 years ago by markk

The problem is this line:-

2010-12-01 02:04:33.050 VidOutVDPAU: Created VDPAU decoder (11 ref frames)

The solution is to increase the number of VDPAU buffers by setting vdpaubuffersize=XX in the filters section of the video display profile page (you'll need to find what value for XX works for you). This is technically a bug in the MythTV VDPAU code that should be fixed for 0.25.

Changing to a more recent GPU or updating your drivers may also fix the problem.

If you're creating these MKV's yourself, you should definitely consider changing the settings. That clip will have issues with other hardware acceleration platforms - such as Apple's VDA - and 11 reference frames is entirely OTT.

comment:3 Changed 3 years ago by anonymous

Thanks! Setting vdpaubuffersize=30 fixes playback on my ION-based setup :)

But I don't think #9149 is a duplicate of this ticket, that ticket doesn't use VDPAU and according to the ticket, VDPAU is not even compiled into his setup.

comment:4 Changed 3 years ago by kenni

  • Status changed from infoneeded_new to new

comment:5 Changed 3 years ago by kenni

  • Owner changed from janne to markk
  • Status changed from new to assigned

comment:6 Changed 3 years ago by markk

  • Milestone changed from unknown to 0.25
  • Status changed from assigned to accepted

comment:7 Changed 3 years ago by markk

  • Resolution set to Fixed
  • Status changed from accepted to closed

Fixed in f8c108ef9a5 and 5e04d57bc87a6

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'new'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.