Modify
Warning Please read the Ticket HowTo before creating or commenting on a ticket. Failure to do so may cause your ticket to be rejected or result in a slower response.

Opened 3 years ago

Closed 2 years ago

#9177 closed defect (Invalid)

Channel changes involving analog tuner fail

Reported by: Douglas Peale <Douglas_Peale@…> Owned by: danielk
Priority: minor Milestone: unknown
Component: MythTV - General Version: 0.24-fixes
Severity: medium Keywords:
Cc: Ticket locked: yes

Description

Procedure to recreate bug

If "Watch TV" starts on a SD channel the first time it is run in a session, changing channels to an HD channel will pause for a while then exit to the menu with "Error opening jump program file buffer" message box. Re-starting "Watch TV" will be back to the SD channel, and attempting the channel change will generate the same error again.

This bug is 100% repeatable.

Work around

Change to a different physical tuner than the default. Change to an HD channel on this tuner. You will get dumped back to the menu with the "Error opening jump program file buffer" error. Re-start "Watch TV" change to the same tuner you were on when you got the error. You will now viewing the HD channel without the error. For the rest of the session, you will be able to change tuners & channels without running into the "Error opening jump program file buffer" error.

Aditional data

Myth Front End Log:

Starting mythfrontend.real..
2010-11-03 15:12:12.088 mythfrontend version: branches/release-0-24-fixes [27085] www.mythtv.org
2010-11-03 15:12:12.088 Using runtime prefix = /usr
2010-11-03 15:12:12.088 Using configuration directory = /home/dpeale/.mythtv
2010-11-03 15:12:12.089 ThreadPool:HTTP: Initial 1, Max 5, Timeout 60000
2010-11-03 15:12:13.416 Empty LocalHostName.
2010-11-03 15:12:13.416 Using localhost value of Compromise
2010-11-03 15:12:13.422 New DB connection, total: 1
2010-11-03 15:12:13.425 Connected to database 'mythconverg' at host: localhost
2010-11-03 15:12:13.429 Closing DB connection named 'DBManager0'
2010-11-03 15:12:13.430 Connected to database 'mythconverg' at host: localhost
2010-11-03 15:12:13.431 Current locale en_US
2010-11-03 15:12:13.431 Reading locale defaults from /usr/share/mythtv//locales/en_us.xml
2010-11-03 15:12:13.640 ScreenSaverX11Private: Gnome screen saver support enabled
2010-11-03 15:12:13.641 DPMS is active.
2010-11-03 15:12:13.693 Desktop video mode: 2560x1600 59.860 Hz
2010-11-03 15:12:13.916 Enabled verbose msgs:  important general
2010-11-03 15:12:13.919 Loading en_us translation for module mythfrontend
2010-11-03 15:12:13.924 LIRC, Error: Failed to connect to Unix socket '/var/run/lirc/lircd'
			eno: No such file or directory (2)
2010-11-03 15:12:13.924 JoystickMenuThread: Joystick disabled - Failed to read /home/dpeale/.mythtv/joystickmenurc
2010-11-03 15:12:13.948 Using Frameless Window
2010-11-03 15:12:14.025 Using the Qt painter
2010-11-03 15:12:14.274 Current MythTV Schema Version (DBSchemaVer): 1264
2010-11-03 15:12:14.574 ThemeInfo, Warning: Unable to open themeinfo.xml for /usr/share/mythtv/themes/BlackCurves-OSD/themeinfo.xml
2010-11-03 15:12:14.574 ThemeInfo, Error: The theme (/usr/share/mythtv/themes/BlackCurves-OSD) is missing a themeinfo.xml file.
2010-11-03 15:12:14.575 ThemeInfo, Warning: Unable to open themeinfo.xml for /usr/share/mythtv/themes/Gray-OSD/themeinfo.xml
2010-11-03 15:12:14.575 ThemeInfo, Error: The theme (/usr/share/mythtv/themes/Gray-OSD) is missing a themeinfo.xml file.
2010-11-03 15:12:14.805 Pulse: PulseAudio suspend OK
2010-11-03 15:12:15.002 Pulse: PulseAudio resume OK
2010-11-03 15:12:15.095 Registering Internal as a media playback plugin.
2010-11-03 15:12:15.114 Loading en_us translation for module mytharchive
2010-11-03 15:12:15.157 MediaMonitorUnix::AddDevice() - empty device path.
2010-11-03 15:12:15.158 MediaMonitorUnix::AddDevice() - empty device path.
2010-11-03 15:12:15.158 MediaMonitorUnix::AddDevice() - empty device path.
2010-11-03 15:12:15.159 MediaMonitorUnix::AddDevice() - empty device path.
2010-11-03 15:12:15.159 MediaMonitorUnix::AddDevice() - empty device path.
2010-11-03 15:12:15.160 MediaMonitorUnix::AddDevice() - empty device path.
2010-11-03 15:12:15.161 MediaMonitorUnix::AddDevice() - empty device path.
2010-11-03 15:12:15.161 MediaMonitorUnix::AddDevice() - empty device path.
2010-11-03 15:12:15.161 MediaMonitorUnix::AddDevice() - empty device path.
2010-11-03 15:12:15.162 MonitorRegisterExtensions(0x100, gif,jpg,png)
2010-11-03 15:12:15.162 Loading en_us translation for module mythgallery
2010-11-03 15:12:15.168 Current MythVideo Schema Version (mythvideo.DBSchemaVer): 1038
2010-11-03 15:12:15.184 Loading en_us translation for module mythvideo
2010-11-03 15:12:15.188 Loading en_us translation for module mythweather
2010-11-03 15:12:15.354 Found mainmenu.xml for theme 'MythCenter-wide'
2010-11-03 15:12:15.378 MythCoreContext: Connecting to backend server: 192.168.63.3:6543 (try 1 of 1)
2010-11-03 15:12:15.379 Using protocol version 63
2010-11-03 15:12:24.471 New DB connection, total: 2
2010-11-03 15:12:24.472 Connected to database 'mythconverg' at host: localhost
2010-11-03 15:12:24.517 TV: Attempting to change from None to WatchingLiveTV
2010-11-03 15:12:24.518 MythCoreContext: Connecting to backend server: 192.168.63.3:6543 (try 1 of 1)
2010-11-03 15:12:24.518 Using protocol version 63
2010-11-03 15:12:24.537 Spawning LiveTV Recorder -- begin
2010-11-03 15:12:24.592 Spawning LiveTV Recorder -- end
2010-11-03 15:12:24.608 We have a playbackURL(/var/lib/mythtv/recordings/1045_20101103151224.mpg) & cardtype(DUMMY)
2010-11-03 15:12:24.608 We have a RingBuffer
2010-11-03 15:12:24.638 AudioPlayer: Disabling Audio, params(0,2,44100)
2010-11-03 15:12:24.718 Pulse: PulseAudio suspend OK
2010-11-03 15:12:24.740 AudioOutput Error: Aborting Audio Reconfigure. Invalid audio parameters ch 2 fmt 0 @ 44100Hz
2010-11-03 15:12:24.740 AudioPlayer: Disabling Audio, reason is: Aborting Audio Reconfigure. Invalid audio parameters ch 2 fmt 0 @ 44100Hz
2010-11-03 15:12:24.740 playCtx, Error: Aborting Audio Reconfigure. Invalid audio parameters ch 2 fmt 0 @ 44100Hz
2010-11-03 15:12:24.748 VideoOutputXv: XVideo Adaptor Name: 'Radeon Textured Video'
2010-11-03 15:12:24.764 OSD: Base theme size: 1280x720
2010-11-03 15:12:24.764 OSD: Scaling factors: 0.5625x0.8
2010-11-03 15:12:24.860 OSD: Base theme size: 1280x720
2010-11-03 15:12:24.860 OSD: Scaling factors: 0.5625x0.8
2010-11-03 15:12:24.860 OSD: Base theme size: 1280x720
2010-11-03 15:12:24.860 OSD: Scaling factors: 0.5625x0.8
greedyhdeint: size changed from 0 x 0 -> 720 x 576
2010-11-03 15:12:24.876 Player(0): Video timing method: DRM
2010-11-03 15:12:24.892 TV: Changing from None to WatchingLiveTV
2010-11-03 15:12:24.892 TV: State is LiveTV & mctx == ctx
2010-11-03 15:12:24.894 TV: UpdateOSDInput done
2010-11-03 15:12:24.894 TV: UpdateLCD done
2010-11-03 15:12:24.894 TV: ITVRestart done
2010-11-03 15:12:25.006 VideoOutput: Created YV12 OSD.
2010-11-03 15:12:25.026 ScreenSaverX11Private: DPMS Deactivated 1
greedyhdeint: size changed from 0 x 0 -> 720 x 576
2010-11-03 15:12:25.590 Player(0): DecoderGetFrame() called with NULL decoder.
2010-11-03 15:12:26.087 RingBuf(/var/lib/mythtv/recordings/1045_20101103151225.mpg): Waited 0.2 seconds for data 
			to become available... 9892 < 32768
2010-11-03 15:12:26.087 Checking to see if there's a new livetv program to switch to..
greedyhdeint: size changed from 0 x 0 -> 704 x 480
2010-11-03 15:12:26.275 VideoOutputXv: XVideo Adaptor Name: 'Radeon Textured Video'
2010-11-03 15:12:26.292 OSD: Base theme size: 1280x720
2010-11-03 15:12:26.292 OSD: Scaling factors: 0.55x0.666667
2010-11-03 15:12:26.366 OSD: Base theme size: 1280x720
2010-11-03 15:12:26.366 OSD: Scaling factors: 0.55x0.666667
2010-11-03 15:12:26.367 AFD: Opened codec 0x7f3ac845bed0, id(MPEG2VIDEO) type(Video)
2010-11-03 15:12:26.367 AFD: codec AC3 has 2 channels
2010-11-03 15:12:26.367 AFD: Opened codec 0x7f3ac84a9f80, id(AC3) type(Audio)
2010-11-03 15:12:26.367 AFD: codec AC3 has 1 channels
2010-11-03 15:12:26.367 AFD: Opened codec 0x7f3ac8492ac0, id(AC3) type(Audio)
2010-11-03 15:12:26.520 Pulse: PulseAudio resume OK
2010-11-03 15:12:26.620 Pulse: PulseAudio suspend OK
2010-11-03 15:12:26.649 AO: Opening audio device 'surround71:CARD=Intel,DEV=0' ch 6(2) sr 48000 sf signed 32 bit reenc 0
2010-11-03 15:12:26.650 Opening ALSA audio device 'surround71:CARD=Intel,DEV=0'.
2010-11-03 15:12:26.828 AudioPlayer: Enabling Audio
2010-11-03 15:12:27.153 VideoOutput: Created YV12 OSD.
2010-11-03 15:12:33.090 BrowseDispInfo()
2010-11-03 15:12:33.090 BrowseStart()
2010-11-03 15:12:33.094 browsechanid: 0 -> 1021
2010-11-03 15:12:35.911 BrowseEnd()
greedyhdeint: size changed from 0 x 0 -> 704 x 480
2010-11-03 15:12:39.362 RingBuf(/var/lib/mythtv/recordings/1021_20101103151237.mpg) Error: OpenFile(): File too small (0B).
2010-11-03 15:12:39.362 Player(0), Error: JumpToProgram's OpenFile failed (card type: HDHOMERUN).
2010-11-03 15:12:39.362 
LiveTVChain has 4 entries
   DUMMY: 1045 (15:12:24 to 15:12:25)
  HDHOMERUN: 1045 (15:12:25 to 15:12:36) discontinuous
   DUMMY: 1021 (15:12:36 to 15:12:36) discontinuous
* HDHOMERUN: 1021 (15:12:37 to 16:00:00) discontinuous

2010-11-03 15:12:39.362 Player(0), Error: Unknown recorder error, exiting decoder
2010-11-03 15:12:39.440 TV: Attempting to change from WatchingLiveTV to None
2010-11-03 15:12:39.447 MythPainter: 18 images not yet de-allocated.
2010-11-03 15:12:39.639 Pulse: PulseAudio resume OK
2010-11-03 15:12:39.731 TV: Changing from WatchingLiveTV to None
2010-11-03 15:12:39.752 ScreenSaverX11Private: DPMS Reactivated 1
2010-11-03 15:12:39.752 TV: Attempting to change from None to None
2010-11-03 15:12:39.798 TV: Attempting to change from None to WatchingLiveTV
2010-11-03 15:12:39.798 MythCoreContext: Connecting to backend server: 192.168.63.3:6543 (try 1 of 1)
2010-11-03 15:12:39.799 Using protocol version 63
2010-11-03 15:12:39.817 Spawning LiveTV Recorder -- begin
2010-11-03 15:12:39.871 Spawning LiveTV Recorder -- end
2010-11-03 15:12:39.891 We have a playbackURL(/var/lib/mythtv/recordings/1045_20101103151239.mpg) & cardtype(DUMMY)
2010-11-03 15:12:39.894 We have a RingBuffer
2010-11-03 15:12:39.895 playCtx, Error: Attempting to setup a player, but it already exists.
2010-11-03 15:12:39.895 TV Error: LiveTV not successfully started
2010-11-03 15:12:56.209 Pulse: Cleaning up PulseHandler
2010-11-03 15:12:56.209 Deleting UPnP client...
Error in my_thread_global_end(): 1 threads didn't exit

Excerpt from back end log:

2010-11-03 15:11:48.207 I'm idle now... shutdown will occur in 180 seconds.
2010-11-03 15:12:15.379 MainServer::ANN Playback
2010-11-03 15:12:15.386 adding: Compromise as a client (events: 0)
2010-11-03 15:12:15.393 MainServer::ANN Monitor
2010-11-03 15:12:15.402 adding: Compromise as a client (events: 1)
2010-11-03 15:12:24.518 MainServer::ANN Playback
2010-11-03 15:12:24.523 adding: Compromise as a client (events: 0)
2010-11-03 15:12:24.538 TVRec(1): Changing from None to WatchingLiveTV
2010-11-03 15:12:24.555 TVRec(1): HW Tuner: 1->1
2010-11-03 15:12:24.570 LoadFromScheduler(): Error, called from backend.
2010-11-03 15:12:24.572 AutoExpire: CalcParams(): Max required Free Space: 3.0 GB w/freq: 14 min
2010-11-03 15:12:25.164 Finished recording Bosley: Hair Loss Answers: channel 1045
2010-11-03 15:12:25.184 LoadFromScheduler(): Error, called from backend.
2010-11-03 15:12:25.186 AutoExpire: CalcParams(): Max required Free Space: 3.0 GB w/freq: 14 min
2010-11-03 15:12:25.211 Finished recording Bosley: Hair Loss Answers: channel 1045
2010-11-03 15:12:26.829 RecBase(1:1): GetKeyframePositions(28,9223372036854775807,#2) out of 6
2010-11-03 15:12:27.070 RecBase(1:1): GetKeyframePositions(28,9223372036854775807,#2) out of 6
2010-11-03 15:12:36.025 TVRec(1): HW Tuner: 1->1
2010-11-03 15:12:36.039 LoadFromScheduler(): Error, called from backend.
2010-11-03 15:12:36.041 AutoExpire: CalcParams(): Max required Free Space: 3.0 GB w/freq: 14 min
2010-11-03 15:12:36.062 Finished recording Bosley: Hair Loss Answers: channel 1045
2010-11-03 15:12:36.205 MainServer::ANN Playback
2010-11-03 15:12:36.215 adding: Compromise as a client (events: 0)
2010-11-03 15:12:36.224 MainServer::ANN Monitor
2010-11-03 15:12:36.234 adding: Compromise as a client (events: 1)
2010-11-03 15:12:36.788 DTVSM(1016A87D-0) Error: Wrong PMT; pmt->pn(1) desired(2)
2010-11-03 15:12:36.833 DTVSM(1016A87D-0) Error: Wrong PMT; pmt->pn(3) desired(2)
2010-11-03 15:12:36.911 Finished recording The Dr. Oz Show "Secrets the Food Industry Doesn't Want You to Know": channel 1021
2010-11-03 15:12:36.927 LoadFromScheduler(): Error, called from backend.
2010-11-03 15:12:36.928 AutoExpire: CalcParams(): Max required Free Space: 3.0 GB w/freq: 14 min
2010-11-03 15:12:36.935 recording already exists...
2010-11-03 15:12:36.980 Finished recording The Dr. Oz Show "Secrets the Food Industry Doesn't Want You to Know": channel 1021
2010-11-03 15:12:39.640 TVRec(1): Changing from WatchingLiveTV to None
2010-11-03 15:12:39.712 Finished recording The Dr. Oz Show "Secrets the Food Industry Doesn't Want You to Know": channel 1021
2010-11-03 15:12:39.799 MainServer::ANN Playback
2010-11-03 15:12:39.806 adding: Compromise as a client (events: 0)
2010-11-03 15:12:39.819 TVRec(1): Changing from None to WatchingLiveTV
2010-11-03 15:12:39.825 TVRec(1): HW Tuner: 1->1
2010-11-03 15:12:39.853 LoadFromScheduler(): Error, called from backend.
2010-11-03 15:12:39.854 AutoExpire: CalcParams(): Max required Free Space: 3.0 GB w/freq: 14 min
2010-11-03 15:12:39.896 TVRec(1): Changing from WatchingLiveTV to None
2010-11-03 15:12:39.922 Finished recording Bosley: Hair Loss Answers: channel 1045
2010-11-03 15:12:59.247 I'm idle now... shutdown will occur in 180 seconds.
2010-11-03 15:14:05.916 Expiring 0 MB for 1045 at 2010-11-03T15:12:24 => "Bosley: Hair Loss Answers"
2010-11-03 15:14:05.921 Expiring 3 MB for 1045 at 2010-11-03T15:12:25 => "Bosley: Hair Loss Answers"
2010-11-03 15:14:05.932 Expiring 0 MB for 1021 at 2010-11-03T15:12:37 => "The Dr. Oz Show":"Secrets the Food Industry Doesn't Want You to Know"
Someone is still logged in, don't shut down!

Attachments (5)

mythfrontend.log (153.2 KB) - added by Douglas_Peale@… 3 years ago.
log durring "error opening jump program file"
mythbackend.log (55.5 KB) - added by Douglas_Peale@… 3 years ago.
Backend with extra logging options added.
mythfrontend.2.log (185.9 KB) - added by Douglas_Peale@… 3 years ago.
front end log taken at same time as backend log
v0.24-151-g1a69c92.tar.gz (136.5 KB) - added by brianafischer@… 3 years ago.
frontend and backend logs running fixes/0.24 [v0.24-151-g1a69c92]
another_v0.24-151-g1a69c92.tar.gz (158.8 KB) - added by anonymous 3 years ago.
frontend and backend logs

Download all attachments as: .zip

Change History (40)

comment:1 Changed 3 years ago by robertm

  • Resolution set to Invalid
  • Status changed from new to closed

Dupe of #9034 and many many others. Please search existing tickets before opening new ones.

comment:2 Changed 3 years ago by robertm

  • Resolution Invalid deleted
  • Status changed from closed to new

Reopening until I can clarify something, this may be two distinct issues with a common symptom. Ringbuffer optimizations may be at issue here.

comment:3 Changed 3 years ago by robertm

  • Owner set to danielk
  • Status changed from new to assigned

comment:4 Changed 3 years ago by gilson585@…

I too am experiencing the same issue since upgrading to 0.24 currently running build 27299 from mythbuntu autobuilds. This only occurs on my analog tuner and does not affect my digital tuners. I can however go to a dig channel and then back to analog no prob. Sometimes crashes to desktop or plays interlaced video with wrong A/R ratio and no sound if I try to change channels directly on analog tuner. I also posted here http://ubuntuforums.org/showthread.php?t=1626755

comment:5 Changed 3 years ago by robertm

  • Ticket locked set

gilson, read the ticket howto. This is your second "me too" (and locked ticket of the morning. STOP, or risk being banned.

comment:6 Changed 3 years ago by tralph

  • Status changed from assigned to infoneeded

Is this still a problem with the latest code?

comment:7 Changed 3 years ago by wagnerrp

  • Ticket locked unset

comment:8 Changed 3 years ago by Douglas_Peale@…

What is your definition of "latest code?"

It is still a problem on the version I am running.

Last update:
mythtv-database:amd64 (0.24.0+fixes.20110201.14bfdc3-0ubuntu0mythbuntu2, 0.24.0+fixes.20110202.cd0acb0-0ubuntu0mythbuntu2),
mythmusic:amd64 (0.24.0+fixes.20110201.14bfdc3-0ubuntu0mythbuntu2, 0.24.0+fixes.20110202.cd0acb0-0ubuntu0mythbuntu2),
mythtv:amd64 (0.24.0+fixes.20110201.14bfdc3-0ubuntu0mythbuntu2, 0.24.0+fixes.20110202.cd0acb0-0ubuntu0mythbuntu2),
mytharchive:amd64 (0.24.0+fixes.20110201.14bfdc3-0ubuntu0mythbuntu2, 0.24.0+fixes.20110202.cd0acb0-0ubuntu0mythbuntu2),
mythtv-themes:amd64 (0.24.0+fixes.20110201.14bfdc3-0ubuntu0mythbuntu2, 0.24.0+fixes.20110202.cd0acb0-0ubuntu0mythbuntu2),
mythtv-theme-metallurgy:amd64 (0.24.0+fixes.20110201.14bfdc3-0ubuntu0mythbuntu2, 0.24.0+fixes.20110202.cd0acb0-0ubuntu0mythbuntu2),
mythgallery:amd64 (0.24.0+fixes.20110201.14bfdc3-0ubuntu0mythbuntu2, 0.24.0+fixes.20110202.cd0acb0-0ubuntu0mythbuntu2),
libmyth-python:amd64 (0.24.0+fixes.20110201.14bfdc3-0ubuntu0mythbuntu2, 0.24.0+fixes.20110202.cd0acb0-0ubuntu0mythbuntu2),
mythtv-common:amd64 (0.24.0+fixes.20110201.14bfdc3-0ubuntu0mythbuntu2, 0.24.0+fixes.20110202.cd0acb0-0ubuntu0mythbuntu2),
mythweb:amd64 (0.24.0+fixes.20110201.14bfdc3-0ubuntu0mythbuntu2, 0.24.0+fixes.20110202.cd0acb0-0ubuntu0mythbuntu2),
mythtv-theme-childish:amd64 (0.24.0+fixes.20110201.14bfdc3-0ubuntu0mythbuntu2, 0.24.0+fixes.20110202.cd0acb0-0ubuntu0mythbuntu2),
mythtv-backend:amd64 (0.24.0+fixes.20110201.14bfdc3-0ubuntu0mythbuntu2, 0.24.0+fixes.20110202.cd0acb0-0ubuntu0mythbuntu2),
mythtv-theme-graphite:amd64 (0.24.0+fixes.20110201.14bfdc3-0ubuntu0mythbuntu2, 0.24.0+fixes.20110202.cd0acb0-0ubuntu0mythbuntu2),
mythtv-dbg:amd64 (0.24.0+fixes.20110201.14bfdc3-0ubuntu0mythbuntu2, 0.24.0+fixes.20110202.cd0acb0-0ubuntu0mythbuntu2),
libmythtv-perl:amd64 (0.24.0+fixes.20110201.14bfdc3-0ubuntu0mythbuntu2, 0.24.0+fixes.20110202.cd0acb0-0ubuntu0mythbuntu2),
mythtv-backend-master:amd64 (0.24.0+fixes.20110201.14bfdc3-0ubuntu0mythbuntu2, 0.24.0+fixes.20110202.cd0acb0-0ubuntu0mythbuntu2),
mythtv-theme-arclight:amd64 (0.24.0+fixes.20110201.14bfdc3-0ubuntu0mythbuntu2, 0.24.0+fixes.20110202.cd0acb0-0ubuntu0mythbuntu2),
mythweather:amd64 (0.24.0+fixes.20110201.14bfdc3-0ubuntu0mythbuntu2, 0.24.0+fixes.20110202.cd0acb0-0ubuntu0mythbuntu2),
mythvideo:amd64 (0.24.0+fixes.20110201.14bfdc3-0ubuntu0mythbuntu2, 0.24.0+fixes.20110202.cd0acb0-0ubuntu0mythbuntu2),
mythtv-frontend:amd64 (0.24.0+fixes.20110201.14bfdc3-0ubuntu0mythbuntu2, 0.24.0+fixes.20110202.cd0acb0-0ubuntu0mythbuntu2),
mythtv-theme-mythbuntu:amd64 (0.24.0+fixes.20110201.14bfdc3-0ubuntu0mythbuntu2, 0.24.0+fixes.20110202.cd0acb0-0ubuntu0mythbuntu2),
libmyth-0.24-0:amd64 (0.24.0+fixes.20110201.14bfdc3-0ubuntu0mythbuntu2, 0.24.0+fixes.20110202.cd0acb0-0ubuntu0mythbuntu2),
mythtv-transcode-utils:amd64 (0.24.0+fixes.20110201.14bfdc3-0ubuntu0mythbuntu2, 0.24.0+fixes.20110202.cd0acb0-0ubuntu0mythbuntu2)

comment:9 Changed 3 years ago by tralph

I'm not sure if the changes that might help are included in your build. Please retry with a version newer than 2011-02-02. Some changes were made in the last day or so that increases the time we wait for the ring buffer to be created with enough data to start playback.

comment:10 Changed 3 years ago by Douglas_Peale@…

My system update this morning with 20110203.

Still no joy. Still get "Error opening jump program file buffer" when changing from an SD channel to an HD channel if an HD channel has not yet been successfully tuned yet.

It has actually gotten worse. My work around is no longer completely effective. An input source must begin on an HD channel before problem free channel changing is possible. I can switch from source A showing SD to source B showing HD, then change channels on source B between HD and SD or vise versa, but if I go back to source A, attempting to change to an HD channel causes the error. If source B happened to be on an SD channel when first selected, attempting to change to an HD channel wall cause the error.

comment:11 Changed 3 years ago by tralph

Douglas, please attach frontend logs with -v playback,file,extra.

Changed 3 years ago by Douglas_Peale@…

log durring "error opening jump program file"

comment:12 Changed 3 years ago by Douglas_Peale@…

added log file as an attachment.

It was created by running this command on a command line:

$ mythfrontend -v playback,file,extra >mythfronend.log

While it was running, I started "Watch TV" It started on an SD channel (2) I tried changing to an HD channel (2.1), it waited for a while and exited "Watch TV" with the error message.

If you need to have me try something else, let me know.

comment:13 Changed 3 years ago by tralph

Doug, thanks for the log. Nothing appears wrong with the frontend. It just never gets any data which points to the backend having an issue. Please provide logs from the backend with record,file,extra. Thanks.

comment:14 Changed 3 years ago by Douglas_Peale@…

Not quite sure how to add the options to the backend since it runs automatically. Give me some instructions and I'll do it. It will have to be tomorrow though since it is kind of late tonight.

Changed 3 years ago by Douglas_Peale@…

Backend with extra logging options added.

Changed 3 years ago by Douglas_Peale@…

front end log taken at same time as backend log

comment:15 Changed 3 years ago by Douglas_Peale@…

I got these instructions from the mythtv-users mailing list:

Depends which version you're running, but on 10.04 you have to edit /etc/init/mythtv-backend.conf, and append the option to the end of the command in the script block (line 23 on my machine). The line should end up something like this:

LANG=$LANG /usr/bin/mythbackend --logfile /var/log/mythtv/mythbackend.log --user mythtv -v "record,file,extra"

I generated the front end log the same way as before, so the backend and frontend logs are for the same events.

comment:16 Changed 3 years ago by tralph

Douglas, I looked at the backend log but don't see anything suspicious. I'm not experienced in this area so someone else will need to take a look when they get a chance.

comment:17 Changed 3 years ago by Douglas_Peale@…

This bug is 100% repeatable, let me know when someone thinks of another test I can run.

Changed 3 years ago by brianafischer@…

frontend and backend logs running fixes/0.24 [v0.24-151-g1a69c92]

Changed 3 years ago by anonymous

frontend and backend logs

comment:18 follow-up: Changed 3 years ago by gabriel.j.michael@…

Hi, I am also experiencing this bug. I've attached frontend and backend logs with the logging options discussed above. Running 0.24-fixes, MythTV version g1a69c92.

The logs show a successful initial channel tuning, a successful channel change, and a failed channel change, in that order. Please let me know if I can do any testing. Sorry, accidentally forgot to put name for the file upload, its the "another" by anonymous.

comment:19 in reply to: ↑ 18 Changed 3 years ago by mdean

Replying to gabriel.j.michael@…:

Hi, I am also experiencing this bug. I've attached frontend and backend logs with the logging options discussed above. Running 0.24-fixes, MythTV version g1a69c92.

Gabriel, 0.24-fixes, MythTV version g1a69c92 is from Nov 23, 2010, and all the Live TV fixes went in within the last week. You need to use a version of MythTV 0.24-fixes newer than Feb 10, 2011. Please ask on the mythtv-users mailing list if you have questions on how to upgrade to a new-enough version with your distro.

comment:20 Changed 3 years ago by mdean

OK, the original commit was Nov 23, 2010, but it was backported to 0.24-fixes on Feb 2, 2011. You still need a newer version to get the Live TV fixes. Apologies for the confusion--I'm still trying to figure out github (which seems to think the date a change was backported to a branch is irrelevant).

comment:21 Changed 3 years ago by brianafischer@…

I just confirmed this issue is resolved using MythTV Version v0.24-166-g3d55e51.

comment:22 Changed 3 years ago by Douglas_Peale@…

I can't quite confirm success. I did not have any trouble changing channels on my digital tuners, and I was able to switch to my (never working) analog tuner without the "Error opening jump program file buffer", but when I tried changing channels on my analog tuner, I did get this error.

comment:23 Changed 3 years ago by tralph

Douglas, which distro/kernel are you using? I'm only asking since people have observed dvb issues with newer distro/kernels. Your problem actually seems like the device never sends any data which might point to a driver/kernel issue.

comment:24 Changed 3 years ago by Douglas_Peale@…

Ubuntu 10.10
sysinfo crashes with an exception in Gtk# so I can't use that to identify the kernel

in history.log I found this:
Start-Date: 2011-02-15 10:15:38
Install: linux-headers-2.6.35-27-generic:amd64 (2.6.35-27.47), linux-headers-2.6.35-27:amd64 (2.6.35-27.47), linux-image-2.6.35-27-generic:amd64 (2.6.35-27.47)

Is this sufficient?

In case my previous message was not clear on the subject, I have definitely seen an improvement in the behavior of live TV, it appears that my digital tuners are working correctly now, and it is only my analog tuner causing problems now.

comment:25 Changed 3 years ago by robertm

  • Status changed from infoneeded to assigned

comment:26 Changed 3 years ago by dac437@…

I had this channel switching problem in v0.24.1-9-g3657f31, but I fixed it by setting "Use Quick Tune" to "Live TV Only". This setting in in the "Input Connections" menu of mythtv-setup. I am using an HVR-1850.

comment:27 Changed 3 years ago by salimthedream@…

I don't understand how to fix this. What does "Change to a different physical tuner than the default." mean? I only have one physical tuner.

comment:28 Changed 3 years ago by Douglas_Peale@…

If you only have one tuner, the work around won't work for you.

comment:29 Changed 3 years ago by paul.lugaro@…

Hi all,

It's really a problem. I have the same issue and, in fact, I always had this problem since I bought my tuner card. today I updated MythTV via yum on Fedora, hoping that the problem after 2 or 3 updates via yum will be ok but it's not. Because I have also only 1 physical card, I just don't know how to bypass the problem. In fact, the purpose to bought a TV card was to use in with MythTV and I just can't see more than 1 channel, the start channel. When I'm trying to change the channel, whatever, I also have this message "Error opening jump program file buffer". I'm really sorry but I don't understand why such critical problem, concerning a lot of people and so reproducible still exist, after such long time. I will give you any details/logs/report/information if you need them because, as a lot of people, I just and only want to see TV with MythTV.
Just to conclude that I tried a lot of things and spent a lot of time trying to solve his problem, without chance.
Thank you.

I'm on Fedora 14: 2.6.35.13-91.fc14.x86_64
My MythTV version (installed from yum): 0.24.1-2.fc14.x86_64
Analogic channels, in NTSC, in Peru (Cable Magico)
My TV tuner card: KWorld PCI Analog TV Card - PVR-TV 7134SE
lspci: Philips Semiconductors SAA7134/SAA7135HL Video Broadcast Decoder based

comment:30 Changed 3 years ago by mdean

  • Summary changed from "Error opening jump program file buffer" when changing channels in live TV to Unable to change from SDTV channel to HDTV channel in Live TV

Please take all the discussion and "me too" posts to the users mailing list. This ticket is already long enough that it will be hard for developers to find the important/relevant information in the 30 comments.

The generic error message, "Error opening jump program file buffer," describes the final symptom of many different problems--the file MythTV is supposed to play back in Live TV doesn't exist. This problem can be caused by system or MythTV misconfiguration or, in some cases, MythTV code failures.

Therefore, it is quite possible some of these "me too" posts are actually seeing different problems (such as having incorrect file system permissions, using NFS without disabling file system attribute caching, having incorrect times on frontend or backend systems, having misconfigured Input Connections, or many other problems with the underlying system) and can fix their configurations. This applies especially to those who have only NTSC (SDTV) channels and a single tuner (because, obviously, they cannot have a case where they switch from SDTV to HDTV channels).

Until we know it's a MythTV code failure, discussion should occur on list. And, even once we find it's a MythTV code failure, we need to identify whether it's the same issue that was reported here or if it needs its own ticket. And, if you are not seeing the same issue as the original reporter, posting to this ticket is not going to help you get your issue fixed (as you won't get instructions on how to fix system misconfiguration here and the developer who fixes this issue will be focused on the originally reported issue).

In other words, having the message, "Error opening jump program file buffer," in your logs messages does /not/ mean you are seeing the same issue as the original reporter.

comment:31 Changed 3 years ago by paul.lugaro@…

Hi,
Well, I posted my message just because while I was looking for any solution for my problem, I found this post. I don't want to analyse any post to become a debugger. I'm just a common user, with a problem that avoid me to use a software as I want, offering my little help if I can of course, sharing that I saw the same error message. As you will understand, it's not my role to determine if people have exactly the same issue. My last post was just a comment.
MythTV is really a nice program that I use daily and I thank all the team to give us this great tool.
So please don't take my last post as a critic but only a post to share that another user have the same error message, using the same option.
Have a nice day.

comment:32 Changed 3 years ago by robertm

  • Ticket locked set

comment:33 Changed 3 years ago by mdean

  • Summary changed from Unable to change from SDTV channel to HDTV channel in Live TV to Channel changes involving analog tuner fail

Trying to better summarize information in comments.

comment:34 Changed 2 years ago by danielk

  • Status changed from assigned to accepted

May be a duplicate of #9830 and #9846.

comment:35 Changed 2 years ago by danielk

  • Resolution set to Invalid
  • Status changed from accepted to closed

It looks like the problem here was that the channel info was out of date and the UI was not running the dummy recorder but instead trying to play an empty file. The dummy recorder does appear to be working on channel changes in trunk.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'new'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.