Opened 9 years ago

Closed 9 years ago

#9183 closed defect (Duplicate)

Mythfrontend crashes on "scene changes".

Reported by: j2@… Owned by:
Priority: minor Milestone: 0.24
Component: MythTV - General Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

(Trunk 27105, Ubuntu 10.04, PVR-500)

Right, this problem started appearing for me about two weeks back in trunk. I am honestly not sure which rev i was on before. (And I am not sure if it is possible to check?)

I mulled it out on the users-list, but didn't get any applicable feedback, so I decided to give it a trac-run.

The problem now is that in most "scene changes", as in if the show goes to "all black screen" or you come "in or our" of a commercial... Or even moving from one commercial segment to another, Mythfrontend just crashes. Not all recordings behave this way, but I would say that all recording from some channgels DO behave this way. (THey are all recorded from the same STB to composite on the PVR).

Below is a log dump of me starting to watch a recording, until it crashes. SOmetimes (very rarely) I also see

"pure virtual method called terminate called without an active exception "

Anything I can / need to do to help with more info. Let me know.

2010-11-03 20:57:07.969 TV: Attempting to change from None to WatchingRecording
2010-11-03 20:57:07.980 MythCoreContext: Connecting to backend server: 192.168.0.42:6543 (try 1 of 1)
2010-11-03 20:57:07.980 Using protocol version 63
2010-11-03 20:57:08.115 AudioPlayer: Disabling Audio, params(0,2,44100)
2010-11-03 20:57:08.250 AudioOutput Error: Aborting Audio Reconfigure. Invalid audio parameters ch 2 fmt 0 @ 44100Hz
2010-11-03 20:57:08.251 AudioPlayer: Disabling Audio, reason is: Aborting Audio Reconfigure. Invalid audio parameters ch 2 fmt 0 @ 44100Hz
2010-11-03 20:57:08.251 playCtx, Error: Aborting Audio Reconfigure. Invalid audio parameters ch 2 fmt 0 @ 44100Hz
2010-11-03 20:57:08.363 AFD Warning: ScanATSCCaptionStreams() called with no PMT
2010-11-03 20:57:08.363 AFD: Opened codec 0xaadbaf40, id(MPEG2VIDEO) type(Video)
2010-11-03 20:57:08.363 AFD: codec MP2 has 2 channels
2010-11-03 20:57:08.363 AFD: Opened codec 0xaad7b540, id(MP2) type(Audio)
2010-11-03 20:57:08.450 AO: Opening audio device '/dev/dsp' ch 2(2) sr 48000 sf signed 16 bit reenc 0
2010-11-03 20:57:08.451 AudioPlayer: Enabling Audio
2010-11-03 20:57:08.524 VideoOutputXv: XVideo Adaptor Name: 'NV17 Video Texture'
2010-11-03 20:57:08.561 [mpeg2video @ 0x4e44660]warning: first frame is no keyframe
2010-11-03 20:57:08.565 [mpeg2video @ 0x4e44660]warning: first frame is no keyframe
2010-11-03 20:57:08.570 OSD: Base theme size: 1920x1080
2010-11-03 20:57:08.571 OSD: Scaling factors: 0.375x0.533333
2010-11-03 20:57:08.631 OSD: Base theme size: 1920x1080
2010-11-03 20:57:08.631 OSD: Scaling factors: 0.375x0.533333
2010-11-03 20:57:08.631 OSD: Base theme size: 1920x1080
2010-11-03 20:57:08.631 OSD: Scaling factors: 0.375x0.533333
YadifDeint: In-Pixformat = 1 Out-Pixformat=1
YadifDeint: size changed from 0 x 0 -> 720 x 576
YadifDeint: Using existing thread.
2010-11-03 20:57:08.636 Player(2): Video timing method: USleep with busy wait
2010-11-03 20:57:08.637 TV: Changing from None to WatchingRecording
2010-11-03 20:57:08.705 VideoOutput: Created YV12 OSD.
2010-11-03 21:00:01.582 TV: Attempting to change from WatchingRecording to WatchingPreRecorded
2010-11-03 21:00:01.583 TV: Changing from WatchingRecording to WatchingPreRecorded
2010-11-03 21:03:27.269 OSD: Base theme size: 1920x1080
2010-11-03 21:03:27.269 OSD: Scaling factors: 0.28125x0.4
2010-11-03 21:03:27.361 OSD: Base theme size: 1920x1080
2010-11-03 21:03:27.361 OSD: Scaling factors: 0.28125x0.4
2010-11-03 21:03:29.476 OSD: Base theme size: 1920x1080
2010-11-03 21:03:29.476 OSD: Scaling factors: 0.375x0.533333

Attachments (1)

gdb.txt (72.7 KB) - added by Janne Johansson <j2@…> 9 years ago.

Download all attachments as: .zip

Change History (7)

comment:1 Changed 9 years ago by otto at kolsi dot fi

dupe of #9166 ?

comment:2 Changed 9 years ago by Janne Johansson <j2@…>

Ok, I just noticed something.

The channel that does NOT cause this broadcasts all their content in 16:9. THe channel(s) that DOES cause this changes between 16:9 and 4:3.

comment:3 Changed 9 years ago by sphery

Priority: majorminor
Status: newinfoneeded_new

Please attach a backtrace at the point of the crash, as described at http://www.mythtv.org/wiki/Debugging . Thanks.

Changed 9 years ago by Janne Johansson <j2@…>

Attachment: gdb.txt added

comment:4 Changed 9 years ago by Janne Johansson <j2@…>

Since I have no idea how such a file _should_ look, I hope i rebuilt MyhtTV correctly.

ONe slight change. When running via gdb, mythtv doesn't crash to desktop, but just "locks up" when the problem occurs, but maybe that is as expected?

comment:5 Changed 9 years ago by Janne Johansson <j2@…>

And my comment in "Comment 2" just went out through the window. I just got the same behaviour on the "16:9 only" channel.

comment:6 Changed 9 years ago by markk

Milestone: unknown0.24
Resolution: Duplicate
Status: infoneeded_newclosed

Duplicate of #9166

Note: See TracTickets for help on using tickets.