Modify
Warning Please read the Ticket HowTo before creating or commenting on a ticket. Failure to do so may cause your ticket to be rejected or result in a slower response.

Opened 3 years ago

Closed 2 years ago

#9233 closed defect (fixed)

Video res. higher than GUI -> video not scaled

Reported by: greg Owned by: danielk
Priority: minor Milestone: 0.25
Component: MythTV - Video Playback Version: 0.24-fixes
Severity: medium Keywords: video mode, resolution
Cc: Ticket locked: no

Description

When I select different resolutions for the GUI (720p) and Video (1080p), the video output mode is properly changed during playback, but the video itself is not upscaled. I will attach a screenshot and the fe log with -v playback. Having such a setup is desirable (for me) to be able to use the webbrowser in 720p mode (higher usability of window controls). Also, the UI themes work faster on my machine with that lower resolution.

Attachments (2)

fe.log (21.7 KB) - added by greg 3 years ago.
myth-resolution.jpg (18.3 KB) - added by greg 3 years ago.
note: video distortion from screenshooter not in sync with vo - pls ignore!

Download all attachments as: .zip

Change History (14)

Changed 3 years ago by greg

Changed 3 years ago by greg

note: video distortion from screenshooter not in sync with vo - pls ignore!

comment:1 Changed 3 years ago by robertm

  • Owner changed from janne to markk
  • Status changed from new to assigned

comment:2 Changed 3 years ago by markk

  • Milestone set to 0.25
  • Status changed from assigned to accepted

comment:3 Changed 3 years ago by dargllun@…

How well are my chances that a potential fix will be backported to 0.24-fixes?

comment:4 Changed 3 years ago by wagnerrp

  • Ticket locked set

Please keep such comments on the mailing list.

comment:5 Changed 3 years ago by markk

  • Ticket locked unset

comment:6 Changed 3 years ago by markk

  • Status changed from accepted to infoneeded

Greg

I can't reproduce this with any of my machines here. My gut feeling is that this is a driver bug although there is every possibility I'm missing something.

Can you confirm what your video hardware and driver versions are (I'm assuming ATI) and outline what settings you have enabled in Settings->Appearance->Theme/Screen? Settings.

Additionally, you may want to try alternative/latest versions of your driver to see if there is any improvement.

comment:7 Changed 3 years ago by dargllun@…

Hi Mark,

I'm indeed on AMD HD3200 HW, using the fairly recent r600g driver and a KMS kernel. In Appearance->Screen Settings(2) I have:
GUI: 1280x720, Video: 1920x1080,any,standard

I tested wit xv-blit and opengl output, same issue.

The resolution is correctly switched to 1080p when watching a video, and back to 720p when returning to the GUI. Its just that the display area is smaller, and still using the 720p dimensions.

There is one kind of funny thing: both with xv and opengl, the OSD menu appears to have some notion of that the picture is supposed to be wider. The horizontal dimension appears to be correct, and the right side is cut @ 1280. Vertically it's also higher than it would need to be for 720p.

So again: everything ok except the displayed video area.

Personally I very much doubt a driver bug, as the r600g is quite mature with such basic things, and in fact might even be superior to fglrx WRT to the xrandr implementation. Unfortunately I can't easily test fglrx right now, WAF would take a bad hit...

Let me know if you need more input.

comment:8 Changed 3 years ago by robertm

  • Status changed from infoneeded to assigned

comment:9 Changed 3 years ago by markk

  • Status changed from assigned to accepted

comment:10 Changed 2 years ago by markk

  • Owner markk deleted
  • Status changed from accepted to assigned

comment:11 Changed 2 years ago by danielk

  • Owner set to danielk

comment:12 Changed 2 years ago by Github

  • Resolution set to fixed
  • Status changed from assigned to closed

Fixes #9233. Refs #7408. Re-enables WindowResized?().

We traded a one small bug for two others just prior to 0.24.

Branch: master
Changeset: 47d7c773e98ef2945667ddf9119d4be446e07bf8

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'new'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.