Modify
Warning Please read the Ticket HowTo before creating or commenting on a ticket. Failure to do so may cause your ticket to be rejected or result in a slower response.

Opened 3 years ago

Closed 20 months ago

#9261 closed Bug Report - Hang/Deadlock (Need more Info)

[HANG] Mythbackend hangs after upgrade to 0.24-fixes when try to start recording

Reported by: ernst.reiter@… Owned by: stuartm
Priority: critical Milestone: 0.26
Component: MythTV - EIT Version: 0.24-fixes
Severity: low Keywords:
Cc: Ticket locked: no

Description

After the upgrade to 0.24 when tring to start a recording, mythbackend stops responding. Backtrace and log is attached.

Attachments (2)

gdb.txt (63.7 KB) - added by ernst.reiter@… 3 years ago.
myth.log (4.3 KB) - added by ernst.reiter@… 3 years ago.

Download all attachments as: .zip

Change History (13)

Changed 3 years ago by ernst.reiter@…

Changed 3 years ago by ernst.reiter@…

comment:1 Changed 3 years ago by robertm

  • Status changed from new to assigned

comment:2 Changed 3 years ago by danielk

  • Component changed from MythTV - Recording to MythTV - EIT
  • Owner danielk deleted
  • Priority changed from major to minor
  • Severity changed from medium to low
  • Status changed from assigned to new

This appears to be caused by a dead lock in the EIT shutdown code.

comment:3 Changed 3 years ago by kenni

  • Milestone set to unknown
  • Owner set to stuarta
  • Status changed from new to assigned

comment:4 Changed 3 years ago by jrauti@…

I have same problem with my system and I can see same deadlock with EITScanner::lock on my gdb backtrace. Is it possible that EITScanner::RunEventLoop?() manages to monopolise lock so that EITScanner::StopPassiveScan? can't get lock? This link http://stackoverflow.com/questions/2121200/qmutex-stuck-in-locked-state suggests that it is possible scenario. Most of the RunEventLoop?() runs with lock activated most it's time especially when activeScan==false.
One fact that speaks also for this is that I can do controlled shutdown for backend in couple seconds so it's deadlock that can be resolved. Could solution be that RunEventLoop?() is chanced so that it does sched_yield (or sleeps) when activeScan==false?

comment:5 Changed 3 years ago by beirdo

  • Summary changed from Mythbackend hangs after upgrade to 0.24-fixes when try to start recording to [HANG] Mythbackend hangs after upgrade to 0.24-fixes when try to start recording

comment:6 Changed 3 years ago by beirdo

#9583 may be a dupe of this.

comment:7 Changed 2 years ago by stuartm

  • Milestone changed from unknown to 0.25
  • Owner changed from stuarta to stuartm
  • Priority changed from minor to critical
  • Status changed from assigned to accepted
  • Type changed from Bug Report to Bug Report - Hang/Deadlock

I'll take this, although I might be asking for input from Stuart A or Daniel

comment:8 Changed 2 years ago by beirdo

  • Status changed from accepted to infoneeded

Is this repeatable with 0.25-rc? If not, let's close this as it is a report against a fairly old version of 0.24, and we have made a year's worth of changes since.

comment:9 Changed 2 years ago by stuartm

  • Milestone changed from 0.25 to 0.25.1

comment:10 Changed 20 months ago by wagnerrp

  • Milestone changed from 0.25.1 to 0.26

comment:11 Changed 20 months ago by stuartm

  • Resolution set to Need more Info
  • Status changed from infoneeded to closed

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'new'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.