Opened 9 years ago

Closed 9 years ago

Last modified 8 years ago

#9270 closed Bug Report (Upstream Bug)

Hauppauge HVR-4000 DVB-T Channel scanning/tuning broken

Reported by: jamatik@… Owned by: Janne Grunau
Priority: major Milestone: unknown
Component: MythTV - DVB Version: Unspecified
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Since I know mythtv, it isn't possible to scan (or tune) DVB-T (cannot test DVB-S/2) Channels without a little hack on any mythtv-version and any kernel-version with the Hauppauge HVR-4000. No matter what Tuning-Delays I setup in mythtv-setup for this tv-card. (I'm currently using the newest firmware) http://linuxtv.org/wiki/index.php/Hauppauge_WinTV-HVR-4000

It's not the best way, but at least I can even use MythTV. I always must patch the current version of dvbchannel.cpp like in this forum post http://www.mythtvtalk.com/hvr-4000-fails-scan-11318/ I don't know the reason but with this big delay it works in mythtv. But the tuning delay on channel change is not noticeable. Strange since most other programms like dvbscan, xine are working out of the box.

I'm not sure if it's only mythtv, but the DVB Kernel-driver seems to work well. I have no problem using dvbscan to scan channels or "xine dvb://" to watch TV. Using DVB-T.

Change History (5)

comment:1 Changed 9 years ago by stuartm

Resolution: Upstream Bug
Status: newclosed

I'll check with Devin when I next see him, but he's quoted in that forum thread as saying that it's a driver bug and he should know, he's a DVB driver developer.

I'm closing as an upstream bug, not a bug in MythTV.

comment:2 Changed 9 years ago by vezza@…

Hi! I am affected by the same problem, any hope that the upstream bug will be fixed? Does there is a bug tracking system for this kind of problems? thanks...

comment:3 Changed 9 years ago by robertm

Ticket locked: set

comment:4 Changed 8 years ago by Raymond Wagner

Ticket locked: unset

comment:5 Changed 8 years ago by dheitmueller@…

djh - note a patch has been submitted to the LinuxTV mailing list for this issue:

http://www.mail-archive.com/linux-media@vger.kernel.org/msg34010.html

The bug being tracked in Launchpad as the following:

https://bugs.launchpad.net/mythtv/+bug/439163/

But, as stuartm made clear in his comment, this was a kernel issue and not a MythTV bug.

Note: See TracTickets for help on using tickets.