Modify
Warning Please read the Ticket HowTo before creating or commenting on a ticket. Failure to do so may cause your ticket to be rejected or result in a slower response.

Opened 3 years ago

Closed 2 years ago

Last modified 2 years ago

#9305 closed Bug Report (Fixed)

Pause / Play after fast forward causes movie to restart

Reported by: salstrom@… Owned by: markk
Priority: minor Milestone:
Component: MythTV - DVD Playback Version: 0.24-fixes
Severity: medium Keywords: DVD Playback fast forward
Cc: Ticket locked: no

Description (last modified by wagnerrp)

While watching a movie using the Internal Player using the Fast Forward (any speed) then pressing Pause / Play causes the movie to start over at the beginning.

I have experienced this with .iso files on Storage Groups and not using Storage Groups as well as with DVD's in the local drive.

Attachments (3)

Dragon_tattoo.txt (70.6 KB) - added by anonymous 3 years ago.
surfs_up.txt (121.7 KB) - added by anonymous 3 years ago.
version_info (634 bytes) - added by wagnerrp 3 years ago.

Download all attachments as: .zip

Change History (15)

comment:1 Changed 3 years ago by markk

  • Milestone changed from unknown to 0.25
  • Status changed from new to accepted
  • Version changed from Unspecified to 0.24-fixes

comment:2 Changed 3 years ago by markk

  • Status changed from accepted to infoneeded

I cannot reproduce this here with various dvds.

Please attach the full output of mythfrontend -v playback

Changed 3 years ago by anonymous

Changed 3 years ago by anonymous

comment:3 Changed 3 years ago by salstrom@…

I've attached two files. Dragon_tattoo.txt is the log from playing the DVD disk of Region 1 (Netflix) The Girl With the Dragon Tattoo. I skipped to Chapter 4 then used Fast Forward 3x. Then pressed "Pause" to stop the fast forward then "Play". It started the movie from the beginning.

surfs_up.txt is the Region 1 movie Surf's Up which was ripped as a .iso. This was started from the beginning. Same as above, FF 3x then Pause / Play. The movie restarted.

Someone on the mythtv-users list said they had the same issue with all the movies they tried as well.

comment:4 follow-up: Changed 3 years ago by markk

  • Status changed from infoneeded to assigned

OK - I can re-create it here (missed the Pause bit). Looks like libdvdnav is seeking back to the start when you pause (but doesn't when pausing from normal playback).

As a temporary workaround, if you press enter (or whatever is correct on your remote) to exit fast forward (rather than pause then play) that you should find it works as expected.

comment:5 Changed 3 years ago by markk

  • Status changed from assigned to accepted

comment:6 in reply to: ↑ 4 Changed 3 years ago by salstrom@…

Replying to markk:

OK - I can re-create it here (missed the Pause bit). Looks like libdvdnav is seeking back to the start when you pause (but doesn't when pausing from normal playback).

As a temporary workaround, if you press enter (or whatever is correct on your remote) to exit fast forward (rather than pause then play) that you should find it works as expected.

Great... Good to see you were able to track it down. If you end up making a 0.24-fixes patch to it I'd be happy to test it. Thanks for your work!!!

comment:7 Changed 3 years ago by markk

(In [27397]) Remove an unnecessary player call in the TV class and improve the
logging slightly. Refs #9305

comment:8 Changed 3 years ago by wagnerrp

  • Description modified (diff)

Changed 3 years ago by wagnerrp

comment:9 Changed 3 years ago by markk

Ref #9808

comment:10 Changed 2 years ago by Github

Playback: Fix DVD and Blu Ray seeking.

The main problem here was that when paused, the seek position would
fallback to the current speed (i.e. 0) and playback would resume from
the beginning of the title.

With DVD playback, we were also asking the dvdnav object to seek to the
nearest cell - which led to some sizeable search discrepancies depending
where playback was relative to the nearest cell. We now ask for a more
accurate search.

N.B. I also tried to use a relative time search to the nearest cell
followed by a smaller absolute time search (as outline in the dvdnav
api) but this seemed to be even less accurate.

Refs #9305

Branch: master
Changeset: 4b0803be0c0974c1849c297064eeb96bf7817b9b

comment:11 Changed 2 years ago by markk

  • Milestone changed from 0.25 to 0.24.2
  • Resolution set to Fixed
  • Status changed from accepted to closed

Fixed in 088335b4bd8147a1

comment:12 Changed 2 years ago by stuartm

  • Milestone 0.24.2 deleted

Milestone 0.24.2 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'new'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.