Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#9361 closed Bug Report (Fixed)

DTS Passthrough constantly stutters/choppy/laggy on trunk through s/pdif / Optical

Reported by: mitch.capper@… Owned by: JYA
Priority: minor Milestone: 0.25
Component: MythTV - Audio Output Version: Master Head
Severity: medium Keywords: DTS, stutter, SPDIF, Optical
Cc: Ticket locked: no

Description

Problem was first raised in ticket #8839 but was told to open a new ticket on the issue. On two seperate machines with two different sets of hardware (different motherboards, 32vs64 bit, different sound cards and sound chips) when DTS audio is enabled and mythtv is set to use the optical out playback stutters (multiple times a second). Playback without DTS pass through enabled is fine.

The original ticket has some older log files but I have attached the current log file (r27420) on the current machine.

The machine is running kernel 2.6.34 x86_64. The sound card is a Xonar DX and the mythtv audio is set to: ALSA:iec958:CARD=DX,DEV=0

A sample DTS file that causes the issue is at: http://rapidshare.com/files/436402017/test.mkv

I have not found a DTS file it does not happen on, and have tested a half dozen or so.

Attachments (1)

mythfrontend.log (28.1 KB) - added by mitch.capper@… 8 years ago.
recent log under r27420

Download all attachments as: .zip

Change History (10)

Changed 8 years ago by mitch.capper@…

Attachment: mythfrontend.log added

recent log under r27420

comment:1 Changed 8 years ago by mitch.capper@…

Sorry two other additional points: Also playback with mplayer and -afm hwac3 pass through the DTS with no choppiness or lag. Choppiness happens on main receiver and a second receiver of a different brand.

comment:2 Changed 8 years ago by Kenni Lund [kenni a kelu dot dk]

Status: newassigned

comment:3 Changed 8 years ago by myth@…

For what it's worth you are not alone with this issue.

I had the same thing in 0.23 fixes and now with every build of 0.24 I have tried. In 0.23 I wasn't using storage groups, so just used mplayer for mkv files. With 0.24 I have moved to storage groups, but have been able to work around it by unticking the box that says my amp supports DTS. As I'm using an HDMI connection myth just decodes the DTS then sends multi-channel PCM. Not ideal but as it's a usable solution I hadn't spent any more time on it.

Other formats I've tried with DTS in seem to be OK for me, it's just mkv files.

Logs don't suggest any problems, myth seems to think it is streaming the DTS data OK.

In case it helps, the frontend in questions is a diskless Zotac IONITX-A (so VDPAU for all video), 2GB RAM, running 64bit Gentoo. OS is recently updated (with no change in the behaviour above), though I'm still on a 2.6.31 kernel (the hastle I had getting HDMI audio working has put me off updating for the time being) I have recently upgraded the nVidia driver though, which has not changed this behaviour either.

Regards, Graham

comment:4 Changed 8 years ago by JYA

Are you using trunk like the title of this ticket states or 0.24.

If using 0.24 ; try trunk ... backup first

comment:5 Changed 8 years ago by JYA

Status: assignedinfoneeded

Please report if you still have this issue now. The spdif muxer has been completely rewritten from scratch.

comment:6 Changed 8 years ago by mitch.capper@…

This fixed not only my DTS issue of not working but also an audio sync problem i was having, thanks it works great now!

comment:7 Changed 8 years ago by JYA

Excellent. Closing it as fixed.

Fixed in SHA: 649fa85cb41f12860603

comment:8 Changed 8 years ago by JYA

Resolution: Fixed
Status: infoneededclosed

comment:9 Changed 8 years ago by sphery

Milestone: unknown0.25
Note: See TracTickets for help on using tickets.