Opened 9 years ago

Closed 8 years ago

#9396 closed Bug Report - Crash (Unverified)

[CRASH] alsa:bluetooth crashes mythmusic

Reported by: fbeatrous@… Owned by: paulh
Priority: critical Milestone: 0.25
Component: Plugin - MythMusic Version: 0.24-fixes
Severity: medium Keywords: alsa bluetooth
Cc: Ticket locked: no

Description

I have ALSA:bluetooth configured as a bluetooth headset. Attempting to play mp3 music with "Audio output device" set to ALSA:bluetooth causes mythfrontend to exit immediately. The last few lines in the log file are

2010-12-20 12:54:51.403 XMLParse: LoadTheme? using '/usr/local/share/mythtv/themes/default-wide/music-ui.xml' 2010-12-20 12:54:52.010 AO: Opening audio device 'bluetooth' ch 2(2) sr 44100 sf signed 16 bit reenc 0 2010-12-20 12:54:52.010 ALSA, Error: snd_pcm_info_get_card: Operation not permitted 2010-12-20 12:54:52.010 ALSA, Error: Unable to sufficiently increase ALSA hardware buffer size - underruns are likely

HOWEVER: Identical lines appear in the log file when I start playback of a recorded tv program, and, in this case, the recording plays with stereo sound in the bluetooth headset.

Also, I can play music with mplayer using bluetooth audio.

As far as I can tell, the failure is unique to mythmusic.

I should also mention that bluetooth audio worked for me with mythmusic in 0.23.

Attachments (2)

bt.log (954 bytes) - added by fbeatrous@… 9 years ago.
Backtrace after seg fault
gdb.txt (48.2 KB) - added by fbeatrous@… 9 years ago.

Download all attachments as: .zip

Change History (13)

comment:1 Changed 9 years ago by stuartm

Component: Plugin - MythMusicMythTV - Audio Output
Owner: changed from paulh to JYA
Status: newassigned

comment:2 Changed 9 years ago by JYA

Status: assignedinfoneeded

The error showing in the log is normal if your ALSA hardware buffer is set too low (you would have a line telling you what to do to increase it) and has no bearing on audio working or not (just that you will lilely get interruption with buffer under runs)

So please provide a backtrace, because your log doesn't contain any indications on what could be wrong, nor help identifying if the issue is in the myth music plugin, or the core audio framework

Changed 9 years ago by fbeatrous@…

Attachment: bt.log added

Backtrace after seg fault

comment:3 Changed 9 years ago by stuartm

Milestone: unknown0.25
Status: infoneededassigned

comment:4 Changed 9 years ago by beirdo

Summary: alsa:bluetooth crashes mythmusic[CRASH] alsa:bluetooth crashes mythmusic

comment:5 Changed 9 years ago by JYA

Status: assignedinfoneeded

Please try with the latest version of mythtv. MythMusic could incorrectly call the audio framework. Even if audio initialisation failed, mythmusic would happily use it.

Added some work-around code so even if mythmusic is doing the wrong thing, it won't crash.

Changed 9 years ago by fbeatrous@…

Attachment: gdb.txt added

comment:6 Changed 9 years ago by fbeatrous@…

Just tried with the latest 0.24 fixes (v0.24-196-g4af46b1), with the same result as before: Bluetooth audio works with playback of recorded tv, but mythmusic crashes when I attempt to use bluetooth.

A backtrace is attached.

comment:7 Changed 9 years ago by JYA

Latest version of mythtv isn't 0.24, but in trunk/master

comment:8 Changed 9 years ago by JYA

Owner: changed from JYA to paulh

The crash is in: avfDecoder::initialize (this=0x98f9f08) at avfdecoder.cpp:215

comment:9 Changed 9 years ago by robertm

Status: infoneededassigned

comment:10 Changed 8 years ago by stuartm

Component: MythTV - Audio OutputPlugin - MythMusic
Priority: minorcritical
Type: Bug ReportBug Report - Crash

comment:11 Changed 8 years ago by paulh

Resolution: Unverified
Status: assignedclosed

A lot has changed since this ticket was opened and to my knowledge this is the only report of problems of this kind. Please try 0.25 and reopen if it's still a problem.

Note: See TracTickets for help on using tickets.