Modify
Warning Please read the Ticket HowTo before creating or commenting on a ticket. Failure to do so may cause your ticket to be rejected or result in a slower response.

Opened 3 years ago

Closed 10 months ago

Last modified 10 months ago

#9429 closed Bug Report - General (fixed)

No DVD subtitles (LOTR SEE DVD disk 1)

Reported by: otto@… Owned by: natanojl
Priority: minor Milestone: 0.27
Component: MythTV - DVD Playback Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

LOTR SEE disk 1 does not show Finnish subtitles. I've attached -v playback log where disk is started from the beginning (with no visible subs). Then subtitles are manually re-selected using OSD menu, but that does not help either.

Attachments (4)

frontend-version.txt (637 bytes) - added by otto@… 3 years ago.
lotr-see-disk1-no-subtitles.log (163.6 KB) - added by otto@… 3 years ago.
subtitle_menu.patch (3.1 KB) - added by natanojl 23 months ago.
Only use subtitle tracks reported by dvdnav
0001-Filter-and-sort-DVD-subtitle-tracks-so-that-only-the.patch (9.8 KB) - added by peper03@… 11 months ago.

Download all attachments as: .zip

Change History (20)

Changed 3 years ago by otto@…

Changed 3 years ago by otto@…

comment:1 Changed 3 years ago by kenni

  • Status changed from new to assigned

comment:2 Changed 2 years ago by markk

  • Milestone changed from unknown to 0.25
  • Status changed from assigned to accepted

comment:3 Changed 2 years ago by markk

  • Owner markk deleted
  • Status changed from accepted to assigned

comment:4 Changed 2 years ago by beirdo

  • Milestone changed from 0.25 to unknown

comment:5 follow-up: Changed 2 years ago by stuartm

Otto, is this still an issue? Which version, theatrical or extended? I have the theatrical version on Region 2 DVD but this UK version only includes English subtitles and I can't reproduce.

comment:6 Changed 2 years ago by stuartm

  • Status changed from assigned to infoneeded

comment:7 Changed 2 years ago by stuartm

  • Type changed from Bug Report to Bug Report - General

comment:8 in reply to: ↑ 5 Changed 2 years ago by otto@…

Replying to stuartm:

Otto, is this still an issue? Which version, theatrical or extended? I have the theatrical version on Region 2 DVD but this UK version only includes English subtitles and I can't reproduce.

Unfortunately I can test this next time after a month or so. Version is extended edition for Nordic countries, having Finnish, Swedish etc. subtitles.

comment:9 follow-up: Changed 2 years ago by stichnot

  • Owner set to stichnot

Otto, or anyone else in possession of this DVD: It would be extremely helpful if you could use a DVD authoring tool to extract the problematic title into a separate .iso file, with all subtitle and audio tracks intact, upload a 50-100MB excerpt somewhere, and provide a link.

Also, I note that on line 2183 of the log file:

2011-01-03 20:24:47.599 Subtitles: Display AV sub for 3834 ms

It looks like one subtitle was actually displayed, but then no more. Is that correct? Was it a valid Finnish subtitle?

comment:10 in reply to: ↑ 9 Changed 2 years ago by otto@…

Otto, or anyone else in possession of this DVD: It would be extremely helpful if you could use a DVD authoring tool to extract the problematic title into a separate .iso file, with all subtitle and audio tracks intact, upload a 50-100MB excerpt somewhere, and provide a link.

Also, I note that on line 2183 of the log file:

2011-01-03 20:24:47.599 Subtitles: Display AV sub for 3834 ms

It looks like one subtitle was actually displayed, but then no more. Is that correct? Was it a valid Finnish subtitle?

I'm able to check this out after two weeks or so.

comment:11 Changed 23 months ago by stichnot

Otto, a gentle reminder that I need a sample. Thanks.

Changed 23 months ago by natanojl

Only use subtitle tracks reported by dvdnav

comment:12 Changed 23 months ago by natanojl

Can you try the attached patch (for master) and see if it helps with the language selection from the OSD menu?

comment:13 Changed 15 months ago by natanojl

  • Owner changed from stichnot to natanojl

Changed 11 months ago by peper03@…

comment:14 Changed 11 months ago by peper03@…

New patch that builds on natanojl's but also adds subtitle streams that have not yet been physically read (but are known to be mapped) to allow the user to select a subtitle stream without having to miss at least the first packet.
Additionally, the language descriptions should be handled correctly with this patch.

See also LangSPU_16x9.iso in stuartm's repository.

comment:15 Changed 10 months ago by Richard <peper03@…>

  • Resolution set to fixed
  • Status changed from infoneeded to closed

In d7fe81b6b309941c0f3ad35b4ddefb827a2d08d0/mythtv:

Filter and sort DVD subtitle tracks so that only the tracks mapped into the current program chain are shown.

This patch also adds the subtitle streams that are mapped but have not yet been
physically read. This allows the user to select the language without having to
wait for the first subtitle packet (and therefore miss it).

Fixes #9429

Signed-off-by: Jonatan Lindblad <jlindblad@…>

comment:16 Changed 10 months ago by natanojl

  • Milestone changed from unknown to 0.27

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'new'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.