Opened 9 years ago

Closed 7 years ago

#9481 closed Bug Report (fixed)

Mythmusic CD ripping follows strict order

Reported by: stuartm Owned by: stuartm
Priority: critical Milestone: 0.25
Component: Plugin - MythMusic Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

When inserting a CD we first check whether any of the tracks have already been ripped, if the answer is yes we prompt the user to either ignore these tracks or to remove them from the database. (The latter may then involve re-ripping everything)

If the user chooses to ignore tracks on the CD which already exist in the database then we only display the remaining tracks in the track selection dialog. The problem is that the CD ripping code still counts from zero, if we try to rip the first track in the list (say #4) it still rips the first track on the CD - the wrong track with the right metadata. The same mistake then applies to all the remaining tracks.

It makes more sense to show the entire list of tracks in the track selection, only with duplicate tracks disabled by default and maybe some sort of statetype to indicate that they've been disabled because they already exist on the filesystem. This might remove the need for the interactive dialog entirely ...

Change History (5)

comment:1 Changed 9 years ago by stuartm

Status: newaccepted

comment:2 Changed 8 years ago by stuartm

Priority: minorcritical

comment:3 Changed 8 years ago by stuartm

Milestone: 0.24.10.24.2

comment:4 Changed 7 years ago by stuartm

Milestone: 0.24.20.25

comment:5 Changed 7 years ago by Github

Resolution: fixed
Status: acceptedclosed

Replace old ui dialogs with mythui ones and fix a bug with disabled tracks. Fixes #9481

Branch: master Changeset: 6ce2585ca7e05bb90e12859c7c73400b36948cfc

Note: See TracTickets for help on using tickets.