Opened 9 years ago

Closed 9 years ago

#9493 closed Patch - Feature (Duplicate)

New build/packager script

Reported by: Lawrence Rust <lvr@…> Owned by:
Priority: minor Milestone: unknown
Component: Packaging Version: Master Head
Severity: medium Keywords: cross-compile build debug
Cc: Ticket locked: no

Description

The attached script will build MythTV and all dependent libraries in one of 3 ways:

  • Cross compile from Linux to Windows
  • Compile on Windows using the MSys environment
  • Compile on Linux

The Windows builds produce a runtime installation and a self extracting installer that will run on Windows 2k and later.

The script will also produce debug or release builds and can simply switch between Myth branch tags.

It is my hope that the devs at MythTV will incorporate this script into standard builds so that:

  • Windows builds are less frequently broken
  • Windows versions are more frequently tested, especially now that it runs with wine.
  • All testing is done with debug builds of all dependent libraries, especially Qt and mysql where extensive runtime assertion tests are included.

Attachments (1)

mythbuild-110118.zip (14.5 KB) - added by Lawrence Rust <lvr@…> 9 years ago.

Download all attachments as: .zip

Change History (3)

Changed 9 years ago by Lawrence Rust <lvr@…>

Attachment: mythbuild-110118.zip added

comment:1 Changed 9 years ago by beirdo

Once the scripts no longer need custom patching, we will likely see this checked into the packaging repository, at least for Windows building.

comment:2 Changed 9 years ago by beirdo

Resolution: Duplicate
Status: newclosed

This seems to be a dupe of #9374. I will make a back link to this ticket there.

Note: See TracTickets for help on using tickets.