Opened 9 years ago

Closed 9 years ago

#9504 closed Bug Report (Invalid)

FTA EPG not displayed for one channel only

Reported by: 0123peter@… Owned by: Stuart Auchterlonie
Priority: minor Milestone: unknown
Component: MythTV - EIT Version: 0.24
Severity: medium Keywords: fta epg missing c31
Cc: Ticket locked: no

Description

Here in Melbourne Australia there are six free to air dvb-t stations. MythTV displays free to air electronic program data for all channels - except one. The exception is Community Television (CH31, actually broadcast on physical channel 32, I think). I know that the data is there because my parents' set top box displays it. The people who run C31 seem to be mostly new to the game and not too sure of what they are doing, so it is very possible that there is something wrong with their epg data, but I am sure that MythTV could handle C31's problems more gracefully than just ignoring them.

The signal strength seems reasonable. Picture quality is good. I have tried adding a 125kHz offset, which helps for channels 9 and 28.

Change History (9)

comment:1 Changed 9 years ago by sphery

Component: MythTV - GeneralMythTV - EIT
Owner: set to Stuart Auchterlonie

comment:2 Changed 9 years ago by Stuart Auchterlonie

Status: newinfoneeded_new

It's most likely incorrectly signalled by the broadcaster.

If you go into the channel in mythtv-setup you can check and see if "Enable EIT" (i think that's what it's labelled) is ticked or not.

If it's not, and you configured the channel using mythtv-setup's channel scanner, then the broadcaster is incorrectly signalling it.

You can manually tick that checkbox and it'll use the EIT if it is there. Please let us know if this is the issue.

Stuart

comment:3 Changed 9 years ago by Peter D. <0123peter@…>

mythtv-setup

  1. Channel Editor

down to C31 <return>

video source? That has always been set to "eit".

Use on air guide XMLTV? That is now checked. What goes in the "ID" field?

Have I missed something obvious?

MythTV is now refusing to play live TV. I have my suspicions about one of my tuner cards. I will remove it and try again.

The version that I am using is from, mythtv-setup-0.24-27162.2plf2010.1.x86_64.rpm

I don't think that I have really answered your question, but if I were sure would I be expected to remove the "need info" flag? Or is that a developer only thing?

comment:4 in reply to:  3 Changed 9 years ago by Stuart Auchterlonie

Replying to Peter D. <0123peter@…>:

mythtv-setup

  1. Channel Editor

down to C31 <return>

video source? That has always been set to "eit".

Good!

Use on air guide XMLTV? That is now checked. What goes in the "ID" field?

Use on air guide = EIT data. If that was unticked before that confirms my suspicion.

XMLTV ID is used by the various xmltv grabbers to link the data they get with the channel. This is unused by the EIT scanner.

Have I missed something obvious?

nope. you've done exactly what you needed to. Once you sort out your tuner you should find that you have EIT data for that channel...

Don't worry about changing the flags on the ticket. That's for me to do.

Stuart

comment:5 Changed 9 years ago by Peter D. <0123peter@…>

This has been partly solved - or more accurately - one question has been answered and another problem uncovered. Possibly this ticket should be closed and another one opened. This is my first ticket with MythTV, I don't know what the standard behavior is here.

I think that the tuner card issue was that one of the cards was more sensitive to the 125 kHz offset problem than the other, but I adjusted the frequency and removed one of the tuners.

Ticking the "Use on air guide XMLTV" does result in the EPG guide being populated for that channel. BUT there seems to be something *wrong* with that data. The TV guide looks fine, programs are recorded, but information about recording is not displayed.

Attempting to mark any program from *any* channel gives no visible change on the TV guide. Also the list of pending recordings is empty and the list of recorded programs is empty - even though the files exist and can be viewed with Kaffeine.

Things were partly restored to normality after I removed C31 from the list of visible channels.

Thank you

comment:6 Changed 9 years ago by Peter D. <0123peter@…>

After "cleaning out" tuners, sources and connections the re-configured system is still "odd".

comment:7 Changed 9 years ago by Peter D. <0123peter@…>

A web search suggested that C31 is using local time rather than GMT in their FTA EPG data. Things seem to be OK with a minus 11 hour adjustment (+10 time zone plus daylight saving here).

Could MythTV be expected to note a difference in time zones between stations and offer a _presumed_ time off in the configuration? This situation must exist even with correctly configured TV stations when the receiver is on a time zone boundary.

comment:8 Changed 9 years ago by Peter D. <0123peter@…>

Correction; everything was fine *until* I tried to record a program from the broken epg.

The original title of this bug report does not reflect what is failing. I can't see any way to change the title. Unless someone tells me otherwise, I will wait a couple of days, close this bug report, and open a new one that better describes what is wrong. Perhaps, "MythTV chokes on broken FTA EPG data. (Timezone problem?)"

comment:9 Changed 9 years ago by robertm

Resolution: Invalid
Status: infoneeded_newclosed

Original issue solved, piggyback issue should be in a different ticket.

Note: See TracTickets for help on using tickets.