Opened 10 years ago

Closed 6 years ago

#9506 closed Bug Report - General (Fixed)

UPNP Browse/BrowseFlag=BrowseMetadata returns incorrect data.

Reported by: support@… Owned by: stuartm
Priority: minor Milestone: 0.28
Component: MythTV - UPnP Version: 0.23.1
Severity: medium Keywords: DLNA UPnP Browse BrowseMetaData
Cc: Ticket locked: no

Description

When executing the UPNP command Browse, with the BrowseFlag? parameter set to "BrowseMetadata?", and the ObjectID set to the ID of track, MythTV returns metadata for the parent container, instead of the object itself.

I'm the author of 2player -- and Android UPnP Diigital Media Controller. I'm reporting by proxy for a user of my product, based on examinging debug logs. The issue occurs in 0.22, and 0.23.1. It may or may not have been corrected in 0.24, but I have no easy way to test. Sorry.

To reproduce the issue, load 2player (http://two-play.com/2player.htm) on an Android phone, browse, and play music. 2player issues Browse/BrowseMetadata? commands while setting up to play a track. (Performance on Windows 7 Media Center is dramatically improved if res metadata is not requested when generating browse lists, so 2player request the track metadata as required).

Any questions, please contact me via address provided in the reporter field.

Change History (7)

comment:1 Changed 10 years ago by rerdavies@…

Sorry. Re-reading, I didn't provide concrete repro steps.

Load 2player (http://two-play.com/2player.htm) on an Android phone. Select MythTV as a source device, and play either to the local device or a DMR of your choice. Navigate through the selection menus to select a track. Press to play. 2player reports "Incorrect device response: Invalid DIDL response." (The cause of the message: 2player has requested metadata on the track, and MythTV returns DIDL with no res elements (because it contains the DIDL for the parent container -- an album -- which has no res metadata).

You can also repro with Intel UPnP Developer tools, by issueing a Browse UPnP command, with the objectID of a track, and the BrowseFlag? parameter set to "BrowseMetadata?".

comment:2 Changed 9 years ago by stuartm

Milestone: unknown0.25
Type: Bug ReportBug Report - General

comment:3 Changed 9 years ago by beirdo

Milestone: 0.25unknown

comment:4 Changed 6 years ago by stuartm

Owner: changed from dblain to stuartm
Status: newassigned

comment:5 Changed 6 years ago by stuartm

Milestone: unknown0.28
Status: assignedaccepted

comment:6 Changed 6 years ago by stuartm

The given example is now fixed but I need to check that the fixes work for all containers and items which may take me some time as there are no good upnp debugging tools for linux and very few software clients use BrowseMetadata?.

comment:7 Changed 6 years ago by stuartm

Resolution: Fixed
Status: acceptedclosed
Note: See TracTickets for help on using tickets.