Opened 9 years ago

Closed 8 years ago

#9550 closed Bug Report - Crash (Works for me)

[CRASH] Segfault when listening to music

Reported by: Wendy Seltzer <wendy@…> Owned by: paulh
Priority: blocker Milestone: 0.25
Component: Plugin - MythMusic Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Mythfrontend has been crashing regularly after a period of listening to music. My setup has frontend and backend on different machines, both running the same git checkout.

To reproduce: Start mythfrontend, play music from a long playlist or smart playlist. After some time (sometimes minutes, more often hours), it crashes.

Attachments (3)

mythversion (851 bytes) - added by Wendy Seltzer <wendy@…> 9 years ago.
segfault.txt (28.6 KB) - added by Wendy Seltzer <wendy@…> 9 years ago.
gdb log
segfault-2 (16.6 KB) - added by Wendy Seltzer <wendy@…> 9 years ago.
another gdb log

Download all attachments as: .zip

Change History (9)

Changed 9 years ago by Wendy Seltzer <wendy@…>

Attachment: mythversion added

Changed 9 years ago by Wendy Seltzer <wendy@…>

Attachment: segfault.txt added

gdb log

comment:1 Changed 9 years ago by stuartm

Milestone: unknown0.25
Priority: minorblocker

comment:2 Changed 9 years ago by stuartm

Version: UnspecifiedTrunk Head

Changed 9 years ago by Wendy Seltzer <wendy@…>

Attachment: segfault-2 added

another gdb log

comment:3 Changed 9 years ago by beirdo

Status: newassigned
Summary: Segfault when listening to music[CRASH] Segfault when listening to music

comment:4 Changed 8 years ago by stuartm

Type: Bug ReportBug Report - Crash

comment:5 in reply to:  2 Changed 8 years ago by lorence.dyone@…

Replying to stuartm: nice one

comment:6 Changed 8 years ago by paulh

Resolution: Works for me
Status: assignedclosed

Try updating to current master, I use MythMusic nearly every day and have never seen this crash.

Note: See TracTickets for help on using tickets.