Opened 9 years ago

Closed 9 years ago

#9567 closed Bug Report (Fixed)

Mythfrontend segfaults when I attempt to "Edit Recording Schedule"

Reported by: mrdorozen@… Owned by:
Priority: minor Milestone: 0.24.1
Component: MythTV - User Interface Library Version: 0.24-fixes
Severity: medium Keywords: segfault recording schedule
Cc: Ticket locked: no

Description

When I attempt to choose "Edit Recording Schedule" from the context menu for any recording, MythTV segfaults immediately and dumps me to desktop. Running with the "-v all" option, no message is displayed from the time of the keypress to the dump to desktop. Sometimes, but not always, it says segmentation fault - otherwise the behavior is identical and virtually instant. The same occurs if I try to access it through manage recordings. Scheduling a new recording has the exact same effect, either using the guide or program finder.

The error replicates 100% of the time on both the front and backend machines. Frontend is AMD Sempron 140 w/ HVR-1800 DVB card and Geforce 8200 on board. Backend is AMD Phenom II 3.2 X4 w/ HVR-1800 DVB and PVR-500 analog cards and GT240 video card. (Other machines in the house replicate the error as well).

I have checked the database and repaired/optimized. No signs of errors. I have tried all the available themes without effect. It began after upgrade to 0.24. I'm running Gentoo Linux 64 bit and kernel 2.6.34. Building out of the official MythTV Gentoo repository, most recent stable version. (In Gentoo, that's 0.24_p20110201.) Compile options are plain vanilla -fomit-frame-poiner -O2. Compiler is GCC 4.4.4.

Rebuilt with +debug useflag to get a trace. When run with GDB, it still does not work, but instead freezes up and no longer accepts input at all at the same place (no immediate dump to desktop).

It appears to be a segmentation fault in MythUI-0.24.so.0

Program received signal SIGSEGV, Segmentation fault. 0x00007ffff51f3228 in MythScreenType::SetFocusWidget?(MythUIType*) () from /usr/lib/libmythui-0.24.so.0

I have attached the complete GDB output. Please let me know if anything else would helpful, and thank you in advance for your assistance.

Attachments (3)

gdb.txt (37.0 KB) - added by mrdorozen@… 9 years ago.
GDB output / segfault info
gdb.2.txt (51.7 KB) - added by mrdorozen@… 9 years ago.
Updated gdb output with symbol info - compiled using debug profile
mythfrontend-bugbuddy.txt (51.3 KB) - added by mrdorozen@… 9 years ago.
BugBuddy? automatically generated output when mythfrontend crashes

Download all attachments as: .zip

Change History (10)

Changed 9 years ago by mrdorozen@…

Attachment: gdb.txt added

GDB output / segfault info

comment:1 Changed 9 years ago by sphery

Component: MythTV - GeneralMythTV - User Interface Library
Status: newinfoneeded_new

mrdorozen, can you rebuild your MythTV with debugging symbols (using a --compile-type=profile build should be fine), as described at http://www.mythtv.org/wiki/Debugging and http://www.mythtv.org/wiki/Debugging#Debugging_with_Gentoo_ebuilds , and retrieve another backtrace, please? (If you did build a profile or debug build, please follow instructions at http://www.mythtv.org/wiki/Debugging#Debugging_with_Gentoo_ebuilds, since your ebuild is stripping symbols.) Thanks.

comment:2 Changed 9 years ago by mrdorozen@…

Yeah sorry, I just realized what I did - I stuck "media-tv/mythtv debug" in package.keywords instead of in package.use, hence the lack of symbol info...

Rerunning now, and will reattach shortly.

Matt

comment:3 Changed 9 years ago by mrdorozen@…

Ok, sorry for the delay, had some difficulty getting symbols in there - too many layers protecting me from myself... also had to rebuild all of the related packages like Qt, etc.

For anyone else using Gentoo, note that you need to add nostrip to your features and that the debug flag actually does trigger a -g option in gcc (this isn't how the Gentoo guys want us to use debug).

Anyways, here's the new gdb.txt

Changed 9 years ago by mrdorozen@…

Attachment: gdb.2.txt added

Updated gdb output with symbol info - compiled using debug profile

comment:4 Changed 9 years ago by mrdorozen@…

Also, when I just run it outside of gdb, I still get a crash as before, but now bugbuddy gathers some useful info about the crash, so I'm attaching that too in the hope that it may also be useful. (It duplicates a lot of the info in gdb.txt, but has other stuff too.)

Changed 9 years ago by mrdorozen@…

Attachment: mythfrontend-bugbuddy.txt added

BugBuddy? automatically generated output when mythfrontend crashes

comment:5 Changed 9 years ago by paulh

Probably already fixed in cd0acb0504eda. Try updating to current fixes.

comment:6 Changed 9 years ago by mrdorozen@…

Confirmed fixed for me as of Gentoo snapshot 0.24_p20110211 (maybe earlier).

comment:7 Changed 9 years ago by sphery

Milestone: unknown0.24.1
Resolution: Fixed
Status: infoneeded_newclosed

Thanks for reporting back

Note: See TracTickets for help on using tickets.