Opened 9 years ago

Closed 6 years ago

#9607 closed Bug Report - Crash (Unverified)

mythfrontend SIGSEGV in QBasicAtomicInt::operator!=()

Reported by: Marc Randolph <mrand@…> Owned by:
Priority: blocker Milestone: 0.27
Component: MythTV - Video Library Version: 0.24-fixes
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Just arrowing around in video library. UI hung for a while, then crashed. I see from the log that it appears to have been trying to fire up a video - I probably did hit <enter> (and also arrow keys and <ESC>) while it was frozen... so it must have seen the <enter> and launched whatever movie was highlighted at the time.

Close if this backtrace is not useful.

Attachments (2)

ThreadStacktrace.txt (60.0 KB) - added by Marc Randolph <mrand@…> 9 years ago.
mythfrontend.log (132.4 KB) - added by Marc Randolph <mrand@…> 9 years ago.

Download all attachments as: .zip

Change History (12)

Changed 9 years ago by Marc Randolph <mrand@…>

Attachment: ThreadStacktrace.txt added

Changed 9 years ago by Marc Randolph <mrand@…>

Attachment: mythfrontend.log added

comment:1 Changed 9 years ago by beirdo

Type: Bug Report - GeneralBug Report - Crash

comment:2 Changed 8 years ago by Github

Milestone: unknown0.25
Resolution: fixed
Status: newclosed

NULL protection on a deletion

Fixes #9607

This fixes the crash symptoms, not what could have caused a null child in the first place. The crash was from trying to free NULL.

Branch: master Changeset: a849a0b99f788fe856d5bbc11c0e30056280441c

comment:3 Changed 8 years ago by beirdo

Owner: set to beirdo

comment:4 Changed 8 years ago by danielk

Resolution: fixed
Status: closednew

The crash is happening in m_ChildrenList.begin() not in delete *it;

comment:5 Changed 8 years ago by beirdo

Owner: beirdo deleted
Status: newassigned

comment:6 Changed 8 years ago by beirdo

Component: MythTV - GeneralMythTV - Video Library
Milestone: 0.25unknown
Owner: set to robertm
Status: assignednew

comment:7 Changed 8 years ago by robertm

Owner: robertm deleted
Status: newassigned

comment:8 Changed 8 years ago by Raymond Wagner

Status: assignednew

comment:9 Changed 6 years ago by stuartm

Milestone: unknown0.27
Priority: minorblocker
Status: newinfoneeded_new

Marc, sorry for the lack of attention given to this ticket. I can't easily explain the segfault you saw here and it's a very old report, so much has changed since then. Have you reproduced this since?

comment:10 Changed 6 years ago by stuartm

Resolution: Unverified
Status: infoneeded_newclosed

Backtrace just doesn't tell us enough to fix the underlying issue.

Note: See TracTickets for help on using tickets.