Opened 8 years ago

Closed 6 years ago

#9654 closed Patch - Bug Fix (Works for me)

[PATCH] Fix SEGV faults in mythfrontend during backend selection

Reported by: Lawrence Rust <lvr@…> Owned by: sphery
Priority: minor Milestone: 0.26
Component: MythTV - User Interface Library Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

This patch fixes several segv faults and logic problems with mythfrontend during backend configuration either after a fresh install or by specifying the -p option.

1 Can't select Manual dbase configuration with -p option
2 Can't Cancel
3 Segv after selecting Save on win32
4 Segv in ShowOkPopup? due to stale static data
5 Segv in MythScreenStack::PopScreen? due to null pointer

Attachments (1)

be-select.diff (9.0 KB) - added by Lawrence Rust <lvr@…> 8 years ago.

Download all attachments as: .zip

Change History (10)

Changed 8 years ago by Lawrence Rust <lvr@…>

Attachment: be-select.diff added

comment:1 Changed 8 years ago by stuartm

Are these issues reproducible on other platforms? I can't reproduce any of them.

comment:2 Changed 8 years ago by Lawrence Rust <lvr@…>

All apart from 1 are reproducible on both Linux & Windows. The exception is the seg fault when you select Save caused by a NULL m_XML in BackendSelection::Accept

  1. Start "mythfrontend -p", select language, tab to Manual and click. If your setup conforms to defaults you'll go to the root menu. If you have anything unusual you'll get a dialog - Cannot login.
  2. Start "mythfrontend -p", select language, tab to cancel and click, same result as 1.
  3. Win32 only: Start "mythfrontend -p", select language, tab to Save and click - SEGV
  4. Start "mythfrontend -p", select language, tab to cancel and click - Cannot login. Click cancel again - SEGV

comment:3 Changed 8 years ago by sphery

Owner: changed from stuartm to sphery
Status: newaccepted

comment:4 Changed 8 years ago by paulh

Milestone: unknown0.25

comment:5 Changed 8 years ago by sphery

Ref: f53cc94e8

comment:6 Changed 7 years ago by stuartm

Priority: minorblocker

comment:7 Changed 7 years ago by sphery

Priority: blockerminor

Segfaults have been fixed in master (by the above-referenced changeset and potentially other additional changes). (Though I can't test the win32 segfault, those mentioned as #4 and #5 in original description are fixed.)

comment:8 Changed 7 years ago by beirdo

Milestone: 0.25unknown

All that is pending is:

Segv after selecting Save on win32

comment:9 Changed 6 years ago by stuartm

Milestone: unknown0.26
Resolution: Works for me
Status: acceptedclosed

Code has changed significantly since this ticket was opened, the one remaining issue on win32 may or may not be fixed, but we'd need an updated patch. I'd suggest a new ticket is created if the bug persists.

Note: See TracTickets for help on using tickets.