Modify

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#9658 closed Bug Report - General (Invalid)

Pressing F1 while viewing program info causes hang-like behaviour

Reported by: John Veness <John.Veness.mythtv@…> Owned by:
Priority: minor Milestone: unknown
Component: MythTV - General Version: 0.24-fixes
Severity: medium Keywords:
Cc: Ticket locked: no

Description (last modified by wagnerrp)

Steps to reproduce:

1, Go into Watch Recordings
2, Highlight any recording
3, Press I
4, Press F1

At this point the frontend seems to hang. You cannot scroll the program info window up or down and cannot press Esc to back out. However, a second press of F1 brings it back to life.

$ mythfrontend --version
Please attach all output as a file in bug reports.
MythTV Version   : v0.24-209-g13be9c2
MythTV Branch    : fixes/0.24
Network Protocol : 63
Library API      : 0.24.20101129-1
QT Version       : 4.7.0

Attachments (0)

Change History (2)

comment:1 Changed 7 years ago by paulh

  • Resolution set to Invalid
  • Status changed from new to closed

It's actually working as it should.

The web browser mythui widget needs to know where the key presses should be processed either by myth or by the Qt QWebView browser widget we use behind the scenes. For example if you press 'm' should that open the popup menu or should it enter an 'm' in an edit box on a web page? In order to toggle where key presses get handled there is a TOGGLEINPUT key binding (set to F1 by default) which switches where key presses get handled.

Without it there would be no way to enter many keys like 'm' or 'i' in a search edit on a web page for example because myth would get the key before the web page.

comment:2 Changed 7 years ago by wagnerrp

  • Description modified (diff)

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'new'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.